~ubuntu-branches/ubuntu/precise/xbill/precise

« back to all changes in this revision

Viewing changes to debian/patches/04_fix_ftbfs_as_needed.diff

  • Committer: Charlie Smotherman
  • Date: 2011-08-21 20:18:26 UTC
  • mfrom: (7.1.1 xbill)
  • Revision ID: cjsmo@cableone.net-20110821201826-0rs7awzhd3jq86yd
Tags: 2.1-8ubuntu1
* debian/patches/04_fix_ftbfs_as_needed.diff:
  - fix build with ld --as-needed (LP: #803215)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: fix build with ld --as-needed
 
2
 when building with ld --as-needed libraries must be placed
 
3
 after object files needing them on the command line so the symbols
 
4
 of the libraries are registered as needed.
 
5
Author: Julian Taylor <jtaylor.debian@googlemail.com>
 
6
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/xbill/+bug/803215
 
7
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632528
 
8
 
 
9
Index: xbill-2.1/Makefile.in
 
10
===================================================================
 
11
--- xbill-2.1.orig/Makefile.in  2011-07-03 11:37:04.137365185 +0200
 
12
+++ xbill-2.1/Makefile.in       2011-07-03 11:41:22.957365347 +0200
 
13
@@ -2,7 +2,7 @@
 
14
 CFLAGS = @CFLAGS@
 
15
 CPPFLAGS = @CPPFLAGS@
 
16
 LDFLAGS = @LDFLAGS@
 
17
-LIBS = @LIBS@ @X_LIBS@ @WIDGET_LIBS@ @X_PRE_LIBS@
 
18
+LIBS = @LIBS@ @X_LIBS@ @WIDGET_LIBS@ @X_PRE_LIBS@ -lXpm
 
19
 INSTALL=@INSTALL@
 
20
 INSTALL_DATA=@INSTALL_DATA@
 
21
 MKINSTALLDIRS = $(SHELL) $(top_srcdir)/mkinstalldirs
 
22
@@ -21,7 +21,7 @@
 
23
 VPATH = @srcdir@
 
24
 
 
25
 ALL_CFLAGS =   $(CFLAGS) $(CPPFLAGS) -I$(srcdir)
 
26
-ALL_LDFLAGS =  $(CFLAGS) $(LDFLAGS) -lXpm
 
27
+ALL_LDFLAGS =  $(CFLAGS) $(LDFLAGS)
 
28
 IMAGE_DEFINES=-DIMAGES=\"${datadir}/xbill\"
 
29
 SCORE_DEFINES=-DSCOREFILE=\"${localstatedir}/xbill.scores\"
 
30