~ubuntu-branches/ubuntu/precise/xdm/precise

« back to all changes in this revision

Viewing changes to debian/patches/debian.diff

  • Committer: Bazaar Package Importer
  • Author(s): Artur Rona
  • Date: 2011-01-30 00:53:09 UTC
  • mfrom: (9.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20110130005309-30mjjyk7div7d494
Tags: 1:1.1.10-3ubuntu1
* Merge from debian unstable.  Remaining changes: (LP: #682196)
  - debian/{rules, xdm.install, local/ubuntu*}:
    + Add Ubuntu graphics and configure xdm to use them by default.
  - debian/patches/ubuntu_no_whiteglass.diff: Don't hardcode
    the default Xcursor theme to whiteglass. Use the Ubuntu
    default x-cursor-theme instead.
* debian/patches/ftbfs_binutils-gold.diff: Fix FTBFS with binutils-gold
  and ld --as-needed. (Closes: #556694)
* Dropped changes, no longer applicable:
  - debian/{xdm.postinst.in, xdm.postrm.in, xdm.preinst.in}

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
Ported parts of 905_debian_xdm.diff. Some changes are now done through
6
6
configure flags
7
7
 
8
 
* Use different paths for the auth directory.  This is just an effort to move
9
 
  in the direction of the FHS.
10
8
* config/Xservers.ws.cpp:
11
9
  - add comments to help local admins
12
10
  - run local server with TCP listening turned off for security
15
13
* config/xdm-config.cpp:
16
14
  - Supply a simpler default configuration, so that no matter what X server
17
15
    number is used, people get the same results.
18
 
  - Define a default userPath and systemPath.  Again, this smacks of the FHS
19
 
    (we should be able to drop that part nowadays?).
20
16
 
21
 
Index: xdm/config/Makefile.am
22
 
===================================================================
23
 
--- xdm.orig/config/Makefile.am
24
 
+++ xdm/config/Makefile.am
25
 
@@ -55,7 +55,7 @@
26
 
     -DXDMPIDDIR="$(XDMPIDDIR)" -DXDMCONFIGDIR="$(XDMCONFIGDIR)" \
27
 
     -DXDMSCRIPTDIR="$(XDMSCRIPTDIR)" -DSU="$(SU)" \
28
 
     -DCHOOSERPATH="$(XDMLIBDIR)/chooser" $(XPMDEFINES) \
29
 
-    -DSHELL_CMD="$(SHELL_CMD)" $(MKTEMP_DEFINES)
30
 
+    -DSHELL_CMD="$(SHELL_CMD)" $(MKTEMP_DEFINES) -DXDMAUTHDIR="$(XDMAUTHDIR)"
31
 
 
32
 
 Xservers.ws: $(srcdir)/Xservers.ws.cpp
33
 
        $(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $(srcdir)/Xservers.ws.cpp | $(CPP_SED_MAGIC) > $@
34
17
Index: xdm/config/Xservers.ws.cpp
35
18
===================================================================
36
19
--- xdm.orig/config/Xservers.ws.cpp
37
20
+++ xdm/config/Xservers.ws.cpp
38
 
@@ -10,4 +10,26 @@
 
21
@@ -9,4 +9,26 @@
39
22
 XCOMM look like:
40
23
 XCOMM  XTerminalName:0 foreign
41
24
 XCOMM
43
26
+XCOMM When adding X servers, please keep the following things in mind:
44
27
+XCOMM - If the X server's number is not zero, it must be passed to the X
45
28
+XCOMM   server's command line as its first argument.
46
 
+XCOMM - When using the XFree86 X server, it is wise to add the vtXX
 
29
+XCOMM - When using the Xorg X server, it is wise to add the vtXX
47
30
+XCOMM   option to each local X server, since this is the only sure way
48
31
+XCOMM   of knowing in advance which X server attaches to which virtual
49
32
+XCOMM   console.
55
38
+XCOMM   X servers that do not listen on a TCP port, so you do not need
56
39
+XCOMM   to remove the "-nolisten tcp" option for SSH's benefit.
57
40
+XCOMM - See the Xserver(1) manpage for a description of X server
58
 
+XCOMM   options.  If you are using the XFree86 X server, see the
59
 
+XCOMM   XFree86(1) manpage for a description of options specific to it
 
41
+XCOMM   options.  If you are using the Xorg X server, see the
 
42
+XCOMM   Xorg(1) manpage for a description of options specific to it
60
43
+XCOMM   (such as "-depth").
61
44
+XCOMM
62
45
+XCOMM Examples for multiple local X displays:
67
50
===================================================================
68
51
--- xdm.orig/config/Xsession.cpp
69
52
+++ xdm/config/Xsession.cpp
70
 
@@ -4,84 +4,5 @@
71
 
 XCOMM $Xorg: Xsession,v 1.4 2000/08/17 19:54:17 cpqbld Exp $
72
 
 XCOMM $XFree86: xc/programs/xdm/config/Xsession,v 1.2 1998/01/11 03:48:32 dawes Exp $
 
53
@@ -1,84 +1,5 @@
 
54
 XCOMM!SHELL_CMD
 
55
 XCOMM
73
56
 
74
57
-XCOMM redirect errors to a file in user's home directory if we can
75
58
-
158
141
===================================================================
159
142
--- xdm.orig/config/xdm-config.cpp
160
143
+++ xdm/config/xdm-config.cpp
161
 
@@ -17,22 +17,22 @@
162
 
 DisplayManager.keyFile:                XDMCONFIGDIR/xdm-keys
163
 
 DisplayManager.servers:                XDMCONFIGDIR/Xservers
164
 
 DisplayManager.accessFile:     XDMCONFIGDIR/Xaccess
165
 
+DisplayManager.authDir:        XDMAUTHDIR
 
144
@@ -18,19 +18,16 @@
166
145
 DisplayManager*resources:      XDMCONFIGDIR/Xresources
167
146
 DisplayManager.willing:                SU nobody -c XDMSCRIPTDIR/Xwilling
168
147
 ! All displays should use authorization, but we cannot be sure
182
161
-DisplayManager._0.setup:       XDMSCRIPTDIR/Xsetup_0
183
162
-DisplayManager._0.startup:     XDMSCRIPTDIR/GiveConsole
184
163
-DisplayManager._0.reset:       XDMSCRIPTDIR/TakeConsole
185
 
+DisplayManager*userPath:       /usr/local/bin:/usr/bin:/bin:/usr/games
186
 
+DisplayManager*systemPath:     /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
187
164
 #ifdef XPM
188
165
 DisplayManager*loginmoveInterval:      10
189
166
 #endif /* XPM */
190
 
Index: xdm/configure.ac
191
 
===================================================================
192
 
--- xdm.orig/configure.ac
193
 
+++ xdm/configure.ac
194
 
@@ -221,6 +221,12 @@
195
 
        [XDMSCRIPTDIR="$withval"], [XDMSCRIPTDIR="${XDMLIBDIR}"])
196
 
 AC_SUBST(XDMSCRIPTDIR)
197
 
 
198
 
+AC_ARG_WITH(xdmauthdir,
199
 
+       AC_HELP_STRING([--with-xdmauthdir=<pathname>],
200
 
+         [specify a directory where authentication cookie files should be stored (default is same as xdmconfigdir)]),
201
 
+       [XDMAUTHDIR="$withval"], [XDMAUTHDIR="${XDMCONFIGDIR}"])
202
 
+AC_SUBST(XDMAUTHDIR)
203
 
+
204
 
 AC_ARG_WITH(logdir,
205
 
        AC_HELP_STRING([--with-logdir=<pathname>],
206
 
          [specify directory for xdm log files (default=/var/log)]),
207
 
@@ -526,7 +532,7 @@
208
 
 
209
 
 # -DDEF_AUTH_DIR="$(XDMDIR)"
210
 
 
211
 
-AC_DEFINE_DIR(DEF_AUTH_DIR, XDMCONFIGDIR, 
212
 
+AC_DEFINE_DIR(DEF_AUTH_DIR, XDMAUTHDIR,
213
 
        [Define to pathname where authentication cookie files should be stored])
214
 
 
215
 
 # -DDEF_GREETER_LIB="$(XDMDIR)/libXdmGreet.so"
216
 
Index: xdm/xdm.man.cpp
217
 
===================================================================
218
 
--- xdm.orig/xdm.man.cpp
219
 
+++ xdm/xdm.man.cpp
220
 
@@ -306,7 +306,7 @@
221
 
 This names a directory under which
222
 
 .I xdm
223
 
 stores authorization files while initializing the session.  The
224
 
-default value is \fI XDMDIR.\fP
225
 
+default value is \fI XDMAUTHDIR.\fP
226
 
 Can be overridden for specific displays by
227
 
 DisplayManager.\fIDISPLAY\fP.authFile.
228
 
 .IP \fBDisplayManager.autoRescan\fP
229
 
@@ -1464,7 +1464,7 @@
230
 
 .I BINDIR/xterm
231
 
 the default session program and failsafe client
232
 
 .TP 20
233
 
-.I XDMDIR/A<display>\-<suffix>
234
 
+.I XDMAUTHDIR/authdir/authfiles/A<display>\-<suffix>
235
 
 the default place for authorization files
236
 
 .TP 20
237
 
 .I /tmp/K5C<display>
238
 
Index: xdm/Makefile.am
239
 
===================================================================
240
 
--- xdm.orig/Makefile.am
241
 
+++ xdm/Makefile.am
242
 
@@ -116,6 +116,7 @@
243
 
        -D__xorgversion__="\"$(XORGRELSTRING)\" \"$(XORGMANNAME)\"" \
244
 
        -DCHOOSERPATH=$(xdmlibdir)/chooser -DXDMLOGDIR=$(XDMLOGDIR) \
245
 
        -DXDMDIR=$(XDMCONFIGDIR) -DBINDIR=$(bindir) -DXDMPIDDIR=$(XDMPIDDIR) \
246
 
+       -DXDMAUTHDIR=$(XDMAUTHDIR) \
247
 
        -D__appmansuffix__=$(APP_MAN_SUFFIX) \
248
 
        -D__filemansuffix__=$(FILE_MAN_SUFFIX) \
249
 
        -D__libmansuffix__=$(LIB_MAN_SUFFIX) \