~ubuntu-branches/ubuntu/precise/xorg-server/precise

« back to all changes in this revision

Viewing changes to debian/patches/505_Xi_ensure_replayed_touch_events_have_devices.patch

  • Committer: Package Import Robot
  • Author(s): Timo Aaltonen, Christopher James Halse Rogers, Ricardo Salveti de Araujo, Timo Aaltonen, Bryce Harrington, Chase Douglas
  • Date: 2011-09-09 14:13:07 UTC
  • mfrom: (1.1.45 upstream) (0.11.27 sid)
  • Revision ID: package-import@ubuntu.com-20110909141307-7x9s9j3l5kkren6o
Tags: 2:1.10.4-1ubuntu1
[ Christopher James Halse Rogers ]
* Drop i8xx-disablement patch.  2.6.39 and later kernels contain a patch
  which alledgedly fixes the cache-incoherency problems. (LP: #817814)

[ Ricardo Salveti de Araujo ]
* debian/patches/112_armel-pvr-drv.patch:
  - Include support for the pvr driver available on OMAP 4 (LP: #828494)

[ Timo Aaltonen ]
* Merge from Debian unstable.
  - Fixes Xephyr assert failure in dixGetPrivateAddr (LP: #821090)
* debian/rules: Modify the patch stampdir creation.
* Update patch 500_xi2.1.patch to apply.
* Refresh patches.
* debian/rules: Add PATH for the xvfb-run check, otherwise Xvfb is not found.
* debian/rules: Shift the xvfb-run test to be run later, to ensure that the
  binaries are installed.

[ Bryce Harrington ]
* debian/rules: Add check target invoking xvfb-run to test that it works
* debian/control: Add build dependency on xauth, required by xvfb-run

[ Chase Douglas ]
* Add fixes for touch grab handling, courtesy of Carlos Garnacho
  - 505_Xi_ensure_replayed_touch_events_have_devices.patch
  - 506_Xi_ensure_touch_events_update_currentTime.patch
  - 507_dix_Ensure_touch_events_are_delivered_to_next_client.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From a1535e63935e6453301e54efbc4c13dc11995b40 Mon Sep 17 00:00:00 2001
 
2
From: Carlos Garnacho <carlosg@gnome.org>
 
3
Date: Mon, 5 Sep 2011 17:25:54 +0200
 
4
Subject: [PATCH 1/6] Xi: ensure replayed touch events have the right devices
 
5
 set
 
6
 
 
7
So update the event device/source to the TouchClientPtr ones
 
8
---
 
9
 Xi/exevents.c |    4 ++++
 
10
 1 files changed, 4 insertions(+), 0 deletions(-)
 
11
 
 
12
diff --git a/Xi/exevents.c b/Xi/exevents.c
 
13
index 2f1a066..b8b9129 100644
 
14
--- a/Xi/exevents.c
 
15
+++ b/Xi/exevents.c
 
16
@@ -1625,12 +1625,16 @@ ProcessTouchOwnership(DeviceIntPtr dev, TouchPointInfoPtr ti, uint8_t reason,
 
17
                 Bool ret;
 
18
 
 
19
                 /* Deliver the saved touch begin event. */
 
20
+                ti->begin_event->device_event.deviceid = tc->device->id;
 
21
+                ti->begin_event->device_event.sourceid = tc->source->id;
 
22
                 ret = DeliverOneTouchEvent(tc, ti, ti->begin_event);
 
23
 
 
24
                 /* Deliver all the touch motion events in the ring buffer. */
 
25
                 ev = ti->first_history;
 
26
                 while (ret && ev != ti->next_history)
 
27
                 {
 
28
+                    ev->device_event.deviceid = tc->device->id;
 
29
+                    ev->device_event.sourceid = tc->source->id;
 
30
                     ret = DeliverOneTouchEvent(tc, ti, ev);
 
31
 
 
32
                     if (ev->any.type == ET_TouchEnd)
 
33
-- 
 
34
1.7.5.4
 
35