~ubuntu-branches/ubuntu/precise/xserver-xorg-input-vmmouse/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix-mouse-scrolling.patch

  • Committer: Bazaar Package Importer
  • Author(s): Krzysztof Klimonda
  • Date: 2009-05-22 15:03:55 UTC
  • mfrom: (1.2.5 sid)
  • Revision ID: james.westby@ubuntu.com-20090522150355-r5ozt1torzvjin0d
Tags: 1:12.6.4-1ubuntu1
* Merge from debian unstable.
* New changes:
  - debian/control:
    + Add mdetect (<< 0.5.2.1ubuntu5) to Replaces: for seamless upgrade.
      This change may be removed after we drop Hardy support.
* Fixes bugs:
  - VMWare fusion host + vmmouse driver generates drag events on
    any click (LP: #366521)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#
2
 
# Ubuntu: https://launchpad.net/bugs/326050
3
 
# Upstream: http://cgit.freedesktop.org/xorg/driver/xf86-input-vmmouse/commit/?id=305fd77bdf4a8b241c3155b068acf4147a2f8077
4
 
# Description: Change ZAxisMapping default to match main mouse driver.
5
 
 
6
 
diff --git a/src/vmmouse.c b/src/vmmouse.c
7
 
index beeed87..99daa92 100644
8
 
--- a/src/vmmouse.c
9
 
+++ b/src/vmmouse.c
10
 
@@ -95,7 +95,7 @@
11
 
  */
12
 
 #define VMMOUSE_MAJOR_VERSION 12
13
 
 #define VMMOUSE_MINOR_VERSION 5
14
 
-#define VMMOUSE_PATCHLEVEL 1
15
 
+#define VMMOUSE_PATCHLEVEL 2
16
 
 #define VMMOUSE_DRIVER_VERSION \
17
 
    (VMMOUSE_MAJOR_VERSION * 65536 + VMMOUSE_MINOR_VERSION * 256 + VMMOUSE_PATCHLEVEL)
18
 
 #define VMMOUSE_DRIVER_VERSION_STRING \
19
 
@@ -675,7 +675,7 @@ MouseCommonOptions(InputInfoPtr pInfo)
20
 
    /*
21
 
     * Process option for ZAxisMapping
22
 
     */
23
 
-   s = xf86SetStrOption(pInfo->options, "ZAxisMapping", NULL);
24
 
+   s = xf86SetStrOption(pInfo->options, "ZAxisMapping", "4 5");
25
 
    if (s) {
26
 
       int b1 = 0, b2 = 0, b3 = 0, b4 = 0;
27
 
       char *msg = NULL;
28