~ubuntu-branches/ubuntu/quantal/akonadi/quantal

« back to all changes in this revision

Viewing changes to debian/patches/02_hardcode_debian_mysqld_path.diff

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2011-05-24 21:04:40 UTC
  • mfrom: (1.1.28 upstream) (3.2.4 experimental)
  • Revision ID: james.westby@ubuntu.com-20110524210440-9bg93j5a4h35tqm3
Tags: 1.5.3-1ubuntu1
* Merge from Debian experimental, remaining changes:
  - Use versioned boost build-depends.
  - Add a mysqld-akonadi wrapper script.
  - Add apparmor profile for mysqld-akonadi (usr.sbin.mysqld-akonadi).
  - Make akonadi-backend-mysql depend on mysql-server-core-5.1 and
    mysql-client-core-5.1 instead of mysql-server-core.
  - Bump Breaks/Replaces akonadi-sever version to "<< 1.5.3~".

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/server/CMakeLists.txt
2
 
+++ b/server/CMakeLists.txt
3
 
@@ -1,5 +1,6 @@
4
 
 
5
 
-find_program( MYSQLD_EXECUTABLE mysqld /usr/sbin /usr/local/sbin /usr/libexec /usr/local/libexec /opt/mysql/libexec /usr/mysql/bin )
6
 
+# MySQLd can be found here on Debian systems
7
 
+set( MYSQLD_EXECUTABLE "/usr/sbin/mysqld" CACHE STRING "MySQL Server path" )
8
 
 if( MYSQLD_EXECUTABLE)
9
 
    message( STATUS "MySQL Server found." )
10
 
 else ( MYSQLD_EXECUTABLE )