~ubuntu-branches/ubuntu/quantal/arduino/quantal

« back to all changes in this revision

Viewing changes to debian/patches/mjo_makefile

  • Committer: Package Import Robot
  • Author(s): Scott Howard
  • Date: 2012-01-22 00:55:49 UTC
  • mfrom: (10.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20120122005549-wg60b1vskudwfoca
Tags: 1:1.0+dfsg-5
Updated Arduino.mk and arduino-cli.html in arduino-core for
version 1.0 of IDE (Closes: #654162) Thanks to Antoine Sirinelli.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
 package.
7
7
Origin: other, http://mjo.tc/atelier/2009/02/arduino-cli.html
8
8
 
9
 
--- /dev/null
10
 
+++ b/mjo/README
 
9
Index: arduino/mjo/README
 
10
===================================================================
 
11
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
12
+++ arduino/mjo/README  2012-01-22 00:50:46.246502582 -0500
11
13
@@ -0,0 +1 @@
12
14
+The contents of this directory originate from: http://mjo.tc/atelier/2009/02/arduino-cli.html
13
 
--- /dev/null
14
 
+++ b/mjo/Arduino.mk
 
15
Index: arduino/mjo/Arduino.mk
 
16
===================================================================
 
17
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
18
+++ arduino/mjo/Arduino.mk      2012-01-22 00:50:46.250502582 -0500
15
19
@@ -0,0 +1,394 @@
16
20
+########################################################################
17
21
+#
407
411
+.PHONY:        all clean depends upload raw_upload reset
408
412
+
409
413
+include $(DEP_FILE)
410
 
--- /dev/null
411
 
+++ b/mjo/arduino-cli.html
412
 
@@ -0,0 +1,350 @@
 
414
Index: arduino/mjo/arduino-cli.html
 
415
===================================================================
 
416
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
417
+++ arduino/mjo/arduino-cli.html        2012-01-22 00:54:06.686507347 -0500
 
418
@@ -0,0 +1,354 @@
413
419
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
414
420
+<html xmlns="http://www.w3.org/1999/xhtml">
415
421
+  <head>
479
485
+<p>To this we&#39;ll add a Makefile:</p>
480
486
+
481
487
+<pre><code>ARDUINO_DIR = /Applications/Arduino.app/Contents/Resources/Java 
482
 
+                                            
 
488
+ARDUINO_VARIANT = standard
 
489
+                                           
483
490
+TARGET       = CLItest                            
484
491
+MCU          = atmega168                          
485
492
+F_CPU        = 16000000                           
494
501
+<dl>
495
502
+<dt><span class="caps">ARDUINO</span>_DIR</dt>
496
503
+<dd>Where you installed the Arduino software. On the Mac this has to point deep inside the Arduino installation /Applications.  </dd>
 
504
+<dt><span class="caps">ARDUINO</span>_VARIANT</dt>
 
505
+<dd>Selects the appropriate arduino variant from 
 
506
+/usr/share/arduino/hardware/arduino/variants/$(ARDUINO_VARIANT)</dd>
497
507
+<dt><span class="caps">TARGET</span></dt>
498
508
+<dd>The basename used for the final files. Canonically            this would match the .pde file, but you can choose anything!        </dd>
499
509
+<dt><span class="caps">ARDUINO</span>_LIBS</dt>