~ubuntu-branches/ubuntu/quantal/banshee/quantal-updates

« back to all changes in this revision

Viewing changes to debian/patches/workaround-clideps-winmm.patch

  • Committer: Package Import Robot
  • Author(s): Chow Loong Jin
  • Date: 2012-01-23 23:16:49 UTC
  • mfrom: (6.3.22 experimental)
  • Revision ID: package-import@ubuntu.com-20120123231649-safm1f8eycltcgsf
Tags: 2.3.4.ds-1ubuntu1
* Merge from Debian Experimental, remaining changes:
  + Enable and recommend SoundMenu and Disable NotificationArea by default
  + Disable boo and karma extensions
  + Enable and suggest u1ms
  + Move desktop file for Meego UI to /usr/share/une/applications
  + Change the url for the Amazon store redirector
  + [08dea2c] Revert "Fix invalid cast causing ftbfs with libgpod"
* [b617fe0] Convert Ubuntu-specific patches to gbp-pq patches
* Also fixes Launchpad bugs:
  - Fixes race condition while starting (LP: #766303)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Workaround dh_clideps failing on a broken winmm DllImport
2
 
Author: Chow Loong Jin <hyperair@ubuntu.com>
3
 
Forwarded: not-needed
4
 
Applied-Upstream: no
5
 
Index: banshee/src/Libraries/MusicBrainz/Makefile.am
6
 
===================================================================
7
 
--- banshee.orig/src/Libraries/MusicBrainz/Makefile.am  2011-05-14 18:59:01.846280827 +0800
8
 
+++ banshee/src/Libraries/MusicBrainz/Makefile.am       2011-05-14 19:03:01.195144698 +0800
9
 
@@ -5,7 +5,6 @@
10
 
        MusicBrainz/Artist.cs \
11
 
        MusicBrainz/Disc.cs \
12
 
        MusicBrainz/DiscLinux.cs \
13
 
-       MusicBrainz/DiscWin32.cs \
14
 
        MusicBrainz/Event.cs \
15
 
        MusicBrainz/Label.cs \
16
 
        MusicBrainz/LocalDisc.cs \
17
 
Index: banshee/src/Libraries/MusicBrainz/Makefile.in
18
 
===================================================================
19
 
--- banshee.orig/src/Libraries/MusicBrainz/Makefile.in  2011-05-14 18:59:01.829614239 +0800
20
 
+++ banshee/src/Libraries/MusicBrainz/Makefile.in       2011-05-14 19:03:01.195144698 +0800
21
 
@@ -396,7 +396,6 @@
22
 
        MusicBrainz/Artist.cs \
23
 
        MusicBrainz/Disc.cs \
24
 
        MusicBrainz/DiscLinux.cs \
25
 
-       MusicBrainz/DiscWin32.cs \
26
 
        MusicBrainz/Event.cs \
27
 
        MusicBrainz/Label.cs \
28
 
        MusicBrainz/LocalDisc.cs \
29
 
Index: banshee/src/Libraries/MusicBrainz/MusicBrainz/LocalDisc.cs
30
 
===================================================================
31
 
--- banshee.orig/src/Libraries/MusicBrainz/MusicBrainz/LocalDisc.cs     2011-05-14 19:03:42.338284757 +0800
32
 
+++ banshee/src/Libraries/MusicBrainz/MusicBrainz/LocalDisc.cs  2011-05-14 19:04:07.578166429 +0800
33
 
@@ -141,7 +141,7 @@
34
 
                 //case PlatformID.Win32NT:
35
 
                     //return new DiscWin32NT (device);
36
 
                 default:
37
 
-                    return new DiscWin32 (device);
38
 
+                    return null;
39
 
                 }
40
 
             } catch (Exception exception) {
41
 
                 throw new LocalDiscException (exception);