~ubuntu-branches/ubuntu/quantal/gnome-screenshot/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_unity_no_gnomeshell.patch

  • Committer: Package Import Robot
  • Author(s): Iain Lane
  • Date: 2012-06-04 17:09:33 UTC
  • mfrom: (1.2.4)
  • Revision ID: package-import@ubuntu.com-20120604170933-uqrl91r2eipe1ya4
Tags: 3.5.2-0ubuntu1
* New upstream release (LP: #1008595)
  - Add a --file commandline option
  - Add an --include-pointer commandline option
  - Don't warn if fallback X11 code path is hit
  - Warn if --interactive is combined with --clipboard
  - Rename "whole desktop" to "whole screen"
  - Use GResource for UI files
* Refresh patches 
* debian/control: Increase minimum glib version in line with upstream 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-screenshot-3.3.91/src/screenshot-utils.c
 
1
Index: gnome-screenshot-3.5.2/src/screenshot-utils.c
2
2
===================================================================
3
 
--- gnome-screenshot-3.3.91.orig/src/screenshot-utils.c 2012-03-13 20:49:09.685567403 +0100
4
 
+++ gnome-screenshot-3.3.91/src/screenshot-utils.c      2012-03-13 20:50:03.345570001 +0100
 
3
--- gnome-screenshot-3.5.2.orig/src/screenshot-utils.c  2012-06-04 17:09:44.000000000 +0100
 
4
+++ gnome-screenshot-3.5.2/src/screenshot-utils.c       2012-06-04 17:20:23.326338165 +0100
5
5
@@ -630,6 +630,9 @@
6
6
                                      filename);
7
7
     }
8
8
 
9
9
+  if (!g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "Unity"))
10
 
+    screenshot = screenshot_fallback_get_pixbuf (rectangle);
 
10
+      screenshot = screenshot_fallback_get_pixbuf(rectangle);
11
11
+  else {
12
 
   connection = screenshot_application_get_session_bus ();
 
12
   connection = g_application_get_dbus_connection (g_application_get_default ());
13
13
   g_dbus_connection_call_sync (connection,
14
14
                                "org.gnome.Shell",
15
15
@@ -659,6 +662,7 @@