~ubuntu-branches/ubuntu/quantal/iptables/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0600-makefile_jedi_handwaving.patch

  • Committer: Bazaar Package Importer
  • Author(s): Nicolas Valcárcel Scerpella
  • Date: 2009-05-06 16:35:21 UTC
  • mfrom: (5.1.6 upstream) (2.1.2 lenny)
  • Revision ID: james.westby@ubuntu.com-20090506163521-2hbruo0m33h04wxf
Tags: 1.4.3.2-2ubuntu1
* Merge from debian unstable (LP: #372920), remaining changes:
  - Don't fail to run iptables-save if iptables module isn't loaded.
  - debian/patches/0901-build-libipq_pic.a.patch - Build libipq_pic.a with
    -fPIC. Upstream changed build system and patch modified accordingly.
  - Revert changes between 1.4.1.1-3 and 1.4.1.1-4, thus bringing back
    the howtos.
* Droped unexistent patches from debian/patches/series
* Droped 0903-autoload-module-in-iptables-save.diff, fixed upstream
* Added linuxdoc-tools to Build-Depends
* Modified debian/iptables{,-dev}.install to match DM syntax 
  (removed debian/tmp)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: b/Makefile.am
 
1
Index: iptables-1.4.3.2-2ubuntu1/Makefile.am
2
2
===================================================================
3
 
--- a/Makefile.am       2008-07-12 08:57:59.299247757 -0400
4
 
+++ b/Makefile.am       2008-07-12 08:58:51.541600527 -0400
5
 
@@ -3,7 +3,7 @@
 
3
--- iptables-1.4.3.2-2ubuntu1.orig/Makefile.am  2009-05-06 02:05:21.000000000 -0500
 
4
+++ iptables-1.4.3.2-2ubuntu1/Makefile.am       2009-05-06 02:06:18.000000000 -0500
 
5
@@ -4,7 +4,7 @@
6
6
 AUTOMAKE_OPTIONS = foreign subdir-objects
7
7
 
8
8
 AM_CFLAGS        = ${regular_CFLAGS} -I${top_builddir}/include -I${top_srcdir}/include ${kinclude_CFLAGS}
9
 
-SUBDIRS         := extensions
10
 
+SUBDIRS         := extensions howtos
11
 
 if ENABLE_LIBIPQ
12
 
 SUBDIRS         += libipq
 
9
-SUBDIRS          = extensions
 
10
+SUBDIRS          = extensions howtos
 
11
 if ENABLE_DEVEL
 
12
 SUBDIRS         += include
13
13
 endif
14
 
@@ -102,3 +102,6 @@
15
 
        pushd /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION} && ./autogen.sh && popd;
16
 
        tar -C /tmp -cjf ${PACKAGE_TARNAME}-${PACKAGE_VERSION}.tar.bz2 --owner=root --group=root ${PACKAGE_TARNAME}-${PACKAGE_VERSION}/;
17
 
        rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};
 
14
@@ -123,3 +123,6 @@
 
15
 # Using if..fi avoids an ugly "error (ignored)" message :)
 
16
 install-exec-hook:
 
17
        -if test -z "${DESTDIR}"; then /sbin/ldconfig; fi;
18
18
+
19
 
+check: recursive-check
20
 
+       echo "makefile jedi handwaving"
 
19
+test check:
 
20
+       echo "Are we on the air? Hello, Mom!"