~ubuntu-branches/ubuntu/quantal/libgc/quantal

« back to all changes in this revision

Viewing changes to debian/patches/01-catch-all-linux.diff

  • Committer: Bazaar Package Importer
  • Author(s): Christoph Egger
  • Date: 2011-03-02 13:43:18 UTC
  • mfrom: (1.2.5 upstream) (3.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20110302134318-82ful0us5ce82qe8
Tags: 1:7.1-7
* Add ppc64 symbol file (Closes: #615469)
* Add sh4 symbol file (Closes: #614744)
* Add armhf symbol file
* Add powerpcspe symbol file
* Handle sparc64 the same as sparc
* Clear non-arch symbol file to support building on not yet captured
  architectures
* add -pthread to fix build with --no-add-needed

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
 
 
2
Catch all linux variants.
 
3
 
 
4
 -- Chris Lamb <lamby@debian.org>  Wed, 12 Aug 2009 01:14:45 +0100
 
5
 
 
6
diff -urNad /tmp/bp-build/gc-7.1.orig/configure.ac /tmp/bp-build/gc-7.1/configure.ac
 
7
--- gc-7.1.orig/configure.ac    2009-08-12 01:11:00.000000000 +0100
 
8
+++ gc-7.1/configure.ac 2009-08-12 01:11:40.000000000 +0100
 
9
@@ -80,7 +80,7 @@
 
10
     THREADS=posix
 
11
     THREADDLLIBS=-lpthread
 
12
     case "$host" in
 
13
-     x86-*-linux* | ia64-*-linux* | i586-*-linux* | i686-*-linux* | x86_64-*-linux* | alpha-*-linux*)
 
14
+     *-*-linux*)
 
15
        AC_DEFINE(GC_LINUX_THREADS)
 
16
        AC_DEFINE(_REENTRANT)
 
17
         if test "${enable_parallel_mark}" = yes; then
 
18
@@ -89,10 +89,6 @@
 
19
        AC_DEFINE(THREAD_LOCAL_ALLOC)
 
20
        AC_MSG_WARN("Explict GC_INIT() calls may be required.");
 
21
        ;;
 
22
-     *-*-linux*)
 
23
-       AC_DEFINE(GC_LINUX_THREADS)
 
24
-       AC_DEFINE(_REENTRANT)
 
25
-       ;;
 
26
      *-*-aix*)
 
27
        AC_DEFINE(GC_AIX_THREADS)
 
28
        AC_DEFINE(_REENTRANT)