~ubuntu-branches/ubuntu/quantal/libjpeg6b/quantal-updates

« back to all changes in this revision

Viewing changes to debian/patches/200_crop_man.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Bill Allombert
  • Date: 2010-06-29 13:55:42 UTC
  • mfrom: (4.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20100629135542-u2ux634ovmawtrog
Tags: 6b1-1
* New upstream release
  - libjpeg62 has now versionned symbols.
  - Updated build system that use current libtool.
  - Full source code for the build system.
* debian/copyright: add 6b1 upstream download URL.
* debian/control:
  - libjpeg62-dev: Provides libjpeg-dev since the transition has been
    postponed.
  - Remove now useless dependency on libtool and sharutils
  - Bump Standards-Version to 3.9.0.
* Get rid of dpatch system. Patches were only relevant to libjpeg-progs
  which is not build from this package anymore.
* Move to new source format 3.0 (quilt). Patches applied:
  - use-autotools-dev: Use autotools-dev version of config.sub/.guess.
  - extern_C-jpeglib.h: Wrap jpeglib.h with extern "C" {} if __cplusplus 
    is defined.
* debian/rules:
  - Adjust for new build system and new patch system.
* debian/shlibs: add (>=6b1) to avoid linker warnings with libjpeg6b.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
# DP: Manpage update for jpegtran -crop
4
 
 
5
 
case "$1" in
6
 
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
7
 
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
8
 
    *)
9
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
10
 
        exit 1
11
 
esac
12
 
exit 0
13
 
@DPATCH@
14
 
diff -urNad /home/bill/debian/libjpeg/libjpeg6b-6b/jpegtran.1 libjpeg6b-6b/jpegtran.1
15
 
--- /home/bill/debian/libjpeg/libjpeg6b-6b/jpegtran.1   2003-09-22 18:46:08.000000000 +0200
16
 
+++ libjpeg6b-6b/jpegtran.1     2003-09-22 18:49:06.000000000 +0200
17
 
@@ -131,6 +131,40 @@
18
 
 .B \-rot 180 -trim
19
 
 trims both edges.
20
 
 .PP
21
 
+If you are only interested by perfect transformation, add the
22
 
+.B \-perfect
23
 
+switch:
24
 
+.TP
25
 
+.B \-perfect
26
 
+Fails with an error if the transformation is not perfect. For example
27
 
+you may want to do
28
 
+.TP
29
 
+.B (jpegtran \-rot 90 -perfect foo.jpg || djpeg foo.jpg| pnmflip \-r90 | cjpeg)
30
 
+to do a perfect rotation if available or an approximated one if
31
 
+not.
32
 
+.PP
33
 
+We also offer a lossless-crop option, which discards data outside a given
34
 
+image region but losslessly preserves what is inside.  Like the rotate and
35
 
+flip transforms, lossless crop is restricted by the JPEG format: the upper
36
 
+left corner of the selected region must fall on an iMCU boundary.  If this
37
 
+does not hold for the given crop parameters, we silently move the upper left
38
 
+corner up and/or left to make it so, simultaneously increasing the region
39
 
+dimensions to keep the lower right crop corner unchanged.  (Thus, the
40
 
+output image covers at least the requested region, but may cover more.)
41
 
+
42
 
+Note: 
43
 
+.B \-perfect
44
 
+and
45
 
+.B lossless-crop
46
 
+are enhancements from http://sylvana.net/jpegcrop/ that may not be available on
47
 
+non-Debian systems.
48
 
+
49
 
+The image can be losslessly cropped by giving the switch:
50
 
+.TP
51
 
+.B \-crop WxH+X+Y
52
 
+Crop to a rectangular subarea of width W, height H starting at point X,Y.
53
 
+.PP
54
 
+.PP
55
 
 Another not-strictly-lossless transformation switch is:
56
 
 .TP
57
 
 .B \-grayscale
58
 
@@ -231,7 +265,9 @@
59
 
 .PP
60
 
 The transform options can't transform odd-size images perfectly.  Use
61
 
 .B \-trim
62
 
-if you don't like the results without it.
63
 
+or
64
 
+.B \-perfect
65
 
+if you don't like the results.
66
 
 .PP
67
 
 The entire image is read into memory and then written out again, even in
68
 
 cases where this isn't really necessary.  Expect swapping on large images,