~ubuntu-branches/ubuntu/quantal/libjpeg6b/quantal

« back to all changes in this revision

Viewing changes to debian/patches/extern_C-jpeglib.h

  • Committer: Bazaar Package Importer
  • Author(s): Bill Allombert
  • Date: 2010-06-29 13:55:42 UTC
  • mfrom: (4.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20100629135542-u2ux634ovmawtrog
Tags: 6b1-1
* New upstream release
  - libjpeg62 has now versionned symbols.
  - Updated build system that use current libtool.
  - Full source code for the build system.
* debian/copyright: add 6b1 upstream download URL.
* debian/control:
  - libjpeg62-dev: Provides libjpeg-dev since the transition has been
    postponed.
  - Remove now useless dependency on libtool and sharutils
  - Bump Standards-Version to 3.9.0.
* Get rid of dpatch system. Patches were only relevant to libjpeg-progs
  which is not build from this package anymore.
* Move to new source format 3.0 (quilt). Patches applied:
  - use-autotools-dev: Use autotools-dev version of config.sub/.guess.
  - extern_C-jpeglib.h: Wrap jpeglib.h with extern "C" {} if __cplusplus 
    is defined.
* debian/rules:
  - Adjust for new build system and new patch system.
* debian/shlibs: add (>=6b1) to avoid linker warnings with libjpeg6b.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Wrap jpeglib.h with extern "C" {} if __cplusplus is defined.
 
2
 Wrap jpeglib.h inside extern "C" { ... } if the compiler
 
3
 defines __cplusplus.
 
4
Author: Bill Allombert <ballombe@debian.org>
 
5
Origin: Debian
 
6
Forwarded: not-needed
 
7
Last-Update: 2010-06-03
 
8
Index: libjpeg6b-6b1/jpeglib.h
 
9
===================================================================
 
10
--- libjpeg6b-6b1.orig/jpeglib.h        2010-06-03 19:02:32.000000000 +0200
 
11
+++ libjpeg6b-6b1/jpeglib.h     2010-06-03 19:02:37.000000000 +0200
 
12
@@ -13,6 +13,10 @@
 
13
 #ifndef JPEGLIB_H
 
14
 #define JPEGLIB_H
 
15
 
 
16
+#ifdef __cplusplus
 
17
+extern "C" {
 
18
+#endif
 
19
+
 
20
 /*
 
21
  * First we include the configuration files that record how this
 
22
  * installation of the JPEG library is set up.  jconfig.h can be
 
23
@@ -1093,4 +1097,8 @@
 
24
 #include "jerror.h"            /* fetch error codes too */
 
25
 #endif
 
26
 
 
27
+#ifdef __cplusplus
 
28
+}
 
29
+#endif
 
30
+
 
31
 #endif /* JPEGLIB_H */