~ubuntu-branches/ubuntu/quantal/libmodule-info-perl/quantal

« back to all changes in this revision

Viewing changes to debian/patches/version-comparison.patch

  • Committer: Bazaar Package Importer
  • Author(s): Ansgar Burchardt, gregor herrmann, Ansgar Burchardt, Salvatore Bonaccorso
  • Date: 2010-06-06 21:51:52 UTC
  • Revision ID: james.westby@ubuntu.com-20100606215152-jixscux2upyst0lu
Tags: 0.31-2
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
  field (source stanza); Homepage field (source stanza).
* Set Maintainer to Debian Perl Group.
* Use dist-based URL in debian/watch.
* debian/control: Added: ${misc:Depends} to Depends: field.

[ Ansgar Burchardt ]
* debian/watch: Use extended regexp to match upstream releases.
* Refresh rules for debhelper 7.
* Use Build.PL.
* Use source format 3.0 (quilt).
* Convert debian/copyright to proposed machine-readable format.
* Do not use embedded copy of Test-Simple during build.
* Compare versions as numbers, not as strings in tests.
  + new patch: version-comparison.patch
* Use is_deeply the right way.
  + new patch: is-deeply.patch
* Fix spelling errors.
  + new patch: spelling.patch
* Add missing whatis entry to B::Module::Info.
  + new patch: whatis-entry.patch
* Bump Standards-Version to 3.8.4.
* Add myself to Uploaders.

[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
  perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
  permitted by Debian Policy 3.8.3).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Ansgar Burchardt <ansgar@43-1.org>
 
2
Date: Sun, 06 Jun 2010 21:35:17 +0900
 
3
Origin: vendor
 
4
Subject: Compare versions as numbers, not as strings
 
5
 
 
6
--- libmodule-info-perl.orig/t/n3_version.t
 
7
+++ libmodule-info-perl/t/n3_version.t
 
8
@@ -20,18 +20,18 @@
 
9
 }
 
10
 
 
11
 is( $moo->use_version, 0 );
 
12
-is( $moo->version, '0.12' );
 
13
-is( $boo->version, '1.35', 'proper quoting in complex expression' );
 
14
+is( $moo->version, 0.12 );
 
15
+is( $boo->version, 1.35, 'proper quoting in complex expression' );
 
16
 
 
17
 SKIP: {
 
18
     skip 'version.pm not found', 5 unless $has_version_pm;
 
19
 
 
20
     is( $moo_ver->use_version, 1 );
 
21
     isa_ok( $moo_ver->version, 'version' );
 
22
-    is( $moo_ver->version, '0.120' );
 
23
+    is( $moo_ver->version, 0.120 );
 
24
 
 
25
     isa_ok( $foo_ver->version, 'version' );
 
26
-    is( $foo_ver->version, '7.254' );
 
27
+    is( $foo_ver->version, 7.254 );
 
28
 }
 
29
 
 
30
 SKIP: {