~ubuntu-branches/ubuntu/quantal/libnoise/quantal

« back to all changes in this revision

Viewing changes to debian/patches/fix_ftsbs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Bastian Venthur
  • Date: 2010-02-23 16:54:00 UTC
  • Revision ID: james.westby@ubuntu.com-20100223165400-lzmnyc60526y9o23
Tags: 1.0.0+nmu1
* Non-maintainer upload.
* Fix "FTBFS: undefined reference to `main'". Applied patch by Nobuhiro
  Iwamatsu. (Closes: #526547)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- noise/src/Makefile  2010-02-10 03:28:13.000000000 +0000
 
2
+++ noise/src/Makefile  2010-02-10 03:28:26.000000000 +0000
 
3
@@ -17,7 +17,7 @@
 
4
 
 
5
 # Real build targets
 
6
 libnoise.so.0.3: $(OBJECTS)
 
7
-       $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -shared -Wl,-soname=libnoise.so.0 -o $@ $(OBJECTS:.o=.lo)
 
8
+       $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -Xcompiler -shared -Wl,-soname=libnoise.so.0 -o $@ $(OBJECTS:.o=.lo)
 
9
 
 
10
 libnoise.a: $(OBJECTS)
 
11
        $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o $@ $(OBJECTS)