~ubuntu-branches/ubuntu/quantal/llvm-3.0/quantal

« back to all changes in this revision

Viewing changes to debian/patches/0021-shared-lib-debian.patch

  • Committer: Package Import Robot
  • Author(s): Sylvestre Ledru
  • Date: 2011-11-10 19:30:19 UTC
  • Revision ID: package-import@ubuntu.com-20111110193019-91uxx0q6nzfyxghd
Tags: 3.0~svn143999-1
* New upstream release (based on the svn until the official release is published)
* Patches work from debian/patches:
  - 0003-Debian-version-info-and-bugreport.patch: Refresh.
  - 0008-path-eraseFromDisk.patch: Refresh.
  - 0009-Fix-doclinks.patch: Refresh.
  - 0011-Hurd-fixes.patch: Refresh.
  - 0021-shared-lib-debian.patch: Refresh.
  - 0031-mips-version-script.patch: Refresh.
  - 0004-Pretend-final-release.patch: Remove.
  - 0005-Disable-llvm-stub.patch: Remove.
  - 0019-issue6065.patch: Remove.
  - 0034-kfreebsd.patch: Remove.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- 3.0.orig/tools/llvm-shlib/Makefile  (r�vision 144213)
 
2
+++ 3.0/tools/llvm-shlib/Makefile       (copie de travail)
 
3
@@ -39,6 +39,12 @@
 
4
 LLVMLibsPaths   := $(IncludeInLibLlvm)
 
5
 
 
6
 $(LibName.SO): $(LLVMLibsPaths)
 
7
+       $(Echo) Linking $(BuildMode) $(SharedLibKindMessage) \
 
8
+         $(LIBRARYNAME)$(SHLIBEXT)
 
9
+       $(Verb) $(Link) $(SharedLinkOptions) -o $@ $(ObjectsO) \
 
10
+         $(ProjLibsOptions) $(LLVMLibsOptions) $(LIBS)
 
11
+       mv $(LibName.SO) $(LibName.SO).1
 
12
+       ln -s $(notdir $(LibName.SO)).1 $(LibName.SO)
 
13
 
 
14
 ifeq ($(HOST_OS),Darwin)
 
15
     # set dylib internal version number to llvmCore submission number
 
16
@@ -67,6 +73,7 @@
 
17
     # Include everything from the .a's into the shared library.
 
18
     LLVMLibsOptions := -Wl,--whole-archive $(LLVMLibsOptions) \
 
19
                        -Wl,--no-whole-archive
 
20
+    LLVMLibsOptions += -Wl,--soname=$(notdir $(LibName.SO)).1 -Wl,-Bsymbolic-functions
 
21
 endif
 
22
 
 
23
 ifeq ($(HOST_OS),Linux)