~ubuntu-branches/ubuntu/quantal/lvm2/quantal

« back to all changes in this revision

Viewing changes to debian/patches/libs-cleanup.patch

  • Committer: Steve Langasek
  • Date: 2012-04-14 02:57:53 UTC
  • mfrom: (3.1.22 sid)
  • Revision ID: steve.langasek@canonical.com-20120414025753-ejbdw9c8llik58y9
Merge version 2.02.88-2 from Debian testing

Show diffs side-by-side

added added

removed removed

Lines of Context:
8
8
                LIB_SUFFIX=so
9
9
                DEVMAPPER=yes
10
10
                ODIRECT=yes
11
 
@@ -307,7 +306,7 @@
 
11
@@ -382,7 +381,7 @@
12
12
 AC_MSG_CHECKING(whether to enable readline)
13
13
 AC_ARG_ENABLE([readline],
14
 
   [  --disable-readline      Disable readline support],
15
 
-  [READLINE=$enableval], [READLINE=maybe])
16
 
+  [READLINE=$enableval], [READLINE=yes])
 
14
              AC_HELP_STRING([--disable-readline], [disable readline support]),
 
15
-             READLINE=$enableval, READLINE=maybe)
 
16
+             READLINE=$enableval, READLINE=yes)
17
17
 AC_MSG_RESULT($READLINE)
18
18
 
19
19
 ################################################################################
20
 
@@ -825,20 +824,9 @@
 
20
@@ -972,21 +971,9 @@
21
21
 ################################################################################
22
22
 dnl -- Check for selinux
23
23
 if test x$SELINUX = xyes; then
27
27
-
28
28
-       AC_CHECK_LIB([selinux], [is_selinux_enabled], [
29
29
-               AC_CHECK_HEADERS([selinux/selinux.h],, hard_bailout)
 
30
-               AC_CHECK_HEADERS([selinux/label.h])
30
31
-               AC_DEFINE([HAVE_SELINUX], 1, [Define to 1 to include support for selinux.])
31
32
-               SELINUX_LIBS="-lselinux $SELINUX_LIBS"
32
33
-               SELINUX_PC="libselinux"
41
42
 fi
42
43
 
43
44
 ################################################################################
44
 
@@ -859,49 +847,6 @@
 
45
@@ -1007,49 +994,6 @@
45
46
 AC_CHECK_HEADERS(getopt.h, AC_DEFINE([HAVE_GETOPTLONG], 1, [Define to 1 if getopt_long is available.]))
46
47
 
47
48
 ################################################################################
90
91
-################################################################################
91
92
 dnl -- Internationalisation stuff
92
93
 AC_MSG_CHECKING(whether to enable internationalisation)
93
 
 AC_ARG_ENABLE(nls, [  --enable-nls            Enable Native Language Support],
94
 
@@ -959,7 +904,8 @@
 
94
 AC_ARG_ENABLE(nls,
 
95
@@ -1109,7 +1053,8 @@
95
96
 ################################################################################
96
97
 dnl -- Ensure additional headers required
97
98
 if test x$READLINE = xyes; then
101
102
 fi
102
103
 
103
104
 if test x$CLVMD != xnone; then
104
 
@@ -1163,6 +1109,7 @@
 
105
@@ -1346,6 +1291,7 @@
105
106
 AC_SUBST(SALCK_CFLAGS)
106
107
 AC_SUBST(SALCK_LIBS)
107
108
 AC_SUBST(SELINUX_LIBS)
109
110
 AC_SUBST(SELINUX_PC)
110
111
 AC_SUBST(SNAPSHOTS)
111
112
 AC_SUBST(STATICDIR)
112
 
--- a/tools/Makefile.in
113
 
+++ b/tools/Makefile.in
114
 
@@ -104,8 +104,6 @@
115
 
        LVMLIBS += -ldevmapper-event
116
 
 endif
117
 
 
118
 
-LVMLIBS += -ldevmapper
119
 
-
120
 
 DEFS += -DLVM_SHARED_PATH=\"$(exec_prefix)/sbin/lvm\"
121
 
 
122
 
 CFLOW_LIST = lvmcmdlib.c lvm2cmd.c
123
 
@@ -114,17 +112,17 @@
124
 
 
125
 
 include $(top_builddir)/make.tmpl
126
 
 
127
 
-LIBS += $(UDEV_LIBS)
128
 
+LIBS += -ldevmapper $(UDEV_LIBS)
129
 
 
130
 
 device-mapper: $(TARGETS_DM)
131
 
 
132
 
 dmsetup: dmsetup.o $(top_builddir)/libdm/libdevmapper.$(LIB_SUFFIX)
133
 
        $(CC) $(CFLAGS) $(LDFLAGS) -L$(top_builddir)/libdm \
134
 
-             -o $@ dmsetup.o -ldevmapper $(LIBS)
135
 
+             -o $@ dmsetup.o $(LIBS)
136
 
 
137
 
 dmsetup.static: dmsetup.o $(interfacebuilddir)/libdevmapper.a
138
 
        $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) \
139
 
-             -o $@ dmsetup.o -ldevmapper $(STATIC_LIBS) $(LIBS)
140
 
+             -o $@ dmsetup.o $(STATIC_LIBS) $(LIBS)
141
 
 
142
 
 all: device-mapper
143
 
 
144
 
@@ -144,6 +142,7 @@
145
 
        cat $(top_builddir)/lib/liblvm-internal.a > $@
146
 
        $(AR) rs $@ $(OBJECTS) lvmcmdlib.o lvm2cmd-static.o
147
 
 
148
 
+liblvm2cmd.$(LIB_SUFFIX): LIBS += $(DL_LIBS)
149
 
 liblvm2cmd.$(LIB_SUFFIX): liblvm2cmd.a $(LDDEPS)
150
 
        $(CC) -shared -Wl,-soname,$@.$(LIB_VERSION) \
151
 
        $(CFLAGS) $(CLDFLAGS) -o $@ $(LVMLIBS) $(LIBS) \