~ubuntu-branches/ubuntu/quantal/m2crypto/quantal

« back to all changes in this revision

Viewing changes to debian/patches/fix_kill_signal.patch

  • Committer: Package Import Robot
  • Author(s): Julian Taylor
  • Date: 2011-08-10 17:01:24 UTC
  • mfrom: (23.3.1 oneiric)
  • Revision ID: package-import@ubuntu.com-20110810170124-ctuhz524p63n0hrz
* repackage upstream
  - remove non-free demo/x509/proxylib.py
* switch to dh_python2 (LP: #788514) 
* switch to 3.0 (quilt)
  - converted all upstream changes to patches
  - fix_sslv2_test.patch: testsuite patch for sslv2 deactivation
  - fix_build_with_new_openssl.patch: build fix from debian 0.20.1-1.1
* Merge from debian testing, remaining changes:
  - disable_sslv2_test.patch: disable sslv23_weak_crypto test as it is expected to
    fail with SSLv2 having been disabled in openssl 0.9.8o-1ubuntu3.
    (LP: #600549)
  - fix_sslv2_test2.patch: fix testsuite with newer openssl. (LP: #600549)
    - Backported from http://svn.osafoundation.org/viewvc/m2crypto/trunk/tests/test_smime.py?r1=698&r2=721
  - debian/control: Add openssl for FTBFS. 
  - debian/rules; enable testsuite, add more files to "clean" rule.
  - fix_kill_signal.patch: use signal 9 to kill old s_server processes
    to work around build HUP signal-ignore-mask (LP: #451998).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: fix kill signal
 
2
 use signal 9 to kill old s_server processes
 
3
 to work around build HUP signal-ignore-mask (LP: #451998).
 
4
Author: Chuck Short <zulcss@ubuntu.com>
 
5
Origin: 0.20.1-1ubuntu1
 
6
Bug-Ubuntu: https://bugs.launchpad.net/bugs/451998
 
7
--- m2crypto-0.20.1.orig/tests/test_ssl.py
 
8
+++ m2crypto-0.20.1/tests/test_ssl.py
 
9
@@ -92,7 +92,7 @@ class BaseSSLClientTestCase(unittest.Tes
 
10
             return pid
 
11
 
 
12
     def stop_server(self, pid):
 
13
-        os.kill(pid, 1)
 
14
+        os.kill(pid, 9)
 
15
         os.waitpid(pid, 0)
 
16
 
 
17
     def http_get(self, s):