~ubuntu-branches/ubuntu/quantal/maildir-utils/quantal

« back to all changes in this revision

Viewing changes to debian/patches/fix-index-q-segfault

  • Committer: Bazaar Package Importer
  • Author(s): Norbert Preining
  • Date: 2010-01-19 20:12:43 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100119201243-d8qmzgxgexhy1bs0
Tags: 0.6~beta1-1
* new upstream release 0.6-beta
  - that merges the several different programs under one binary mu
  - no sqlite storage is used anymore
* debian packaging changes:
  - debian/patches
    . remove all patches
  - remove debian/HOWTO (upstream document) it is completely outdated
  - debian/control:
    . adjust build-dep for gmime-2.4
    . remove build-dep on quilt and sqlite
    . adjust the description to new reality
  - debian/rules:
    . do not try to install doc files that are not present anymore
    . disable quilt adaptions
  - add debian/NEWS that explains that the separate programs are gone

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
mu-index -q dies immediately with segfault
2
 
this patch fixes it
3
 
patch by Michael Guntsche <mike@it-loops.com>
4
 
---
5
 
 index/mu-index.c |    5 +++--
6
 
 1 file changed, 3 insertions(+), 2 deletions(-)
7
 
 
8
 
Index: maildir-utils/index/mu-index.c
9
 
===================================================================
10
 
--- maildir-utils.orig/index/mu-index.c 2009-10-30 02:36:24.000000000 +0900
11
 
+++ maildir-utils/index/mu-index.c      2009-10-30 02:36:34.000000000 +0900
12
 
@@ -195,8 +195,9 @@
13
 
        result = run_callback_maybe (data);
14
 
        if (result != MU_OK)
15
 
                return result;
16
 
-       
17
 
-       ++data->_stats->_processed;
18
 
+  
19
 
+       if (!mu_index_app_quiet())
20
 
+               ++data->_stats->_processed;
21
 
                
22
 
        /* see if we need to update/insert anything...*/
23
 
        dbstamp = mu_storage_sqlite_message_timestamp (data->_sqlite, fullpath);