~ubuntu-branches/ubuntu/quantal/netams/quantal

« back to all changes in this revision

Viewing changes to debian/patches/14_fix_pthread.diff

  • Committer: Bazaar Package Importer
  • Author(s): Alexander GQ Gerasiov
  • Date: 2010-07-24 16:37:01 UTC
  • mfrom: (2.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20100724163701-rni105xlqseqe26h
Tags: 3.4.5-2
* debian/Rules.make: Add -lcrypto to fix FTBFS with binutils-gold.
* debian/netams.postinst: Fix some sed magic in netams.conf
  processing.
* debian/control: Standards version updated.
* Vietnamese translation added. Closes: #576026. Thanks to Clytie
  Siddall.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix pthread_cleanup_pop() usage
 
2
 pthread_cleanup_pop() used in wrong context.
 
3
Author: Alexander GQ Gerasiov <gq@debian.org>
 
4
Forwarded: http://netams.com/phpBB3/viewtopic.php?f=2&t=5289
 
5
 
 
6
Index: netams/src/ds_ipfw.c
 
7
===================================================================
 
8
--- netams.orig/src/ds_ipfw.c   2010-05-14 15:35:11.000000000 +0400
 
9
+++ netams/src/ds_ipfw.c        2010-05-14 15:35:16.000000000 +0400
 
10
@@ -82,9 +82,9 @@
 
11
                ds->Measure(&start, len);
 
12
        }
 
13
        
 
14
+       pthread_cleanup_pop(1);
 
15
        } // socket
 
16
        } // bind
 
17
-       pthread_cleanup_pop(1);
 
18
        
 
19
 }
 
20
 /////////////////////////////////////////////////////////////////////////////////////