~ubuntu-branches/ubuntu/quantal/netatalk/quantal

« back to all changes in this revision

Viewing changes to debian/patches/207_afile_namespace_conflict.diff

  • Committer: Bazaar Package Importer
  • Author(s): Zak B. Elep
  • Date: 2006-01-01 15:24:32 UTC
  • Revision ID: james.westby@ubuntu.com-20060101152432-ll1yag8o1tv9zzoj
Tags: 2.0.3-3ubuntu1
Resynchronize with Debian.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- bin/afile/Makefile.am.old   2005-12-29 18:41:20.478636301 +0100
 
2
+++ bin/afile/Makefile.am       2005-12-29 18:45:05.053933780 +0100
 
3
@@ -2,10 +2,10 @@
 
4
 
 
5
 INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/sys
 
6
 
 
7
-bin_PROGRAMS = afile achfile
 
8
+bin_PROGRAMS = apple_file apple_chfile
 
9
 bin_SCRIPTS = acleandir.rc
 
10
 
 
11
-afile_SOURCES = afile.c common.c common.h
 
12
-achfile_SOURCES = achfile.c common.c common.h
 
13
+apple_file_SOURCES = afile.c common.c common.h
 
14
+apple_chfile_SOURCES = achfile.c common.c common.h
 
15
 
 
16
 EXTRA_DIST = acleandir.rc
 
17
--- bin/afile/Makefile.in.old   2005-12-29 18:41:30.019573890 +0100
 
18
+++ bin/afile/Makefile.in       2005-12-29 18:45:08.718598501 +0100
 
19
@@ -1,4 +1,4 @@
 
20
-# Makefile.in generated by automake 1.7.5 from Makefile.am.
 
21
+# Makefile.in generated by automake 1.7.9 from Makefile.am.
 
22
 # @configure_input@
 
23
 
 
24
 # Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
 
25
@@ -213,11 +213,11 @@
 
26
 
 
27
 INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/sys
 
28
 
 
29
-bin_PROGRAMS = afile achfile
 
30
+bin_PROGRAMS = apple_file apple_chfile
 
31
 bin_SCRIPTS = acleandir.rc
 
32
 
 
33
-afile_SOURCES = afile.c common.c common.h
 
34
-achfile_SOURCES = achfile.c common.c common.h
 
35
+apple_file_SOURCES = afile.c common.c common.h
 
36
+apple_chfile_SOURCES = achfile.c common.c common.h
 
37
 
 
38
 EXTRA_DIST = acleandir.rc
 
39
 subdir = bin/afile
 
40
@@ -225,19 +225,19 @@
 
41
 mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
 
42
 CONFIG_HEADER = $(top_builddir)/config.h
 
43
 CONFIG_CLEAN_FILES =
 
44
-bin_PROGRAMS = afile$(EXEEXT) achfile$(EXEEXT)
 
45
+bin_PROGRAMS = apple_file$(EXEEXT) apple_chfile$(EXEEXT)
 
46
 PROGRAMS = $(bin_PROGRAMS)
 
47
 
 
48
-am_achfile_OBJECTS = achfile.$(OBJEXT) common.$(OBJEXT)
 
49
-achfile_OBJECTS = $(am_achfile_OBJECTS)
 
50
-achfile_LDADD = $(LDADD)
 
51
-achfile_DEPENDENCIES =
 
52
-achfile_LDFLAGS =
 
53
-am_afile_OBJECTS = afile.$(OBJEXT) common.$(OBJEXT)
 
54
-afile_OBJECTS = $(am_afile_OBJECTS)
 
55
-afile_LDADD = $(LDADD)
 
56
-afile_DEPENDENCIES =
 
57
-afile_LDFLAGS =
 
58
+am_apple_chfile_OBJECTS = achfile.$(OBJEXT) common.$(OBJEXT)
 
59
+apple_chfile_OBJECTS = $(am_apple_chfile_OBJECTS)
 
60
+apple_chfile_LDADD = $(LDADD)
 
61
+apple_chfile_DEPENDENCIES =
 
62
+apple_chfile_LDFLAGS =
 
63
+am_apple_file_OBJECTS = afile.$(OBJEXT) common.$(OBJEXT)
 
64
+apple_file_OBJECTS = $(am_apple_file_OBJECTS)
 
65
+apple_file_LDADD = $(LDADD)
 
66
+apple_file_DEPENDENCIES =
 
67
+apple_file_LDFLAGS =
 
68
 SCRIPTS = $(bin_SCRIPTS)
 
69
 
 
70
 
 
71
@@ -253,9 +253,9 @@
 
72
 CCLD = $(CC)
 
73
 LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
 
74
        $(AM_LDFLAGS) $(LDFLAGS) -o $@
 
75
-DIST_SOURCES = $(achfile_SOURCES) $(afile_SOURCES)
 
76
-DIST_COMMON = Makefile.am Makefile.in
 
77
-SOURCES = $(achfile_SOURCES) $(afile_SOURCES)
 
78
+DIST_SOURCES = $(apple_chfile_SOURCES) $(apple_file_SOURCES)
 
79
+DIST_COMMON = $(srcdir)/Makefile.in Makefile.am
 
80
+SOURCES = $(apple_chfile_SOURCES) $(apple_file_SOURCES)
 
81
 
 
82
 all: all-am
 
83
 
 
84
@@ -263,7 +263,7 @@
 
85
 .SUFFIXES: .c .lo .o .obj
 
86
 $(srcdir)/Makefile.in:  Makefile.am  $(top_srcdir)/configure.in $(ACLOCAL_M4)
 
87
        cd $(top_srcdir) && \
 
88
-         $(AUTOMAKE) --foreign  bin/afile/Makefile
 
89
+         $(AUTOMAKE) --gnu  bin/afile/Makefile
 
90
 Makefile:  $(srcdir)/Makefile.in  $(top_builddir)/config.status
 
91
        cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
 
92
 binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
 
93
@@ -295,12 +295,12 @@
 
94
          echo " rm -f $$p $$f"; \
 
95
          rm -f $$p $$f ; \
 
96
        done
 
97
-achfile$(EXEEXT): $(achfile_OBJECTS) $(achfile_DEPENDENCIES) 
 
98
-       @rm -f achfile$(EXEEXT)
 
99
-       $(LINK) $(achfile_LDFLAGS) $(achfile_OBJECTS) $(achfile_LDADD) $(LIBS)
 
100
-afile$(EXEEXT): $(afile_OBJECTS) $(afile_DEPENDENCIES) 
 
101
-       @rm -f afile$(EXEEXT)
 
102
-       $(LINK) $(afile_LDFLAGS) $(afile_OBJECTS) $(afile_LDADD) $(LIBS)
 
103
+apple_chfile$(EXEEXT): $(apple_chfile_OBJECTS) $(apple_chfile_DEPENDENCIES) 
 
104
+       @rm -f apple_chfile$(EXEEXT)
 
105
+       $(LINK) $(apple_chfile_LDFLAGS) $(apple_chfile_OBJECTS) $(apple_chfile_LDADD) $(LIBS)
 
106
+apple_file$(EXEEXT): $(apple_file_OBJECTS) $(apple_file_DEPENDENCIES) 
 
107
+       @rm -f apple_file$(EXEEXT)
 
108
+       $(LINK) $(apple_file_LDFLAGS) $(apple_file_OBJECTS) $(apple_file_LDADD) $(LIBS)
 
109
 binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
 
110
 install-binSCRIPTS: $(bin_SCRIPTS)
 
111
        @$(NORMAL_INSTALL)
 
112
@@ -332,9 +332,6 @@
 
113
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/afile.Po@am__quote@
 
114
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/common.Po@am__quote@
 
115
 
 
116
-distclean-depend:
 
117
-       -rm -rf ./$(DEPDIR)
 
118
-
 
119
 .c.o:
 
120
 @am__fastdepCC_TRUE@   if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
 
121
 @am__fastdepCC_TRUE@     -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
 
122
@@ -480,7 +477,7 @@
 
123
 installcheck: installcheck-am
 
124
 install-strip:
 
125
        $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
 
126
-         INSTALL_STRIP_FLAG=-s \
 
127
+         install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
 
128
          `test -z '$(STRIP)' || \
 
129
            echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
 
130
 mostlyclean-generic:
 
131
@@ -488,7 +485,7 @@
 
132
 clean-generic:
 
133
 
 
134
 distclean-generic:
 
135
-       -rm -f Makefile $(CONFIG_CLEAN_FILES)
 
136
+       -rm -f $(CONFIG_CLEAN_FILES)
 
137
 
 
138
 maintainer-clean-generic:
 
139
        @echo "This command is intended for maintainers to use"
 
140
@@ -498,9 +495,10 @@
 
141
 clean-am: clean-binPROGRAMS clean-generic clean-libtool mostlyclean-am
 
142
 
 
143
 distclean: distclean-am
 
144
-
 
145
-distclean-am: clean-am distclean-compile distclean-depend \
 
146
-       distclean-generic distclean-libtool distclean-tags
 
147
+       -rm -rf ./$(DEPDIR)
 
148
+       -rm -f Makefile
 
149
+distclean-am: clean-am distclean-compile distclean-generic \
 
150
+       distclean-libtool distclean-tags
 
151
 
 
152
 dvi: dvi-am
 
153
 
 
154
@@ -521,7 +519,8 @@
 
155
 installcheck-am:
 
156
 
 
157
 maintainer-clean: maintainer-clean-am
 
158
-
 
159
+       -rm -rf ./$(DEPDIR)
 
160
+       -rm -f Makefile
 
161
 maintainer-clean-am: distclean-am maintainer-clean-generic
 
162
 
 
163
 mostlyclean: mostlyclean-am
 
164
@@ -542,16 +541,15 @@
 
165
 
 
166
 .PHONY: CTAGS GTAGS all all-am check check-am clean clean-binPROGRAMS \
 
167
        clean-generic clean-libtool ctags distclean distclean-compile \
 
168
-       distclean-depend distclean-generic distclean-libtool \
 
169
-       distclean-tags distdir dvi dvi-am info info-am install \
 
170
-       install-am install-binPROGRAMS install-binSCRIPTS install-data \
 
171
-       install-data-am install-exec install-exec-am install-info \
 
172
-       install-info-am install-man install-strip installcheck \
 
173
-       installcheck-am installdirs maintainer-clean \
 
174
-       maintainer-clean-generic mostlyclean mostlyclean-compile \
 
175
-       mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
 
176
-       tags uninstall uninstall-am uninstall-binPROGRAMS \
 
177
-       uninstall-binSCRIPTS uninstall-info-am
 
178
+       distclean-generic distclean-libtool distclean-tags distdir dvi \
 
179
+       dvi-am info info-am install install-am install-binPROGRAMS \
 
180
+       install-binSCRIPTS install-data install-data-am install-exec \
 
181
+       install-exec-am install-info install-info-am install-man \
 
182
+       install-strip installcheck installcheck-am installdirs \
 
183
+       maintainer-clean maintainer-clean-generic mostlyclean \
 
184
+       mostlyclean-compile mostlyclean-generic mostlyclean-libtool pdf \
 
185
+       pdf-am ps ps-am tags uninstall uninstall-am \
 
186
+       uninstall-binPROGRAMS uninstall-binSCRIPTS uninstall-info-am
 
187
 
 
188
 # Tell versions [3.59,3.63) of GNU make to not export all variables.
 
189
 # Otherwise a system limit (for SysV at least) may be exceeded.
 
190
--- man/man1/afile.1.old        2005-12-29 18:50:58.959272188 +0100
 
191
+++ man/man1/afile.1    2005-12-29 18:51:51.649585375 +0100
 
192
@@ -1,18 +1,18 @@
 
193
-.TH afile 1 "26 Feb 1998" 2.0.3 Netatalk 
 
194
+.TH apple_file 1 "26 Feb 1998" 2.0.3 Netatalk 
 
195
 .SH NAME
 
196
-afile \- display type and creator of Apple Macintosh files (netatalk format)
 
197
+apple_file \- display type and creator of Apple Macintosh files (netatalk format)
 
198
 .SH SYNOPSIS
 
199
-\fBafile\fR [\-a] \fBfile\fR \&...
 
200
+\fBapple_file\fR [\-a] \fBfile\fR \&...
 
201
 .sp 1
 
202
 .SH DESCRIPTION
 
203
-afile displays the name and Macintosh type and
 
204
+apple_file displays the name and Macintosh type and
 
205
 creator of the \fIfile\fR arguments. Tests
 
206
 whether the file is an AppleDouble header, in which case it checks the
 
207
 corresponding data fork exists, or assumes it is a data fork in which case
 
208
 it looks for the corresponding AppleDouble to find the type/creator
 
209
 information.
 
210
 .PP
 
211
-afile does not look at any of the extension
 
212
+apple_file does not look at any of the extension
 
213
 mapping files such as AppleVolumes.system.
 
214
 .SH OPTIONS
 
215
 .TP 
 
216
@@ -43,6 +43,6 @@
 
217
 .PP
 
218
 9 bad magic in AppleDouble
 
219
 .SH "SEE ALSO"
 
220
-\fBachfile\fR(1),
 
221
+\fBapple_chfile\fR(1),
 
222
 \fBafpd\fR(8)
 
223
 
 
224
--- man/man1/achfile.1.old      2005-12-29 18:52:46.341353898 +0100
 
225
+++ man/man1/achfile.1  2005-12-29 18:53:09.446154302 +0100
 
226
@@ -1,10 +1,10 @@
 
227
-.TH achfile 1 "26 Feb 1998" 2.0.3 Netatalk 
 
228
+.TH apple_chfile 1 "26 Feb 1998" 2.0.3 Netatalk 
 
229
 .SH NAME
 
230
-achfile \- change type and/or creator of Apple Macintosh files (netatalk format)
 
231
+apple_chfile \- change type and/or creator of Apple Macintosh files (netatalk format)
 
232
 .SH SYNOPSIS
 
233
-\fBachfile\fR [ \-t \fBtype\fR ] [ \-c \fBcreator\fR ] \fBfile\fR \&...
 
234
+\fBapple_chfile\fR [ \-t \fBtype\fR ] [ \-c \fBcreator\fR ] \fBfile\fR \&...
 
235
 .SH DESCRIPTION
 
236
-achfile changes the Macintosh type and/or creator
 
237
+apple_chfile changes the Macintosh type and/or creator
 
238
 of the \fIfile\fR arguments which have a
 
239
 corresponding .AppleDouble file.
 
240
 .SH OPTIONS
 
241
@@ -15,6 +15,6 @@
 
242
 .SH DIAGNOSTICS
 
243
 returns exit status 0 if all files changed successfully
 
244
 .SH "SEE ALSO"
 
245
-\fBafile\fR(1),
 
246
+\fBapple_file\fR(1),
 
247
 \fBafpd\fR(8)
 
248
 
 
249
--- bin/afile/acleandir.rc.old  2005-12-29 19:01:03.359755410 +0100
 
250
+++ bin/afile/acleandir.rc      2005-12-29 19:01:16.417250024 +0100
 
251
@@ -42,7 +42,7 @@
 
252
 # now look at the .AppleDouble dir
 
253
 #
 
254
 emptydir $AD  || for (i in $AD/*) {
 
255
-    if (~ $aopt 1 || ! afile $i  >/dev/null >[2=1] ) {
 
256
+    if (~ $aopt 1 || ! apple_file $i  >/dev/null >[2=1] ) {
 
257
        sizemess = ()
 
258
        size = `{wc -c $i}
 
259
        ! ~ $size(1) 589 && sizemess = 'size='^$size(1)
 
260
--- man/man1/acleandir.1.old    2005-12-29 19:10:45.810277957 +0100
 
261
+++ man/man1/acleandir.1        2005-12-29 19:10:54.312460226 +0100
 
262
@@ -44,6 +44,6 @@
 
263
 returns exit status 0 unless bad options are provided or a directory
 
264
 is not given on the command line.
 
265
 .SH "SEE ALSO"
 
266
-\fBafile\fR(1),
 
267
+\fBapple_file\fR(1),
 
268
 \fBafpd\fR(8)
 
269