~ubuntu-branches/ubuntu/quantal/pulseaudio/quantal

« back to all changes in this revision

Viewing changes to debian/patches/0103-module-jackdbus-detect-Avoid-double-free-of-modargs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luke Yelavich, David Henningsson, Luke Yelavich
  • Date: 2011-10-20 11:36:43 UTC
  • Revision ID: james.westby@ubuntu.com-20111020113643-pu2zh690bw7h755f
Tags: 1:1.0-0ubuntu4
[ David Henningsson ]
* Added patches:
  0103-module-jackdbus-detect-Avoid-double-free-of-modargs.patch:
    (LP: #867444)
  0104-source-output-Do-not-use-unset-channel-map-in-pa_sou.patch: 
    (LP: #864071)
  0105-Fix-deferred-volume-not-being-applied-if-sink-is-clo.patch,
  0017-Hack-around-a-bug-in-the-core-causing-volumes-not-to.patch:
    These two patches affect users not having their volume correctly
    set on port change (LP: #877954)

[ Luke Yelavich ]
* debian/control: Update Vcs-Bzr field
* 0102-Always-return-a-three-part-version-number-in-API-cal.patch: Refresh
  the patch from upstrea git, to refer to the correct commit hash, and
  update the description
* Pull some bug fixes from the stable-1.x upstream git branch:
  - 411af6b (sink: Move updating the requested latency after the rewind
             request when finishing a stream move.)
  - 87f70c6 (null-sink: Set latency range at the time of initialization of
             module.)
  - d71a291 (Make pulse build with clang again)
  - 4e5943b (alsa: Give compressed formats preference over PCM)
  - 867170a (alsa: Better error handling in mixer rtpoll callback)
  - c055c55 (echo-cancel: Fail if loaded between a sink and its monitor)
  - 8754e0c (doc: Add some more doxygen tags to existing comments)
  - 2c30c07 (alsa: Make mixer error handling more robust still)
  - 8a5e6e8 (echo-cancel: Don't crash if adjust_time = 0)
  - 7b13a79 (echo-cancel: Close debug files on module unload)
  - 6bf0489 (tests: Fix calculation of memblock size in resampler-test)
  - 93f55a4 (filter-apply: Move sink/source unlink callbacks before m-s-r)
  - b1dabfb (build-sys: Drop libsamplerate from pulsecommon deps)
  - 743a4d0 (build-sys: Provide a simple CMake Config setup (similar to
             pkgconfig))
* Add liborc-0.4-dev as a build dependency to add orc support
* debian/libpulse-dev.install: Ship cmake files

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 58585db8084675b6e1999b7ad5b0d89d98f71db8 Mon Sep 17 00:00:00 2001
 
2
From: David Henningsson <david.henningsson@canonical.com>
 
3
Date: Wed, 5 Oct 2011 10:28:50 +0200
 
4
Subject: [PATCH] module-jackdbus-detect: Avoid double-free of modargs
 
5
 
 
6
If module-jackdbus-detect failed in the later part of initialization,
 
7
the ma variable was freed twice.
 
8
 
 
9
BugLink: http://bugs.launchpad.net/bugs/867444
 
10
Signed-off-by: David Henningsson <david.henningsson@canonical.com>
 
11
---
 
12
 src/modules/jack/module-jackdbus-detect.c |    2 +-
 
13
 1 files changed, 1 insertions(+), 1 deletions(-)
 
14
 
 
15
diff --git a/src/modules/jack/module-jackdbus-detect.c b/src/modules/jack/module-jackdbus-detect.c
 
16
index 6bbf38b..41933c7 100644
 
17
--- a/src/modules/jack/module-jackdbus-detect.c
 
18
+++ b/src/modules/jack/module-jackdbus-detect.c
 
19
@@ -231,7 +231,6 @@ int pa__init(pa_module *m) {
 
20
         pa_log("Failed to parse connect= argument.");
 
21
         goto fail;
 
22
     }
 
23
-    pa_modargs_free(ma);
 
24
 
 
25
     if (!(connection = pa_dbus_bus_get(m->core, DBUS_BUS_SESSION, &error)) || dbus_error_is_set(&error)) {
 
26
 
 
27
@@ -259,6 +258,7 @@ int pa__init(pa_module *m) {
 
28
 
 
29
     check_service_started(u);
 
30
 
 
31
+    pa_modargs_free(ma);
 
32
     return 0;
 
33
 
 
34
 fail:
 
35
-- 
 
36
1.7.5.4
 
37