~ubuntu-branches/ubuntu/quantal/python2.7/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/profiled-build.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-01-06 21:57:07 UTC
  • Revision ID: package-import@ubuntu.com-20120106215707-da7ef71vawoka4yy
Tags: 2.7.2-9ubuntu1
* Update to 20120105, taken from the 2.7 branch.
* Test build using db5.1.
* Overwrite some lintian warnings:
  - The -dbg interpreters are not unusual.
  - The -gdb.py files don't need a python dependency.
  - lintian can't handle a whatis entry starting with one word on the line.
* Fix test failures related to distutils debian installation layout.
* Add build-arch/build-indep targets.
* Regenerate Setup and Makefiles after correcting Setup.local.
* profiled-build.diff: Pass PY_CFLAGS instead of CFLAGS for the profiled
  build.
* Pass dpkg-buildflags to the build process, and build third party
  extensions with these flags.
* Add support to build using -flto (and -g1) on some architectures.
* Disable pgo builds for some architectures (for now, keep just
  amd64 armel armhf i386 powerpc ppc64).
* Build-depend on libgdbm-dev to build and run the gdbm tests.
* Build-depend on xvfb to run the tkinter tests.
* python2.7: Provide python2.7-argparse and python-argparse.
* Don't run test_threading on mips/mipsel.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
# DP: Fix profiled build; don't use Python/thread.gc*, gcc complains
2
2
 
 
3
Index: b/Makefile.pre.in
 
4
===================================================================
3
5
--- a/Makefile.pre.in
4
6
+++ b/Makefile.pre.in
5
 
@@ -383,10 +383,10 @@
6
 
        $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
 
7
@@ -382,18 +382,18 @@
 
8
        $(MAKE) build_all_use_profile
 
9
 
 
10
 build_all_generate_profile:
 
11
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
 
12
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
7
13
 
8
14
 run_profile_task:
9
15
-       ./$(BUILDPYTHON) $(PROFILE_TASK)
11
17
 
12
18
 build_all_use_profile:
13
19
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
14
 
+       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use -fprofile-correction"
 
20
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -fprofile-use -fprofile-correction"
15
21
 
16
22
 coverage:
17
23
        @echo "Building with support for coverage checking:"
 
24
        $(MAKE) clean
 
25
-       $(MAKE) all CFLAGS="$(CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
 
26
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
 
27
 
 
28
 
 
29
 # Build the interpreter