~ubuntu-branches/ubuntu/quantal/recoll/quantal

« back to all changes in this revision

Viewing changes to debian/patches/fix-kFreeBSD-ftbfs.patch

  • Committer: Package Import Robot
  • Author(s): Kartik Mistry
  • Date: 2012-04-04 12:16:48 UTC
  • Revision ID: package-import@ubuntu.com-20120404121648-ahic3utcetzt639f
Tags: 1.17.1-2
* debian/patches:
  + fix-kFreeBSD-ftbfs.patch: Added patch to fix FTBFS on kFreeBSD from
    upstream (Closes: #667083)
  + recoll_ionice_getpid.patch: Added patch to fix FTBFS with gcc-4.7 from
    upstream (Closes: #667352)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Patch to fix FTBFS on kFreeBSD
 
2
Author: Jean-Francois Dockes <jf@dockes.org>
 
3
Debian-bug: http://bugs.debian.org/667083
 
4
Last-Update: 2012-04-04
 
5
--- a/python/recoll/setup.py.in
 
6
+++ b/python/recoll/setup.py.in
 
7
@@ -3,7 +3,7 @@
 
8
 import sys
 
9
 
 
10
 sysname = os.uname()[0]
 
11
-if sysname == 'Linux':
 
12
+if sysname == 'Linux' or sysname == 'GNU/kFreeBSD':
 
13
     libs = ['rcl', 'xapian']
 
14
 else:
 
15
     libs = ['rcl', 'xapian', 'iconv']