~ubuntu-branches/ubuntu/quantal/remote-login-service/quantal-security

« back to all changes in this revision

Viewing changes to debian/patches/pkglibexecdir.patch

  • Committer: Package Import Robot
  • Author(s): Michael Terry
  • Date: 2012-08-15 15:00:35 UTC
  • Revision ID: package-import@ubuntu.com-20120815150035-482vgvqm2n4hvf45
Tags: 0.2.0-0ubuntu1
* Package for Ubuntu (LP: #1037231)
* Switch to dh9 and drop cdbs
* Add watch file
* Cleanup control and copyright files
* Add patch to use pkglibexecdir instead of libexecdir

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
=== modified file 'data/Makefile.am'
 
2
Index: remote-login-service/data/Makefile.am
 
3
===================================================================
 
4
--- remote-login-service.orig/data/Makefile.am  2012-08-15 15:25:48.416334636 -0400
 
5
+++ remote-login-service/data/Makefile.am       2012-08-15 15:25:52.608334681 -0400
 
6
@@ -7,7 +7,7 @@
 
7
 dbus_services_DATA = com.canonical.RemoteLogin.service
 
8
 
 
9
 %.service: %.service.in
 
10
-       sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
 
11
+       sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
 
12
 
 
13
 EXTRA_DIST = \
 
14
        com.canonical.RemoteLogin.service.in \
 
15
Index: remote-login-service/data/com.canonical.RemoteLogin.service.in
 
16
===================================================================
 
17
--- remote-login-service.orig/data/com.canonical.RemoteLogin.service.in 2012-08-15 15:25:48.416334636 -0400
 
18
+++ remote-login-service/data/com.canonical.RemoteLogin.service.in      2012-08-15 15:25:52.608334681 -0400
 
19
@@ -1,3 +1,3 @@
 
20
 [D-BUS Service]
 
21
 Name=com.canonical.RemoteLogin
 
22
-Exec=@libexecdir@/remote-login-service
 
23
+Exec=@pkglibexecdir@/remote-login-service
 
24
Index: remote-login-service/src/Makefile.am
 
25
===================================================================
 
26
--- remote-login-service.orig/src/Makefile.am   2012-08-15 15:25:48.416334636 -0400
 
27
+++ remote-login-service/src/Makefile.am        2012-08-15 15:25:52.608334681 -0400
 
28
@@ -1,7 +1,7 @@
 
29
 
 
30
-libexec_PROGRAMS = \
 
31
+pkglibexec_PROGRAMS = \
 
32
        remote-login-service
 
33
-libexec_SCRIPTS = \
 
34
+pkglibexec_SCRIPTS = \
 
35
        helper-script
 
36
 
 
37
 EXTRA_DIST = \
 
38
@@ -46,7 +46,7 @@
 
39
        server.h
 
40
 libservers_la_CFLAGS = \
 
41
        -DUCCS_QUERY_TOOL="\"thin-client-config\"" \
 
42
-       -DHELPER_SCRIPT="\"$(libexecdir)/helper-script\"" \
 
43
+       -DHELPER_SCRIPT="\"$(pkglibexecdir)/helper-script\"" \
 
44
        $(SERVICE_CFLAGS) \
 
45
        $(COVERAGE_CFLAGS)
 
46
 libservers_la_LDFLAGS = \