~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/20120517-r35434.patch

  • Committer: Package Import Robot
  • Author(s): Antonio Terceiro, Lucas Nussbaum, Daigo Moriwaki, James Healy, Antonio Terceiro
  • Date: 2012-06-02 07:42:28 UTC
  • mfrom: (21.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20120602074228-09t2jgg1ozrsnnfo
Tags: 1.9.3.194-1
[ Lucas Nussbaum ]
* Add hurd-path-max.diff. Fixes FTBFS on Hurd. (Closes: #648055)

[ Daigo Moriwaki ]
* Removed debian/patches/debian/patches/sparc-continuations.diff,
  which the upstream has applied.
* debian/rules:
  - Bumped up tcltk_ver to 8.5.
  - Used chrpath for tcltklib.so to fix a lintian error,
    binary-or-shlib-defines-rpath.
* debian/control:
  - Suggests ruby-switch. (Closes: #654312)
  - Build-Depends: chrpath.
* debian/libruby1.9.1.symbols: Added a new symbol for
  rb_str_modify_expand@Base.
* debian/run-test-suites.bash:
  - Corrected options for test-all.
  - Enabled timeout to allow hang tests to be aborted.

[ James Healy ]
* New upstream release: 1.9.3p194 (Closes: #669582)
  + This release includes a fix for CVE-2011-0188 (Closes: #628451)
  + This release also does not segfault when running the test suite under
    amd64 (Closes: #674347)
* Enable hardened build flags (Closes: #667964)
* debian/control:
  - depend on specific version on coreutils
  - update policy version (no changes)

[ Antonio Terceiro ]
* debian/ruby1.9.1.postinst:
  + bump alternatives priority for `ruby` to 51 so that Ruby 1.9 has a
    higher priority than Ruby 1.8 (50).
  + bump alternatives priority for `gem` to 181 so that the Rubygems
    provided by Ruby 1.9 has priority over the one provided by the rubygems
    package.
* debian/control: added myself to Uploaders:
* debian/libruby1.9.1.symbols: update with new symbols added in 1.9.3p194
  upstream release.
* debian/manpages/*: fix references to command names with s/1.9/1.9.1/
* debian/rules: skip running DRB tests, since they seem to make the build
  hang. This should close #647296, but let's way and see. Also, with this do
  not need to timeout the test suite anymore.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 20120517-r35434.patch by James Healy <jimmy@deefa.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: The test suites for ruby 1.9.3p125 and 1.9.3p194 fails to 
 
6
## DP: complete when built against openssl 1.0.1. The issue was
 
7
## DP: fixed on trunk in revision 35434, this backports the fix
 
8
## DP: into the debian package.
 
9
## DP: TODO: remove this patch when 1.9.3p194+1 is available
 
10
 
 
11
@DPATCH@
 
12
Index: ruby1.9.1/lib/drb/ssl.rb
 
13
===================================================================
 
14
--- ruby1.9.1.orig/lib/drb/ssl.rb       2012-05-17 15:28:27.000000000 +1000
 
15
+++ ruby1.9.1/lib/drb/ssl.rb    2012-05-17 15:28:27.000000000 +1000
 
16
@@ -54,7 +54,7 @@
 
17
           return
 
18
         end
 
19
 
 
20
-        rsa = OpenSSL::PKey::RSA.new(512){|p, n|
 
21
+        rsa = OpenSSL::PKey::RSA.new(1024){|p, n|
 
22
           next unless self[:verbose]
 
23
           case p
 
24
           when 0; $stderr.putc "."  # BN_generate_prime