~ubuntu-branches/ubuntu/quantal/sgt-puzzles/quantal

« back to all changes in this revision

Viewing changes to debian/patches/206_translate-docs.diff

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2009-05-03 14:54:23 UTC
  • mfrom: (1.1.7 upstream) (3.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090503145423-o4d0ubd8ocykbad8
Tags: 8446-1ubuntu1
* Merge from debian unstable, remaining changes:
  - typos in debian/desktop/netslide.desktop (Exec=netslide)
  - xpm icons files for the menus
  - debian/rules adapted to install desktop and icons files.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- sgt-puzzles.orig/Makefile.doc
 
2
+++ sgt-puzzles/Makefile.doc
 
3
@@ -29,6 +29,34 @@
 
4
 .PHONY: man html
 
5
 all: man html
 
6
 
 
7
+LANGUAGES := $(patsubst po/%.po,%,$(wildcard po/*.po))
 
8
+
 
9
+po/puzzles-doc.pot: puzzles.but
 
10
+       po4a-gettextize -f halibut -m $< -p $@
 
11
+po/%.po: po/puzzles-doc.pot
 
12
+       msgmerge -o po/$*.new.po $< po/$*.po
 
13
+       mv po/$*.new.po po/$*.po
 
14
+update-po: po/puzzles-doc.pot $(wildcard po/*.po)
 
15
+
 
16
+doc/puzzles.but.%: puzzles.but po/%.po
 
17
+       mkdir -p doc
 
18
+       po4a-translate -k 0 -f halibut -m puzzles.but -p po/$*.po -l $@
 
19
+
 
20
+doc/puzzles.txt.%: doc/puzzles.but.%
 
21
+       halibut --text=$@ $<
 
22
+
 
23
+doc/html-%-stamp: doc/puzzles.but.%
 
24
+       mkdir -p doc
 
25
+       rm -rf doc/html-$*
 
26
+       mkdir doc/html-$*
 
27
+       cd doc/html-$* && halibut --html ../puzzles.but.$*
 
28
+       touch $@
 
29
+
 
30
+.PHONY: update-po html-%
 
31
+.PRECIOUS: $(addprefix doc/puzzles.but.,$(LANGUAGES))
 
32
+html: $(patsubst %,doc/html-%-stamp,$(LANGUAGES))
 
33
+all: $(addprefix doc/puzzles.txt.,$(LANGUAGES))
 
34
+
 
35
 clean:
 
36
        rm -f puzzles.hlp puzzles.txt HACKING *.html *.hh[pck]
 
37
        rm -f puzzles.cnt