~ubuntu-branches/ubuntu/quantal/silo/quantal

« back to all changes in this revision

Viewing changes to debian/patches/20-silo_ls_fix_date_calc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Fabio M. Di Nitto
  • Date: 2007-10-25 09:28:08 UTC
  • mfrom: (15.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20071025092808-1yhj12t7s4zqsfu5
Tags: 1.4.13a+git20070930-1ubuntu1
* Merge from debian unstable, remaining changes:
  - Build with -fno-stack-protector.
  - Change silo.postinst to automatically update the boot block without
    invoking siloconfig and keep asking questions on upgrades.
  - Convert silo.conf to use /dev/disk/by-uuid.
  - Ubuntu maintainer foobar.
  - Fix debian/rules call to dh_installdocs.
  - Drop the requirement of gcc-4.1 and start using default gcc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: build-tree/second/ls.c
 
2
===================================================================
 
3
--- build-tree.orig/second/ls.c 2007-08-16 08:01:05.000000000 +1200
 
4
+++ build-tree/second/ls.c      2007-08-16 08:01:44.000000000 +1200
 
5
@@ -157,7 +157,8 @@
 
6
     if (tab_ambiguous == NULL && ls_opt & LSOPT_L) {
 
7
        char mode[11];
 
8
        char *q;
 
9
-       unsigned int mtime, day, hour, min, month, year;
 
10
+       unsigned int mtime;
 
11
+       int day, hour, min, month, year;
 
12
        static char *months[] = {
 
13
            "Jan", "Feb", "Mar", "Apr", "May", "Jun",
 
14
            "Jul", "Aug", "Sep", "Oct", "Nov", "Dec" };