~ubuntu-branches/ubuntu/quantal/sl-modem/quantal

« back to all changes in this revision

Viewing changes to debian/patches/ioctl.diff

  • Committer: Bazaar Package Importer
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2011-04-14 16:52:32 UTC
  • mfrom: (1.1.7 upstream) (22.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20110414165232-fakqvs9rs07ukhhl
Tags: 2.9.11~20110321-1
* New upstream release
* Removed patches that got applied upstream: ioctl.diff, semaphore.diff
* Refreshed autoload.diff patch
* Bumped compat level to 8
* debian/control: Bumped Standards-Version to 3.9.2, no changes needed
* Use DKMS debhelper script
  + Renamed debian/dkms.conf.in to debian/sl-modem-source.dkms, also
    replaced #VERSION# with #MODULE_VERSION#
  + debian/control:
    - Added dkms >= 2.1.1.2-1~ to build-deps
    - Removed dkms from Recommends, since dh_dkms will add it to Depends.
  + debian/rules:
    - Use DKMS debhelper addon
    - override dh_dkms to invocate -V option.
  + Removed debian/sl-modem-source.prerm
  + debian/sl-modem-source.postinst: Removed DKMS invocation, as it will be
    added by dh_dkms.
* debian/sl-modem-source.lintian-overrides: Updated path in override.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix compilation of slamr module with 2.6.36
2
 
  ioctl got deprecated since kernel 2.6.36
3
 
Origin: http://bugs.gentoo.org/attachment.cgi?id=259296
4
 
Bug-Gentoo: http://bugs.gentoo.org/show_bug.cgi?id=302456
5
 
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=613906
6
 
Bug-Ubuntu: https://bugs.launchpad.net/bugs/737650
7
 
--- a/drivers/amrmo_init.c      2011-01-06 20:12:59.000000000 +0100
8
 
+++ b/drivers/amrmo_init.c      2011-01-06 20:12:34.000000000 +0100
9
 
@@ -437,11 +437,11 @@ static unsigned int amrmo_poll(struct fi
10
 
 
11
 
 
12
 
 
13
 
-static int amrmo_ioctl(struct inode *inode, struct file *file, unsigned int cmd, unsigned long parg)
14
 
+static long amrmo_unlocked_ioctl(struct file *file, unsigned int cmd, unsigned long parg)
15
 
 {
16
 
        struct amrmo_struct *amrmo = (struct amrmo_struct *)file->private_data;
17
 
         unsigned long flags;
18
 
-       int ret;
19
 
+       long ret;
20
 
        unsigned stat;
21
 
        unsigned long arg=0;
22
 
 
23
 
@@ -514,7 +514,7 @@ static struct file_operations amrmo_fops
24
 
         .read =    amrmo_read,
25
 
         .write =   amrmo_write,
26
 
         .poll =    amrmo_poll,
27
 
-        .ioctl =   amrmo_ioctl,
28
 
+        .unlocked_ioctl =   amrmo_unlocked_ioctl,
29
 
         .open =    amrmo_open,
30
 
         .release = amrmo_release,
31
 
 };