~ubuntu-branches/ubuntu/quantal/usbmuxd/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/find-inotify-multiarch.patch

  • Committer: Package Import Robot
  • Author(s): Whoopie
  • Date: 2013-02-05 08:56:59 UTC
  • Revision ID: package-import@ubuntu.com-20130205085659-z0a8c1an5x4j2b35
Tags: 1.0.8-1ubuntu0.1
Correctly find inotify.h to build with inotify support (LP: #656009).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: correctly find inotify.h in the multiarch location.
 
2
Author: Dmitrijs Ledkovs <xnox@ubuntu.com>
 
3
Bug-Ubuntu: https://bugs.launchpad.net/bugs/656009
 
4
 
 
5
--- usbmuxd-1.0.8.orig/libusbmuxd/CMakeLists.txt
 
6
+++ usbmuxd-1.0.8/libusbmuxd/CMakeLists.txt
 
7
@@ -7,6 +7,8 @@ find_package(Inotify)
 
8
 if (INOTIFY_FOUND)
 
9
   add_definitions("-DHAVE_INOTIFY")
 
10
   message("-- libusbmuxd will be built with inotify support")
 
11
+else (INOTIFY_FOUND)
 
12
+  message("-- libusbmuxd will be built without inotify support")
 
13
 endif()
 
14
 endif(WANT_INOTIFY)
 
15
 
 
16
--- usbmuxd-1.0.8.orig/Modules/FindInotify.cmake
 
17
+++ usbmuxd-1.0.8/Modules/FindInotify.cmake
 
18
@@ -1,7 +1,8 @@
 
19
 set(INOTIFY_H "NOTFOUND")
 
20
-find_file(INOTIFY_H
 
21
-  "sys/inotify.h"
 
22
-  PATHS ENV INCLUDE
 
23
+find_path(INOTIFY_H
 
24
+  sys/inotify.h
 
25
+  PATH_SUFFIXES
 
26
+    ${CMAKE_LIBRARY_ARCHITECTURE}
 
27
 )
 
28
 
 
29
 if (INOTIFY_H)