~ubuntu-branches/ubuntu/quantal/weston/quantal

« back to all changes in this revision

Viewing changes to debian/patches/git.diff

  • Committer: Package Import Robot
  • Author(s): Benjamin Kerensa
  • Date: 2012-09-13 02:33:39 UTC
  • Revision ID: package-import@ubuntu.com-20120913023339-t2agby1oijvvosxp
Tags: 0.95.0-0ubuntu2
* debian/control: added Homepage field
* debian/control: bump Standards-Version to 3.9.3 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: git diff against the tarball
2
 
 
3
 
--- /dev/null
4
 
+++ weston-0.95.0/weston.ini
5
 
@@ -0,0 +1,34 @@
6
 
+[shell]
7
 
+type=desktop-shell.so
8
 
+background-image=/usr/share/backgrounds/gnome/Aqua.jpg
9
 
+background-color=0xff002244
10
 
+panel-color=0x90ff0000
11
 
+locking=true
12
 
+animation=zoom
13
 
+#binding-modifier=ctrl
14
 
+
15
 
+#type=tablet-shell.so
16
 
+#lockscreen-icon=/usr/share/icons/gnome/256x256/actions/lock.png
17
 
+#lockscreen=/usr/share/backgrounds/gnome/Garden.jpg
18
 
+#homescreen=/usr/share/backgrounds/gnome/Blinds.jpg
19
 
+#animation=fade
20
 
+[launcher]
21
 
+icon=/usr/share/icons/gnome/24x24/apps/utilities-terminal.png
22
 
+path=/usr/bin/gnome-terminal
23
 
+
24
 
+[launcher]
25
 
+icon=/usr/share/icons/gnome/24x24/apps/utilities-terminal.png
26
 
+path=/usr/bin/weston-terminal
27
 
+
28
 
+[launcher]
29
 
+icon=/usr/share/icons/hicolor/24x24/apps/google-chrome.png
30
 
+path=/usr/bin/google-chrome
31
 
+
32
 
+[launcher]
33
 
+icon=/usr/share/icons/gnome/24x24/apps/arts.png
34
 
+path=./clients/flower
35
 
+
36
 
+[screensaver]
37
 
+# Uncomment path to disable screensaver
38
 
+path=/usr/libexec/weston-screensaver
39
 
+duration=600
40
 
--- /dev/null
41
 
+++ weston-0.95.0/autogen.sh
42
 
@@ -0,0 +1,9 @@
43
 
+#! /bin/sh
44
 
+
45
 
+test -n "$srcdir" || srcdir=`dirname "$0"`
46
 
+test -n "$srcdir" || srcdir=.
47
 
+(
48
 
+  cd "$srcdir" &&
49
 
+  autoreconf --force -v --install
50
 
+) || exit
51
 
+test -n "$NOCONFIGURE" || "$srcdir/configure" "$@"
52
 
--- /dev/null
53
 
+++ weston-0.95.0/protocol/text-cursor-position.xml
54
 
@@ -0,0 +1,11 @@
55
 
+<protocol name="text_cursor_position">
56
 
+
57
 
+  <interface name="text_cursor_position" version="1">
58
 
+    <request name="notify">
59
 
+      <arg name="surface" type="object" interface="wl_surface"/>
60
 
+      <arg name="x" type="fixed"/>
61
 
+      <arg name="y" type="fixed"/>
62
 
+    </request>
63
 
+  </interface>
64
 
+
65
 
+</protocol>