~ubuntu-branches/ubuntu/quantal/xshisen/quantal

« back to all changes in this revision

Viewing changes to debian/patches/10_oldfixes.patch

  • Committer: Package Import Robot
  • Author(s): gregor herrmann
  • Date: 2011-11-24 21:40:40 UTC
  • mfrom: (4.1.1 sid)
  • Revision ID: package-import@ubuntu.com-20111124214040-fv65k9t6s2co4i8k
Tags: 1:1.51-3.2
* Non-maintainer upload.
* Fix "ftbfs with gcc-4.5 and gcc-4.6": new patch 40_format_security.patch:
  Fix format string use. Based on Daniel T Chen's patch in the BTS.
  (Closes: #565064)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: xshisen-1.51/main.C
2
 
===================================================================
3
 
--- xshisen-1.51.orig/main.C    2011-10-21 18:12:57.000000000 -0400
4
 
+++ xshisen-1.51/main.C 2011-10-21 18:16:00.000000000 -0400
 
1
diff -Nur xshisen-1.51.orig/main.C xshisen-1.51/main.C
 
2
--- xshisen-1.51.orig/main.C
 
3
+++ xshisen-1.51/main.C
5
4
@@ -210,7 +210,7 @@
6
5
     char buffer[100], *p;
7
6
     char *(*codeconv)(const char*);
48
47
     }
49
48
     else {
50
49
         GetGameSize(initial_game_state, num_piece_x, num_piece_y);
51
 
Index: xshisen-1.51/menubar.C
52
 
===================================================================
53
 
--- xshisen-1.51.orig/menubar.C 2011-10-21 18:12:57.000000000 -0400
54
 
+++ xshisen-1.51/menubar.C      2011-10-21 18:16:00.000000000 -0400
 
50
diff -Nur xshisen-1.51.orig/menubar.C xshisen-1.51/menubar.C
 
51
--- xshisen-1.51.orig/menubar.C
 
52
+++ xshisen-1.51/menubar.C
55
53
@@ -158,8 +158,13 @@
56
54
                   (XtCallbackProc)GameCB, (XtPointer)1);
57
55
     XtAddCallback(XtNameToWidget(menushell0, "button_2"), XtNcallback,
66
64
     XtAddCallback(XtNameToWidget(menushell0, "button_4"), XtNcallback,
67
65
                   (XtCallbackProc)GameCB, (XtPointer)4);
68
66
     XtAddCallback(XtNameToWidget(menushell0, "button_5"), XtNcallback,
69
 
Index: xshisen-1.51/score.C
70
 
===================================================================
71
 
--- xshisen-1.51.orig/score.C   2011-10-21 18:12:57.000000000 -0400
72
 
+++ xshisen-1.51/score.C        2011-10-21 18:20:57.000000000 -0400
73
 
@@ -337,7 +337,7 @@
74
 
     }
75
 
     // Always read the latest high score
76
 
     readfile();
77
 
-    sprintf(format, res_strings[0]);
78
 
+    snprintf(format, sizeof(format)-1, "%s", res_strings[0]);
79
 
     prev_time = -1;
80
 
     for(int i=0; i<SCORENUM; i++) {
81
 
         this_time = rec[i].hour * 3600 + rec[i].min * 60 + rec[i].sec;
 
67
diff -Nur xshisen-1.51.orig/score.C xshisen-1.51/score.C
 
68
--- xshisen-1.51.orig/score.C
 
69
+++ xshisen-1.51/score.C
82
70
@@ -372,12 +372,15 @@
83
71
     time_t t;
84
72
     struct tm *tp;
85
73
     struct passwd *pw;
86
74
-    char   namebuf[128], myname[NAMELEN+1], gecos[128], *po;
87
75
+    char   namebuf[142], myname[NAMELEN+1], gecos[128], *po;
88
 
+
 
76
 
89
77
+#ifndef NO_GLOBAL_HIGHSCORE
90
 
 
 
78
+    
91
79
     s1 = scoreToRegister / 1000;
92
80
     ms_to_hms(scoreToRegister, h, m, s);
93
81
     pw = getpwuid(getuid());
118
106
         bp += strlen(bp);
119
107
         sprintf(bp, "    %-14.14s: %2.2d:%2.2d:%2.2d (%4.1f) %6d %s\n",
120
108
                 res_strings[8], t1, t2, t3, y, rcount[0], res_strings[11]);
121
 
Index: xshisen-1.51/readxpm.C
122
 
===================================================================
123
 
--- xshisen-1.51.orig/readxpm.C 2011-10-21 18:12:57.000000000 -0400
124
 
+++ xshisen-1.51/readxpm.C      2011-10-21 18:16:00.000000000 -0400
 
109
diff -Nur xshisen-1.51.orig/readxpm.C xshisen-1.51/readxpm.C
 
110
--- xshisen-1.51.orig/readxpm.C
 
111
+++ xshisen-1.51/readxpm.C
125
112
@@ -12,7 +12,7 @@
126
113
   char buffer[1024];
127
114
 
131
118
     Mp[i].ReadFile(w, buffer, i, globRes.colorCloseness);
132
119
   }
133
120
 }
134
 
Index: xshisen-1.51/Makefile.in
135
 
===================================================================
136
 
--- xshisen-1.51.orig/Makefile.in       2011-10-21 18:12:57.000000000 -0400
137
 
+++ xshisen-1.51/Makefile.in    2011-10-21 18:16:00.000000000 -0400
 
121
diff -Nur xshisen-1.51.orig/Makefile.in xshisen-1.51/Makefile.in
 
122
--- xshisen-1.51.orig/Makefile.in
 
123
+++ xshisen-1.51/Makefile.in
138
124
@@ -17,7 +17,7 @@
139
125
 
140
126
 XSHISENLIB = @datadir@/xshisen
190
176
 
191
177
 .SUFFIXES: .C
192
178
 .C.o:
193
 
Index: xshisen-1.51/lang/XShisen.ad
194
 
===================================================================
195
 
--- xshisen-1.51.orig/lang/XShisen.ad   2011-10-21 18:12:57.000000000 -0400
196
 
+++ xshisen-1.51/lang/XShisen.ad        2011-10-21 18:16:00.000000000 -0400
 
179
diff -Nur xshisen-1.51.orig/lang/XShisen.ad xshisen-1.51/lang/XShisen.ad
 
180
--- xshisen-1.51.orig/lang/XShisen.ad
 
181
+++ xshisen-1.51/lang/XShisen.ad
197
182
@@ -1,7 +1,7 @@
198
183
 ! Common resources
199
184
 XShisen*connectLineColor: blue
203
188
  Shisen-sho for X11    by Masaoki Kobayashi <masaoki@techfirm.co.jp>\n\
204
189
    Shisen-sho for Win  by Shinji Ono <ono@urban.ne.jp>\n\
205
190
    Picture             by Takayuki Akiyama <taco3@ybb.ne.jp>
206
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP.eucJP
207
 
===================================================================
208
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.eucJP       2011-10-21 18:12:57.000000000 -0400
209
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.eucJP    2011-10-21 18:16:00.000000000 -0400
210
 
@@ -1,7 +1,7 @@
211
 
 ! Common resources
212
 
 XShisen*connectLineColor: blue
213
 
 XShisen*connectLineTime: 1000
214
 
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
215
 
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
216
 
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
217
 
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
218
 
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
219
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP
220
 
===================================================================
221
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP     2011-10-21 18:12:57.000000000 -0400
222
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP  2011-10-21 18:16:00.000000000 -0400
223
 
@@ -1,7 +1,7 @@
224
 
 ! Common resources
225
 
 XShisen*connectLineColor: blue
226
 
 XShisen*connectLineTime: 1000
227
 
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
228
 
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
229
 
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
230
 
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
231
 
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
232
 
Index: xshisen-1.51/lang/XShisen.ad.ja
233
 
===================================================================
234
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja        2011-10-21 18:12:57.000000000 -0400
235
 
+++ xshisen-1.51/lang/XShisen.ad.ja     2011-10-21 18:16:00.000000000 -0400
236
 
@@ -1,7 +1,7 @@
237
 
 ! Common resources
238
 
 XShisen*connectLineColor: blue
239
 
 XShisen*connectLineTime: 1000
240
 
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
241
 
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
242
 
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
243
 
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
244
 
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
245
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP.SJIS
246
 
===================================================================
247
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.SJIS        2011-10-21 18:12:57.000000000 -0400
248
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.SJIS     2011-10-21 18:16:00.000000000 -0400
 
191
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP.eucJP xshisen-1.51/lang/XShisen.ad.ja_JP.eucJP
 
192
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.eucJP
 
193
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.eucJP
 
194
@@ -1,7 +1,7 @@
 
195
 ! Common resources
 
196
 XShisen*connectLineColor: blue
 
197
 XShisen*connectLineTime: 1000
 
198
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
 
199
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
 
200
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
 
201
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
 
202
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
 
203
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP xshisen-1.51/lang/XShisen.ad.ja_JP
 
204
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP
 
205
+++ xshisen-1.51/lang/XShisen.ad.ja_JP
 
206
@@ -1,7 +1,7 @@
 
207
 ! Common resources
 
208
 XShisen*connectLineColor: blue
 
209
 XShisen*connectLineTime: 1000
 
210
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
 
211
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
 
212
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
 
213
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
 
214
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
 
215
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja xshisen-1.51/lang/XShisen.ad.ja
 
216
--- xshisen-1.51.orig/lang/XShisen.ad.ja
 
217
+++ xshisen-1.51/lang/XShisen.ad.ja
 
218
@@ -1,7 +1,7 @@
 
219
 ! Common resources
 
220
 XShisen*connectLineColor: blue
 
221
 XShisen*connectLineTime: 1000
 
222
-XShisen*aboutString: ����� for X11 Ver XSHISEN_VERSION\n\n\
 
223
+XShisen*aboutString: ����� for X11 Ver 1.50\n\n\
 
224
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
 
225
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
 
226
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
 
227
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP.SJIS xshisen-1.51/lang/XShisen.ad.ja_JP.SJIS
 
228
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.SJIS
 
229
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.SJIS
249
230
@@ -1,7 +1,7 @@
250
231
 ! Common resources
251
232
 XShisen*connectLineColor: blue
255
236
  �l��� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
256
237
    �l��� for Win   by ���� �W�� <ono@urban.ne.jp>\n\
257
238
    �v�f�U�C��       by �H�R ���V <taco3@ybb.ne.jp>
258
 
Index: xshisen-1.51/lang/XShisen.ad.pl
259
 
===================================================================
260
 
--- xshisen-1.51.orig/lang/XShisen.ad.pl        2011-10-21 18:12:57.000000000 -0400
261
 
+++ xshisen-1.51/lang/XShisen.ad.pl     2011-10-21 18:16:00.000000000 -0400
 
239
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.pl xshisen-1.51/lang/XShisen.ad.pl
 
240
--- xshisen-1.51.orig/lang/XShisen.ad.pl
 
241
+++ xshisen-1.51/lang/XShisen.ad.pl
262
242
@@ -1,7 +1,7 @@
263
243
 ! Common resources
264
244
 XShisen*connectLineColor: blue
323
303
 XShisen*sform*translations: #replace <Btn1Down>: PickupPiece()\n\
324
304
         <Btn2Down>(2): menu(0,0)\n\
325
305
         <Btn3Down>: CancelPiece()\n\
326
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP.JIS7
327
 
===================================================================
328
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.JIS7        2011-10-21 18:12:57.000000000 -0400
329
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.JIS7     2011-10-21 18:16:00.000000000 -0400
 
306
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP.JIS7 xshisen-1.51/lang/XShisen.ad.ja_JP.JIS7
 
307
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.JIS7
 
308
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.JIS7
330
309
@@ -1,7 +1,7 @@
331
310
 ! Common resources
332
311
 XShisen*connectLineColor: blue
336
315
  $B;M@n>J(B for X11     by $B>.NS(B $B@56=(B <masaoki@techfirm.co.jp>\n\
337
316
    $B;M@n>J(B for Win   by $B>.Ln(B $B?8Fs(B <ono@urban.ne.jp>\n\
338
317
    $BGW%G%6%$%s(B       by $B=);3(B $BN4G7(B <taco3@ybb.ne.jp>
339
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP.ujis
340
 
===================================================================
341
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.ujis        2011-10-21 18:12:57.000000000 -0400
342
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.ujis     2011-10-21 18:16:00.000000000 -0400
 
318
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP.ujis xshisen-1.51/lang/XShisen.ad.ja_JP.ujis
 
319
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.ujis
 
320
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.ujis
343
321
@@ -1,7 +1,7 @@
344
322
 ! Common resources
345
323
 XShisen*connectLineColor: blue
349
327
  ����� for X11     by ���� ���� <masaoki@techfirm.co.jp>\n\
350
328
    ����� for Win   by ���� ���� <ono@urban.ne.jp>\n\
351
329
    �ץǥ�����       by ���� δǷ <taco3@ybb.ne.jp>
352
 
Index: xshisen-1.51/lang/XShisen.ad.ja_JP.PCK
353
 
===================================================================
354
 
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.PCK 2011-10-21 18:12:57.000000000 -0400
355
 
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.PCK      2011-10-21 18:16:00.000000000 -0400
 
330
diff -Nur xshisen-1.51.orig/lang/XShisen.ad.ja_JP.PCK xshisen-1.51/lang/XShisen.ad.ja_JP.PCK
 
331
--- xshisen-1.51.orig/lang/XShisen.ad.ja_JP.PCK
 
332
+++ xshisen-1.51/lang/XShisen.ad.ja_JP.PCK
356
333
@@ -1,7 +1,7 @@
357
334
 ! Common resources
358
335
 XShisen*connectLineColor: blue