~ubuntu-branches/ubuntu/quantal/zaptel/quantal

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_udev_rulesdir

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-01-13 02:42:26 UTC
  • Revision ID: james.westby@ubuntu.com-20090113024226-p1xe26sd40ljznk6
Tags: 1:1.4.11~dfsg-3ubuntu1
* debian/patches/ubuntu_udev_rulesdir: Install udev rules into
  /lib/udev/rules.d and prefix with a numeric
* debian/zaptel.dirs: Don't install old directory name
* debian/zaptel.install Install rules from new path
* debian/control: Add Breaks on udev to ensure we get the correct version

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/Makefile  2008-05-13 19:01:28.000000000 +0100
 
2
+++ b/Makefile  2009-01-13 02:41:30.000000000 +0000
 
3
@@ -66,7 +66,7 @@
 
4
 # Set HOTPLUG_FIRMWARE=no to override automatic building with hotplug support
 
5
 # if it is enabled in the kernel.
 
6
 ifeq ($(BUILDVER),linux26)
 
7
-  ifneq (,$(wildcard $(DESTDIR)/etc/udev/rules.d))
 
8
+  ifneq (,$(wildcard $(DESTDIR)/lib/udev/rules.d))
 
9
     DYNFS=yes
 
10
     UDEVRULES=yes
 
11
   endif
 
12
@@ -515,8 +515,8 @@
 
13
   ifneq (yes,$(UDEVRULES)) #!UDEVRULES
 
14
        @echo "**** Dynamic filesystem detected -- not creating device nodes"
 
15
   else # UDEVRULES
 
16
-       install -d $(DESTDIR)/etc/udev/rules.d
 
17
-       build_tools/genudevrules > $(DESTDIR)/etc/udev/rules.d/zaptel.rules
 
18
+       install -d $(DESTDIR)/lib/udev/rules.d
 
19
+       build_tools/genudevrules > $(DESTDIR)/lib/udev/rules.d/40-zaptel.rules
 
20
   endif
 
21
 endif
 
22
 
 
23
--- a/kernel/xpp/utils/Makefile~        2009-01-13 02:43:52.000000000 +0000
 
24
+++ b/kernel/xpp/utils/Makefile 2009-01-13 02:44:08.000000000 +0000
 
25
@@ -29,7 +29,7 @@
 
26
 DATADIR                = $(datadir)/zaptel
 
27
 MANDIR         = $(mandir)/man8
 
28
 HOTPLUG_USB_DIR        = /etc/hotplug/usb
 
29
-UDEV_RULES_DIR = /etc/udev/rules.d
 
30
+UDEV_RULES_DIR = /lib/udev/rules.d
 
31
 PERLLIBDIR     := $(shell eval `perl -V:vendorlib`; echo "$$vendorlib")
 
32
 PERL_DIRS      := $(shell cd zconf; find * -name '[A-Z]*' -type d| xargs)
 
33
 PERL_MODS_PAT  := *.pm $(PERL_DIRS:%=%/*.pm)
 
34
@@ -95,7 +95,7 @@
 
35
        # for backward compatibility and for hotplug users:
 
36
        ln -sf $(DATADIR)/xpp_fxloader $(DESTDIR)$(HOTPLUG_USB_DIR)/
 
37
        $(INSTALL) -d $(DESTDIR)$(UDEV_RULES_DIR)
 
38
-       $(INSTALL_DATA) xpp.rules $(DESTDIR)$(UDEV_RULES_DIR)/
 
39
+       $(INSTALL_DATA) xpp.rules $(DESTDIR)$(UDEV_RULES_DIR)/40-xpp.rules
 
40
 ifneq  (,$(PERLLIBDIR))
 
41
        $(INSTALL) -d $(DESTDIR)$(PERLLIBDIR)
 
42
        for i in $(PERL_DIRS); \