~ubuntu-branches/ubuntu/raring/autofs5/raring

« back to all changes in this revision

Viewing changes to debian/patches/13link_ldap_module_to_krb.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jan Christoph Nordholz
  • Date: 2008-06-12 22:24:27 UTC
  • Revision ID: james.westby@ubuntu.com-20080612222427-835z4g5518ex9wic
Tags: 5.0.3-2
* Update upstream patchset (2008/06/12) - five new patches.
* Bump Standards version to 3.8.0, debhelper to v7.
* Link ldap module against kerberos. Closes: #485470.
* /dev/urandom is sufficiently random for our purpose - use it
  instead of /dev/random, which might block. Closes: #481257.
* Add watch file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 13link_ldap_module_to_krb.dpatch by <hesso@pool.math.tu-berlin.de>
 
3
##
 
4
## DP: lookup_ldap.so has to be linked to libkrb5.so.
 
5
 
 
6
@DPATCH@
 
7
--- autofs5-5.0.3.orig/modules/Makefile 2008-06-12 21:53:14.000000000 +0200
 
8
+++ autofs5-5.0.3/modules/Makefile      2008-06-12 21:53:26.000000000 +0200
 
9
@@ -88,7 +88,7 @@
 
10
 
 
11
 lookup_ldap.so: lookup_ldap.c $(SASL_OBJ)
 
12
        $(CC) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
 
13
-               lookup_ldap.c $(SASL_OBJ) $(AUTOFS_LIB) $(LIBLDAP)
 
14
+               lookup_ldap.c $(SASL_OBJ) $(AUTOFS_LIB) $(LIBLDAP) -lkrb5
 
15
        $(STRIP) lookup_ldap.so
 
16
 
 
17
 mount_nfs.so: mount_nfs.c replicated.o