~ubuntu-branches/ubuntu/raring/autofs5/raring

« back to all changes in this revision

Viewing changes to debian/patches/01UPSTREAM_autofs-5.0.3-correct-ldap-lib.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jan Christoph Nordholz
  • Date: 2009-03-09 01:16:48 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20090309011648-gjynlid883f0s2c4
Tags: 5.0.4-1
* New upstream version (5.0.4 plus patchset as of 2009/03/09).
  * Closes: #518728.
  * Remove dpatch 14, applied upstream.
* New dpatch 14 to avoid using the relatively young SOCK_CLOEXEC
  feature.
* Only invoke 'make clean' on clean target so ./configure isn't
  purged.
* Fix a typo in the postinst regarding the ucf conffile handling.
* Add 'set -e' to package maintenance scripts.
* Drop unnecessary /var/run/autofs from package.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01UPSTREAM_autofs-5.0.3-correct-ldap-lib.patch
3
 
## DP: Supplied by upstream.
4
 
 
5
 
@DPATCH@
6
 
 
7
 
diff --git a/CHANGELOG b/CHANGELOG
8
 
index 5a85a8e..e393f33 100644
9
 
--- a/CHANGELOG
10
 
+++ b/CHANGELOG
11
 
@@ -4,6 +4,7 @@
12
 
 - catch "-xfn" map type and issue "no supported" message.
13
 
 - correction for handling of LDAP base dns with spaces.
14
 
 - avoid using UDP for probing NFSv4 mount requests.
15
 
+- use libldap instead of libldap_r (Guillaume Rousse).
16
 
  
17
 
 14/01/2008 autofs-5.0.3
18
 
 -----------------------
19
 
diff --git a/aclocal.m4 b/aclocal.m4
20
 
index f24e076..a1105ae 100644
21
 
--- a/aclocal.m4
22
 
+++ b/aclocal.m4
23
 
@@ -232,7 +232,7 @@ AC_DEFUN([AF_CHECK_FUNC_LDAP_CREATE_PAGE_CONTROL],
24
 
 
25
 
 # save current ldflags
26
 
 af_check_ldap_create_page_control_save_ldflags="$LDFLAGS"
27
 
-LDFLAGS="$LDFLAGS -lldap_r"
28
 
+LDFLAGS="$LDFLAGS -lldap"
29
 
 
30
 
 AC_TRY_LINK(
31
 
   [ #include <ldap.h> ],
32
 
@@ -265,7 +265,7 @@ AC_DEFUN([AF_CHECK_FUNC_LDAP_PARSE_PAGE_CONTROL],
33
 
 
34
 
 # save current ldflags
35
 
 af_check_ldap_parse_page_control_save_ldflags="$LDFLAGS"
36
 
-LDFLAGS="$LDFLAGS -lldap_r"
37
 
+LDFLAGS="$LDFLAGS -lldap"
38
 
 
39
 
 AC_TRY_LINK(
40
 
   [ #include <ldap.h> ],
41
 
diff --git a/configure b/configure
42
 
index e872392..0d3268c 100755
43
 
--- a/configure
44
 
+++ b/configure
45
 
@@ -4563,7 +4563,7 @@ fi
46
 
 { echo "$as_me:$LINENO: result: $ac_cv_lib_ldap_ldap_initialize" >&5
47
 
 echo "${ECHO_T}$ac_cv_lib_ldap_ldap_initialize" >&6; }
48
 
 if test $ac_cv_lib_ldap_ldap_initialize = yes; then
49
 
-  HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap_r -llber -lresolv"
50
 
+  HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap -llber -lresolv"
51
 
 fi
52
 
 
53
 
        if test "$HAVE_LDAP" = "1"; then
54
 
@@ -4578,7 +4578,7 @@ echo $ECHO_N "checking for ldap_create_page_control in -lldap... $ECHO_C" >&6; }
55
 
 
56
 
 # save current ldflags
57
 
 af_check_ldap_create_page_control_save_ldflags="$LDFLAGS"
58
 
-LDFLAGS="$LDFLAGS -lldap_r"
59
 
+LDFLAGS="$LDFLAGS -lldap"
60
 
 
61
 
 cat >conftest.$ac_ext <<_ACEOF
62
 
 /* confdefs.h.  */
63
 
@@ -4648,7 +4648,7 @@ echo $ECHO_N "checking for ldap_parse_page_control in -lldap... $ECHO_C" >&6; }
64
 
 
65
 
 # save current ldflags
66
 
 af_check_ldap_parse_page_control_save_ldflags="$LDFLAGS"
67
 
-LDFLAGS="$LDFLAGS -lldap_r"
68
 
+LDFLAGS="$LDFLAGS -lldap"
69
 
 
70
 
 cat >conftest.$ac_ext <<_ACEOF
71
 
 /* confdefs.h.  */
72
 
diff --git a/configure.in b/configure.in
73
 
index a9c86dd..27b9bec 100644
74
 
--- a/configure.in
75
 
+++ b/configure.in
76
 
@@ -197,7 +197,7 @@ AC_ARG_WITH(openldap,
77
 
 if test -z "$HAVE_LDAP" -o "$HAVE_LDAP" != "0"; then
78
 
        HAVE_LDAP=0
79
 
        LDAP_FLAGS="$LDAP_FLAGS -DLDAP_DEPRECATED=1"
80
 
-       AC_CHECK_LIB(ldap, ldap_initialize, HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap_r -llber -lresolv", ,
81
 
+       AC_CHECK_LIB(ldap, ldap_initialize, HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap -llber -lresolv", ,
82
 
                     -llber -lresolv $LIBS)
83
 
        if test "$HAVE_LDAP" = "1"; then
84
 
                AC_DEFINE(WITH_LDAP,1,