~ubuntu-branches/ubuntu/raring/clamav/raring

« back to all changes in this revision

Viewing changes to debian/patches/24_nullmailer_ftbfs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stephen Gran
  • Date: 2008-09-05 17:25:34 UTC
  • mfrom: (0.35.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080905172534-yi3f8fkye1o7u1r3
* New upstream version (closes: #497662, #497773)
  - lots of new options for clamd.conf
  - fixes CVEs CVE-2008-3912, CVE-2008-3913, CVE-2008-3914, and
    CVE-2008-1389
* No longer supports --unzip option, so typo is gone (closes: #496276)
* Translations:
  - sv (thanks Martin Bagge <brother@bsnet.se>) (closes: #491760)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## nullmailer_ftbfs.dpatch by  <sgran@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Fix FTBFS with nullmailer
6
 
 
7
 
@DPATCH@
8
 
Index: configure
9
 
===================================================================
10
 
--- a/configure (revision 488)
11
 
+++ b/configure (working copy)
12
 
@@ -14758,21 +14758,42 @@
13
 
     sendmailver_b=`echo $sendmailver | awk -F. '{printf $2}'`
14
 
     sendmailver_c=`echo $sendmailver | awk -F. '{printf $3}'`
15
 
 
16
 
+    case "$sendmailver_a" in
17
 
+      [[:digit:]]*) ;;
18
 
+      *) sendmailver_a= ;;
19
 
+    esac
20
 
+
21
 
+    case "$sendmailver_b" in
22
 
+      [[:digit:]]*) ;;
23
 
+      *) sendmailver_b= ;;
24
 
+    esac
25
 
+
26
 
+    case "$sendmailver_c" in
27
 
+      [[:digit:]]*) ;;
28
 
+      *) sendmailver_c= ;;
29
 
+    esac
30
 
+
31
 
+    if test -n "$sendmailver_a"; then
32
 
 
33
 
 cat >>confdefs.h <<_ACEOF
34
 
 #define SENDMAIL_VERSION_A $sendmailver_a
35
 
 _ACEOF
36
 
 
37
 
+    fi
38
 
+    if test -n "$sendmailver_b"; then
39
 
 
40
 
 cat >>confdefs.h <<_ACEOF
41
 
 #define SENDMAIL_VERSION_B $sendmailver_b
42
 
 _ACEOF
43
 
 
44
 
+    fi
45
 
+    if test -n "$sendmailver_c"; then
46
 
 
47
 
 cat >>confdefs.h <<_ACEOF
48
 
 #define SENDMAIL_VERSION_C $sendmailver_c
49
 
 _ACEOF
50
 
 
51
 
+    fi
52
 
   fi
53
 
 fi
54
 
 
55
 
Index: configure.in
56
 
===================================================================
57
 
--- a/configure.in      (revision 488)
58
 
+++ b/configure.in      (working copy)
59
 
@@ -468,9 +468,30 @@
60
 
     sendmailver_b=`echo $sendmailver | awk -F. '{printf $2}'`
61
 
     sendmailver_c=`echo $sendmailver | awk -F. '{printf $3}'`
62
 
 
63
 
-    AC_DEFINE_UNQUOTED([SENDMAIL_VERSION_A], $sendmailver_a, [major version of Sendmail])
64
 
-    AC_DEFINE_UNQUOTED([SENDMAIL_VERSION_B], $sendmailver_b, [minor version of Sendmail])
65
 
-    AC_DEFINE_UNQUOTED([SENDMAIL_VERSION_C], $sendmailver_c, [subversion of Sendmail])
66
 
+    case "$sendmailver_a" in
67
 
+      [[[:digit:]]]*) ;;
68
 
+      *) sendmailver_a= ;;
69
 
+    esac
70
 
+
71
 
+    case "$sendmailver_b" in
72
 
+      [[[:digit:]]]*) ;;
73
 
+      *) sendmailver_b= ;;
74
 
+    esac
75
 
+
76
 
+    case "$sendmailver_c" in
77
 
+      [[[:digit:]]]*) ;;
78
 
+      *) sendmailver_c= ;;
79
 
+    esac
80
 
+
81
 
+    if test -n "$sendmailver_a"; then
82
 
+      AC_DEFINE_UNQUOTED(SENDMAIL_VERSION_A, $sendmailver_a, [major version of Sendmail])
83
 
+    fi
84
 
+    if test -n "$sendmailver_b"; then
85
 
+      AC_DEFINE_UNQUOTED(SENDMAIL_VERSION_B, $sendmailver_b, [minor version of Sendmail])
86
 
+    fi
87
 
+    if test -n "$sendmailver_c"; then
88
 
+      AC_DEFINE_UNQUOTED(SENDMAIL_VERSION_C, $sendmailver_c, [subversion of Sendmail])
89
 
+    fi
90
 
   fi
91
 
 fi
92