~ubuntu-branches/ubuntu/raring/cloud-utils/raring-201302042112

« back to all changes in this revision

Viewing changes to debian/patches/support-m1-medium-and-x86_64-everywhere.patch

  • Committer: Package Import Robot
  • Author(s): Scott Moser
  • Date: 2012-07-12 13:38:44 UTC
  • Revision ID: package-import@ubuntu.com-20120712133844-m1pfam3g20h74oyq
Tags: 0.25-0ubuntu6
* Sync to upstream trunk at revision 188
  * adds cloudimg-sync and ubuntu-cloudimg-query2 [Ben Howard]
* debian/control: run wrap-and-sort 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
------------------------------------------------------------
2
 
revno: 177
3
 
committer: Scott Moser <smoser@ubuntu.com>
4
 
branch nick: trunk
5
 
timestamp: Fri 2012-03-09 09:27:58 -0500
6
 
message:
7
 
  update for "x86_64 on all sizes" and new size m1.medium
8
 
  
9
 
  This just removes code that insisted m1.small and c1.medium were
10
 
  i386 only, and adds the new m1.medium type.
11
 
=== modified file 'bin/ubuntu-cloudimg-query'
12
 
--- old/bin/ubuntu-cloudimg-query       2012-02-28 19:02:25 +0000
13
 
+++ new/bin/ubuntu-cloudimg-query       2012-03-09 14:27:58 +0000
14
 
@@ -178,9 +178,7 @@
15
 
                [a-z][1-9].[0-9a-z]*|c[cg][1-9].*)
16
 
                        itype="$i";
17
 
                        case "${i}" in
18
 
-                               t1.micro) store=ebs;; # t1.micro does not imply arch
19
 
-                               m1.small|c1.medium) arch=i386;;
20
 
-                               *) arch=amd64;;
21
 
+                               t1.micro) store=ebs;; # t1.micro only supports ebs
22
 
                        esac
23
 
                        ;;
24
 
                http://*|https://*) burl=${i};;
25
 
 
26
 
=== modified file 'bin/ubuntu-ec2-run'
27
 
--- old/bin/ubuntu-ec2-run      2012-02-28 19:00:39 +0000
28
 
+++ new/bin/ubuntu-ec2-run      2012-03-09 14:27:58 +0000
29
 
@@ -95,13 +95,13 @@
30
 
    # cleaned from http://aws.amazon.com/ec2/instance-types/
31
 
    # t1.micro     NONE    # m2.2xlarge    850   # c1.xlarge    1690
32
 
    # m1.small      160    # m1.large      850   # m1.xlarge    1690
33
 
-   # c1.medium     350    # cc1.4xlarge  1690   # cc1.4xlarge  1690
34
 
-   # m2.xlarge     420    # m2.4xlarge   1690   # cg1.4xlarge  1690
35
 
-   #                                            # cc2.8xlarge  3370
36
 
+   # m1.medium     410    # cc1.4xlarge  1690   # cc1.4xlarge  1690
37
 
+   # c1.medium     350    # m2.4xlarge   1690   # cg1.4xlarge  1690
38
 
+   # m2.xlarge     420                          # cc2.8xlarge  3370
39
 
    bdmaps = [ ]
40
 
    if itype in ("t1.micro", "m1.small", "c1.medium"):
41
 
       pass # the first one is always attached. ephemeral0=sda2
42
 
-   elif itype in ("m2.xlarge"):
43
 
+   elif itype in ("m2.xlarge", "m1.medium"):
44
 
       pass # one 420 for m2.xlarge
45
 
    elif ( itype in ("m1.large", "m2.2xlarge") or 
46
 
           itype.startswith("cg1.") or itype.startswith("cc1.")):
47