~ubuntu-branches/ubuntu/raring/consolekit/raring

« back to all changes in this revision

Viewing changes to debian/patches/99-autoreconf.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2010-11-20 18:17:28 UTC
  • mfrom: (0.1.16 sid)
  • Revision ID: james.westby@ubuntu.com-20101120181728-8e5bwe4ttgmk4j41
Tags: 0.4.3-2
Add 01-retry-console-open-on-EIO.patch: As reported in LP: #544139,
ConsoleKit sometimes fails to track the active VT. This particular case
was tracked down to a race condition that happens if you try to open
/dev/console while the current TTY is currently being closed. This yields
an -EIO error, in which case CK should just try again. Thanks Colin Watson
for the patch!

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: consolekit/aclocal.m4
2
 
===================================================================
3
 
--- consolekit.orig/aclocal.m4  2010-09-20 03:08:40.997095837 +0200
4
 
+++ consolekit/aclocal.m4       2010-09-20 03:07:49.397100192 +0200
5
 
@@ -13,8 +13,8 @@
6
 
 
7
 
 m4_ifndef([AC_AUTOCONF_VERSION],
8
 
   [m4_copy([m4_PACKAGE_VERSION], [AC_AUTOCONF_VERSION])])dnl
9
 
-m4_if(m4_defn([AC_AUTOCONF_VERSION]), [2.66],,
10
 
-[m4_warning([this file was generated for autoconf 2.66.
11
 
+m4_if(m4_defn([AC_AUTOCONF_VERSION]), [2.67],,
12
 
+[m4_warning([this file was generated for autoconf 2.67.
13
 
 You have another version of autoconf.  It may work, but is not guaranteed to.
14
 
 If you have problems, you may need to regenerate the build system entirely.
15
 
 To do so, use the procedure documented by the package, typically `autoreconf'.])])
16
 
@@ -2922,14 +2922,10 @@
17
 
   # before this can be enabled.
18
 
   hardcode_into_libs=yes
19
 
 
20
 
-  # Add ABI-specific directories to the system library path.
21
 
-  sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
22
 
-
23
 
   # Append ld.so.conf contents to the search path
24
 
   if test -f /etc/ld.so.conf; then
25
 
     lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[  ]*hwcap[        ]/d;s/[:,      ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
26
 
-    sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
27
 
-
28
 
+    sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
29
 
   fi
30
 
 
31
 
   # We used to test for /lib/ld.so.1 and disable shared libraries on
32
 
@@ -2941,6 +2937,18 @@
33
 
   dynamic_linker='GNU/Linux ld.so'
34
 
   ;;
35
 
 
36
 
+netbsdelf*-gnu)
37
 
+  version_type=linux
38
 
+  need_lib_prefix=no
39
 
+  need_version=no
40
 
+  library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
41
 
+  soname_spec='${libname}${release}${shared_ext}$major'
42
 
+  shlibpath_var=LD_LIBRARY_PATH
43
 
+  shlibpath_overrides_runpath=no
44
 
+  hardcode_into_libs=yes
45
 
+  dynamic_linker='NetBSD ld.elf_so'
46
 
+  ;;
47
 
+
48
 
 netbsd*)
49
 
   version_type=sunos
50
 
   need_lib_prefix=no
51
 
@@ -3541,7 +3549,7 @@
52
 
   lt_cv_deplibs_check_method=pass_all
53
 
   ;;
54
 
 
55
 
-netbsd*)
56
 
+netbsd* | netbsdelf*-gnu)
57
 
   if echo __ELF__ | $CC -E - | $GREP __ELF__ > /dev/null; then
58
 
     lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|_pic\.a)$'
59
 
   else
60
 
@@ -4245,7 +4253,7 @@
61
 
            ;;
62
 
        esac
63
 
        ;;
64
 
-      netbsd*)
65
 
+      netbsd* | netbsdelf*-gnu)
66
 
        ;;
67
 
       *qnx* | *nto*)
68
 
         # QNX uses GNU C++, but need to define -shared option too, otherwise
69
 
@@ -4685,6 +4693,9 @@
70
 
   cygwin* | mingw* | cegcc*)
71
 
     _LT_TAGVAR(export_symbols_cmds, $1)='$NM $libobjs $convenience | $global_symbol_pipe | $SED -e '\''/^[[BCDGRS]][[ ]]/s/.*[[ ]]\([[^ ]]*\)/\1 DATA/;/^.*[[ ]]__nm__/s/^.*[[ ]]__nm__\([[^ ]]*\)[[ ]][[^ ]]*/\1 DATA/;/^I[[ ]]/d;/^[[AITW]][[ ]]/s/.* //'\'' | sort | uniq > $export_symbols'
72
 
   ;;
73
 
+  linux* | k*bsd*-gnu)
74
 
+    _LT_TAGVAR(link_all_deplibs, $1)=no
75
 
+  ;;
76
 
   *)
77
 
     _LT_TAGVAR(export_symbols_cmds, $1)='$NM $libobjs $convenience | $global_symbol_pipe | $SED '\''s/.* //'\'' | sort | uniq > $export_symbols'
78
 
   ;;
79
 
@@ -4749,6 +4760,9 @@
80
 
   openbsd*)
81
 
     with_gnu_ld=no
82
 
     ;;
83
 
+  linux* | k*bsd*-gnu)
84
 
+    _LT_TAGVAR(link_all_deplibs, $1)=no
85
 
+    ;;
86
 
   esac
87
 
 
88
 
   _LT_TAGVAR(ld_shlibs, $1)=yes
89
 
@@ -4970,7 +4984,7 @@
90
 
       fi
91
 
       ;;
92
 
 
93
 
-    netbsd*)
94
 
+    netbsd* | netbsdelf*-gnu)
95
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
96
 
        _LT_TAGVAR(archive_cmds, $1)='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
97
 
        wlarc=
98
 
@@ -5147,6 +5161,7 @@
99
 
        if test "$aix_use_runtimelinking" = yes; then
100
 
          shared_flag="$shared_flag "'${wl}-G'
101
 
        fi
102
 
+       _LT_TAGVAR(link_all_deplibs, $1)=no
103
 
       else
104
 
        # not using gcc
105
 
        if test "$host_cpu" = ia64; then
106
 
@@ -5397,7 +5412,7 @@
107
 
       _LT_TAGVAR(link_all_deplibs, $1)=yes
108
 
       ;;
109
 
 
110
 
-    netbsd*)
111
 
+    netbsd* | netbsdelf*-gnu)
112
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
113
 
        _LT_TAGVAR(archive_cmds, $1)='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags'  # a.out
114
 
       else
115
 
@@ -8626,7 +8641,7 @@
116
 
 Consider adjusting the PKG_CONFIG_PATH environment variable if you
117
 
 installed software in a non-standard prefix.
118
 
 
119
 
-_PKG_TEXT])
120
 
+_PKG_TEXT])dnl
121
 
         ])
122
 
 elif test $pkg_failed = untried; then
123
 
        AC_MSG_RESULT([no])
124
 
@@ -8637,7 +8652,7 @@
125
 
 
126
 
 _PKG_TEXT
127
 
 
128
 
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.])
129
 
+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])dnl
130
 
         ])
131
 
 else
132
 
        $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
133
 
Index: consolekit/configure
134
 
===================================================================
135
 
--- consolekit.orig/configure   2010-09-20 03:08:41.721090604 +0200
136
 
+++ consolekit/configure        2010-09-20 03:07:57.305091267 +0200
137
 
@@ -1,6 +1,6 @@
138
 
 #! /bin/sh
139
 
 # Guess values for system-dependent variables and create Makefiles.
140
 
-# Generated by GNU Autoconf 2.66 for ConsoleKit 0.4.2.
141
 
+# Generated by GNU Autoconf 2.67 for ConsoleKit 0.4.2.
142
 
 #
143
 
 # Report bugs to <https://bugs.freedesktop.org/enter_bug.cgi?product=ConsoleKit>.
144
 
 #
145
 
@@ -629,6 +629,8 @@
146
 
 HAVE_PAM_FALSE
147
 
 HAVE_PAM_TRUE
148
 
 CK_BACKEND
149
 
+CK_COMPILE_GNU_FALSE
150
 
+CK_COMPILE_GNU_TRUE
151
 
 CK_COMPILE_SOLARIS_FALSE
152
 
 CK_COMPILE_SOLARIS_TRUE
153
 
 CK_COMPILE_FREEBSD_FALSE
154
 
@@ -895,8 +897,9 @@
155
 
   fi
156
 
 
157
 
   case $ac_option in
158
 
-  *=*) ac_optarg=`expr "X$ac_option" : '[^=]*=\(.*\)'` ;;
159
 
-  *)   ac_optarg=yes ;;
160
 
+  *=?*) ac_optarg=`expr "X$ac_option" : '[^=]*=\(.*\)'` ;;
161
 
+  *=)   ac_optarg= ;;
162
 
+  *)    ac_optarg=yes ;;
163
 
   esac
164
 
 
165
 
   # Accept the important Cygnus configure options, so we can diagnose typos.
166
 
@@ -1591,7 +1594,7 @@
167
 
 if $ac_init_version; then
168
 
   cat <<\_ACEOF
169
 
 ConsoleKit configure 0.4.2
170
 
-generated by GNU Autoconf 2.66
171
 
+generated by GNU Autoconf 2.67
172
 
 
173
 
 Copyright (C) 2010 Free Software Foundation, Inc.
174
 
 This configure script is free software; the Free Software Foundation
175
 
@@ -1663,7 +1666,7 @@
176
 
     mv -f conftest.er1 conftest.err
177
 
   fi
178
 
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
179
 
-  test $ac_status = 0; } >/dev/null && {
180
 
+  test $ac_status = 0; } > conftest.i && {
181
 
         test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
182
 
         test ! -s conftest.err
183
 
        }; then :
184
 
@@ -1726,7 +1729,7 @@
185
 
 else
186
 
   ac_header_preproc=no
187
 
 fi
188
 
-rm -f conftest.err conftest.$ac_ext
189
 
+rm -f conftest.err conftest.i conftest.$ac_ext
190
 
 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_header_preproc" >&5
191
 
 $as_echo "$ac_header_preproc" >&6; }
192
 
 
193
 
@@ -1960,7 +1963,7 @@
194
 
 running configure, to aid debugging if configure makes a mistake.
195
 
 
196
 
 It was created by ConsoleKit $as_me 0.4.2, which was
197
 
-generated by GNU Autoconf 2.66.  Invocation command line was
198
 
+generated by GNU Autoconf 2.67.  Invocation command line was
199
 
 
200
 
   $ $0 $@
201
 
 
202
 
@@ -2218,7 +2221,7 @@
203
 
       || { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
204
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
205
 
 as_fn_error $? "failed to load site script $ac_site_file
206
 
-See \`config.log' for more details" "$LINENO" 5; }
207
 
+See \`config.log' for more details" "$LINENO" 5 ; }
208
 
   fi
209
 
 done
210
 
 
211
 
@@ -2445,11 +2448,11 @@
212
 
 '
213
 
 case `pwd` in
214
 
   *[\\\"\#\$\&\'\`$am_lf]*)
215
 
-    as_fn_error $? "unsafe absolute working directory name" "$LINENO" 5;;
216
 
+    as_fn_error $? "unsafe absolute working directory name" "$LINENO" 5 ;;
217
 
 esac
218
 
 case $srcdir in
219
 
   *[\\\"\#\$\&\'\`$am_lf\ \    ]*)
220
 
-    as_fn_error $? "unsafe srcdir value: \`$srcdir'" "$LINENO" 5;;
221
 
+    as_fn_error $? "unsafe srcdir value: \`$srcdir'" "$LINENO" 5 ;;
222
 
 esac
223
 
 
224
 
 # Do `set' in a subshell so we don't clobber the current shell's
225
 
@@ -3217,7 +3220,7 @@
226
 
 test -z "$CC" && { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
227
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
228
 
 as_fn_error $? "no acceptable C compiler found in \$PATH
229
 
-See \`config.log' for more details" "$LINENO" 5; }
230
 
+See \`config.log' for more details" "$LINENO" 5 ; }
231
 
 
232
 
 # Provide some information about the compiler.
233
 
 $as_echo "$as_me:${as_lineno-$LINENO}: checking for C compiler version" >&5
234
 
@@ -3332,7 +3335,7 @@
235
 
 { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
236
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
237
 
 as_fn_error 77 "C compiler cannot create executables
238
 
-See \`config.log' for more details" "$LINENO" 5; }
239
 
+See \`config.log' for more details" "$LINENO" 5 ; }
240
 
 else
241
 
   { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
242
 
 $as_echo "yes" >&6; }
243
 
@@ -3375,7 +3378,7 @@
244
 
   { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
245
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
246
 
 as_fn_error $? "cannot compute suffix of executables: cannot compile and link
247
 
-See \`config.log' for more details" "$LINENO" 5; }
248
 
+See \`config.log' for more details" "$LINENO" 5 ; }
249
 
 fi
250
 
 rm -f conftest conftest$ac_cv_exeext
251
 
 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_exeext" >&5
252
 
@@ -3434,7 +3437,7 @@
253
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
254
 
 as_fn_error $? "cannot run C compiled programs.
255
 
 If you meant to cross compile, use \`--host'.
256
 
-See \`config.log' for more details" "$LINENO" 5; }
257
 
+See \`config.log' for more details" "$LINENO" 5 ; }
258
 
     fi
259
 
   fi
260
 
 fi
261
 
@@ -3486,7 +3489,7 @@
262
 
 { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
263
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
264
 
 as_fn_error $? "cannot compute suffix of object files: cannot compile
265
 
-See \`config.log' for more details" "$LINENO" 5; }
266
 
+See \`config.log' for more details" "$LINENO" 5 ; }
267
 
 fi
268
 
 rm -f conftest.$ac_cv_objext conftest.$ac_ext
269
 
 fi
270
 
@@ -3876,7 +3879,7 @@
271
 
   # Broken: fails on valid input.
272
 
 continue
273
 
 fi
274
 
-rm -f conftest.err conftest.$ac_ext
275
 
+rm -f conftest.err conftest.i conftest.$ac_ext
276
 
 
277
 
   # OK, works on sane cases.  Now check whether nonexistent headers
278
 
   # can be detected and how.
279
 
@@ -3892,11 +3895,11 @@
280
 
 ac_preproc_ok=:
281
 
 break
282
 
 fi
283
 
-rm -f conftest.err conftest.$ac_ext
284
 
+rm -f conftest.err conftest.i conftest.$ac_ext
285
 
 
286
 
 done
287
 
 # Because of `break', _AC_PREPROC_IFELSE's cleaning code was skipped.
288
 
-rm -f conftest.err conftest.$ac_ext
289
 
+rm -f conftest.i conftest.err conftest.$ac_ext
290
 
 if $ac_preproc_ok; then :
291
 
   break
292
 
 fi
293
 
@@ -3935,7 +3938,7 @@
294
 
   # Broken: fails on valid input.
295
 
 continue
296
 
 fi
297
 
-rm -f conftest.err conftest.$ac_ext
298
 
+rm -f conftest.err conftest.i conftest.$ac_ext
299
 
 
300
 
   # OK, works on sane cases.  Now check whether nonexistent headers
301
 
   # can be detected and how.
302
 
@@ -3951,18 +3954,18 @@
303
 
 ac_preproc_ok=:
304
 
 break
305
 
 fi
306
 
-rm -f conftest.err conftest.$ac_ext
307
 
+rm -f conftest.err conftest.i conftest.$ac_ext
308
 
 
309
 
 done
310
 
 # Because of `break', _AC_PREPROC_IFELSE's cleaning code was skipped.
311
 
-rm -f conftest.err conftest.$ac_ext
312
 
+rm -f conftest.i conftest.err conftest.$ac_ext
313
 
 if $ac_preproc_ok; then :
314
 
 
315
 
 else
316
 
   { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
317
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
318
 
 as_fn_error $? "C preprocessor \"$CPP\" fails sanity check
319
 
-See \`config.log' for more details" "$LINENO" 5; }
320
 
+See \`config.log' for more details" "$LINENO" 5 ; }
321
 
 fi
322
 
 
323
 
 ac_ext=c
324
 
@@ -4651,7 +4654,7 @@
325
 
 test -z "$CC" && { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
326
 
 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
327
 
 as_fn_error $? "no acceptable C compiler found in \$PATH
328
 
-See \`config.log' for more details" "$LINENO" 5; }
329
 
+See \`config.log' for more details" "$LINENO" 5 ; }
330
 
 
331
 
 # Provide some information about the compiler.
332
 
 $as_echo "$as_me:${as_lineno-$LINENO}: checking for C compiler version" >&5
333
 
@@ -5207,7 +5210,7 @@
334
 
 $as_echo "$ac_cv_build" >&6; }
335
 
 case $ac_cv_build in
336
 
 *-*-*) ;;
337
 
-*) as_fn_error $? "invalid value of canonical build" "$LINENO" 5;;
338
 
+*) as_fn_error $? "invalid value of canonical build" "$LINENO" 5 ;;
339
 
 esac
340
 
 build=$ac_cv_build
341
 
 ac_save_IFS=$IFS; IFS='-'
342
 
@@ -5240,7 +5243,7 @@
343
 
 $as_echo "$ac_cv_host" >&6; }
344
 
 case $ac_cv_host in
345
 
 *-*-*) ;;
346
 
-*) as_fn_error $? "invalid value of canonical host" "$LINENO" 5;;
347
 
+*) as_fn_error $? "invalid value of canonical host" "$LINENO" 5 ;;
348
 
 esac
349
 
 host=$ac_cv_host
350
 
 ac_save_IFS=$IFS; IFS='-'
351
 
@@ -6278,7 +6281,7 @@
352
 
   lt_cv_deplibs_check_method=pass_all
353
 
   ;;
354
 
 
355
 
-netbsd*)
356
 
+netbsd* | netbsdelf*-gnu)
357
 
   if echo __ELF__ | $CC -E - | $GREP __ELF__ > /dev/null; then
358
 
     lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|_pic\.a)$'
359
 
   else
360
 
@@ -8894,6 +8897,9 @@
361
 
   openbsd*)
362
 
     with_gnu_ld=no
363
 
     ;;
364
 
+  linux* | k*bsd*-gnu)
365
 
+    link_all_deplibs=no
366
 
+    ;;
367
 
   esac
368
 
 
369
 
   ld_shlibs=yes
370
 
@@ -9115,7 +9121,7 @@
371
 
       fi
372
 
       ;;
373
 
 
374
 
-    netbsd*)
375
 
+    netbsd* | netbsdelf*-gnu)
376
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
377
 
        archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
378
 
        wlarc=
379
 
@@ -9292,6 +9298,7 @@
380
 
        if test "$aix_use_runtimelinking" = yes; then
381
 
          shared_flag="$shared_flag "'${wl}-G'
382
 
        fi
383
 
+       link_all_deplibs=no
384
 
       else
385
 
        # not using gcc
386
 
        if test "$host_cpu" = ia64; then
387
 
@@ -9666,7 +9673,7 @@
388
 
       link_all_deplibs=yes
389
 
       ;;
390
 
 
391
 
-    netbsd*)
392
 
+    netbsd* | netbsdelf*-gnu)
393
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
394
 
        archive_cmds='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags'  # a.out
395
 
       else
396
 
@@ -10628,14 +10635,10 @@
397
 
   # before this can be enabled.
398
 
   hardcode_into_libs=yes
399
 
 
400
 
-  # Add ABI-specific directories to the system library path.
401
 
-  sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
402
 
-
403
 
   # Append ld.so.conf contents to the search path
404
 
   if test -f /etc/ld.so.conf; then
405
 
     lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[      ]*hwcap[        ]/d;s/[:,      ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
406
 
-    sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
407
 
-
408
 
+    sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
409
 
   fi
410
 
 
411
 
   # We used to test for /lib/ld.so.1 and disable shared libraries on
412
 
@@ -10647,6 +10650,18 @@
413
 
   dynamic_linker='GNU/Linux ld.so'
414
 
   ;;
415
 
 
416
 
+netbsdelf*-gnu)
417
 
+  version_type=linux
418
 
+  need_lib_prefix=no
419
 
+  need_version=no
420
 
+  library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
421
 
+  soname_spec='${libname}${release}${shared_ext}$major'
422
 
+  shlibpath_var=LD_LIBRARY_PATH
423
 
+  shlibpath_overrides_runpath=no
424
 
+  hardcode_into_libs=yes
425
 
+  dynamic_linker='NetBSD ld.elf_so'
426
 
+  ;;
427
 
+
428
 
 netbsd*)
429
 
   version_type=sunos
430
 
   need_lib_prefix=no
431
 
@@ -12760,7 +12775,6 @@
432
 
 Alternatively, you may set the environment variables CONSOLE_KIT_CFLAGS
433
 
 and CONSOLE_KIT_LIBS to avoid the need to call pkg-config.
434
 
 See the pkg-config man page for more details." "$LINENO" 5
435
 
-
436
 
 elif test $pkg_failed = untried; then
437
 
        { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
438
 
 $as_echo "no" >&6; }
439
 
@@ -12775,8 +12789,7 @@
440
 
 See the pkg-config man page for more details.
441
 
 
442
 
 To get pkg-config, see <http://pkg-config.freedesktop.org/>.
443
 
-See \`config.log' for more details" "$LINENO" 5; }
444
 
-
445
 
+See \`config.log' for more details" "$LINENO" 5 ; }
446
 
 else
447
 
        CONSOLE_KIT_CFLAGS=$pkg_cv_CONSOLE_KIT_CFLAGS
448
 
        CONSOLE_KIT_LIBS=$pkg_cv_CONSOLE_KIT_LIBS
449
 
@@ -12945,7 +12958,6 @@
450
 
 Alternatively, you may set the environment variables LIBDBUS_CFLAGS
451
 
 and LIBDBUS_LIBS to avoid the need to call pkg-config.
452
 
 See the pkg-config man page for more details." "$LINENO" 5
453
 
-
454
 
 elif test $pkg_failed = untried; then
455
 
        { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
456
 
 $as_echo "no" >&6; }
457
 
@@ -12960,8 +12972,7 @@
458
 
 See the pkg-config man page for more details.
459
 
 
460
 
 To get pkg-config, see <http://pkg-config.freedesktop.org/>.
461
 
-See \`config.log' for more details" "$LINENO" 5; }
462
 
-
463
 
+See \`config.log' for more details" "$LINENO" 5 ; }
464
 
 else
465
 
        LIBDBUS_CFLAGS=$pkg_cv_LIBDBUS_CFLAGS
466
 
        LIBDBUS_LIBS=$pkg_cv_LIBDBUS_LIBS
467
 
@@ -13054,7 +13065,6 @@
468
 
 Alternatively, you may set the environment variables TOOLS_CFLAGS
469
 
 and TOOLS_LIBS to avoid the need to call pkg-config.
470
 
 See the pkg-config man page for more details." "$LINENO" 5
471
 
-
472
 
 elif test $pkg_failed = untried; then
473
 
        { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
474
 
 $as_echo "no" >&6; }
475
 
@@ -13069,8 +13079,7 @@
476
 
 See the pkg-config man page for more details.
477
 
 
478
 
 To get pkg-config, see <http://pkg-config.freedesktop.org/>.
479
 
-See \`config.log' for more details" "$LINENO" 5; }
480
 
-
481
 
+See \`config.log' for more details" "$LINENO" 5 ; }
482
 
 else
483
 
        TOOLS_CFLAGS=$pkg_cv_TOOLS_CFLAGS
484
 
        TOOLS_LIBS=$pkg_cv_TOOLS_LIBS
485
 
@@ -13155,7 +13164,6 @@
486
 
 Alternatively, you may set the environment variables HISTORY_CFLAGS
487
 
 and HISTORY_LIBS to avoid the need to call pkg-config.
488
 
 See the pkg-config man page for more details." "$LINENO" 5
489
 
-
490
 
 elif test $pkg_failed = untried; then
491
 
        { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
492
 
 $as_echo "no" >&6; }
493
 
@@ -13170,8 +13178,7 @@
494
 
 See the pkg-config man page for more details.
495
 
 
496
 
 To get pkg-config, see <http://pkg-config.freedesktop.org/>.
497
 
-See \`config.log' for more details" "$LINENO" 5; }
498
 
-
499
 
+See \`config.log' for more details" "$LINENO" 5 ; }
500
 
 else
501
 
        HISTORY_CFLAGS=$pkg_cv_HISTORY_CFLAGS
502
 
        HISTORY_LIBS=$pkg_cv_HISTORY_LIBS
503
 
@@ -13502,7 +13509,7 @@
504
 
 CK_BACKEND=""
505
 
 KVM_LIBS=""
506
 
 case "$host" in
507
 
-        *-*-freebsd*)
508
 
+        *-*-freebsd* | *-*-kfreebsd*-gnu)
509
 
         CK_BACKEND="freebsd"
510
 
         { $as_echo "$as_me:${as_lineno-$LINENO}: checking for kvm_openfiles in -lkvm" >&5
511
 
 $as_echo_n "checking for kvm_openfiles in -lkvm... " >&6; }
512
 
@@ -13556,6 +13563,9 @@
513
 
         *-*-solaris*)
514
 
         CK_BACKEND="solaris"
515
 
         ;;
516
 
+        *-*-gnu*)
517
 
+        CK_BACKEND="gnu"
518
 
+        ;;
519
 
        *)
520
 
        as_fn_error $? "No sysdeps back-end implemented for host $host" "$LINENO" 5
521
 
        ;;
522
 
@@ -13587,6 +13597,14 @@
523
 
   CK_COMPILE_SOLARIS_FALSE=
524
 
 fi
525
 
 
526
 
+ if test x$CK_BACKEND = xgnu; then
527
 
+  CK_COMPILE_GNU_TRUE=
528
 
+  CK_COMPILE_GNU_FALSE='#'
529
 
+else
530
 
+  CK_COMPILE_GNU_TRUE='#'
531
 
+  CK_COMPILE_GNU_FALSE=
532
 
+fi
533
 
+
534
 
 
535
 
 
536
 
 
537
 
@@ -14177,6 +14195,10 @@
538
 
   as_fn_error $? "conditional \"CK_COMPILE_SOLARIS\" was never defined.
539
 
 Usually this means the macro was only invoked conditionally." "$LINENO" 5
540
 
 fi
541
 
+if test -z "${CK_COMPILE_GNU_TRUE}" && test -z "${CK_COMPILE_GNU_FALSE}"; then
542
 
+  as_fn_error $? "conditional \"CK_COMPILE_GNU\" was never defined.
543
 
+Usually this means the macro was only invoked conditionally." "$LINENO" 5
544
 
+fi
545
 
 if test -z "${HAVE_PAM_TRUE}" && test -z "${HAVE_PAM_FALSE}"; then
546
 
   as_fn_error $? "conditional \"HAVE_PAM\" was never defined.
547
 
 Usually this means the macro was only invoked conditionally." "$LINENO" 5
548
 
@@ -14606,7 +14628,7 @@
549
 
 # values after options handling.
550
 
 ac_log="
551
 
 This file was extended by ConsoleKit $as_me 0.4.2, which was
552
 
-generated by GNU Autoconf 2.66.  Invocation command line was
553
 
+generated by GNU Autoconf 2.67.  Invocation command line was
554
 
 
555
 
   CONFIG_FILES    = $CONFIG_FILES
556
 
   CONFIG_HEADERS  = $CONFIG_HEADERS
557
 
@@ -14672,7 +14694,7 @@
558
 
 ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
559
 
 ac_cs_version="\\
560
 
 ConsoleKit config.status 0.4.2
561
 
-configured by $0, generated by GNU Autoconf 2.66,
562
 
+configured by $0, generated by GNU Autoconf 2.67,
563
 
   with options \\"\$ac_cs_config\\"
564
 
 
565
 
 Copyright (C) 2010 Free Software Foundation, Inc.
566
 
@@ -14693,11 +14715,16 @@
567
 
 while test $# != 0
568
 
 do
569
 
   case $1 in
570
 
-  --*=*)
571
 
+  --*=?*)
572
 
     ac_option=`expr "X$1" : 'X\([^=]*\)='`
573
 
     ac_optarg=`expr "X$1" : 'X[^=]*=\(.*\)'`
574
 
     ac_shift=:
575
 
     ;;
576
 
+  --*=)
577
 
+    ac_option=`expr "X$1" : 'X\([^=]*\)='`
578
 
+    ac_optarg=
579
 
+    ac_shift=:
580
 
+    ;;
581
 
   *)
582
 
     ac_option=$1
583
 
     ac_optarg=$2
584
 
@@ -14719,6 +14746,7 @@
585
 
     $ac_shift
586
 
     case $ac_optarg in
587
 
     *\'*) ac_optarg=`$as_echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"` ;;
588
 
+    '') as_fn_error $? "missing file argument" ;;
589
 
     esac
590
 
     as_fn_append CONFIG_FILES " '$ac_optarg'"
591
 
     ac_need_defaults=false;;
592
 
@@ -15073,7 +15101,7 @@
593
 
     "pam-ck-connector/Makefile") CONFIG_FILES="$CONFIG_FILES pam-ck-connector/Makefile" ;;
594
 
     "config.h") CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
595
 
 
596
 
-  *) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
597
 
+  *) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5 ;;
598
 
   esac
599
 
 done
600
 
 
601
 
@@ -15389,7 +15417,7 @@
602
 
   esac
603
 
   case $ac_mode$ac_tag in
604
 
   :[FHL]*:*);;
605
 
-  :L* | :C*:*) as_fn_error $? "invalid tag \`$ac_tag'" "$LINENO" 5;;
606
 
+  :L* | :C*:*) as_fn_error $? "invalid tag \`$ac_tag'" "$LINENO" 5 ;;
607
 
   :[FH]-) ac_tag=-:-;;
608
 
   :[FH]*) ac_tag=$ac_tag:$ac_tag.in;;
609
 
   esac
610
 
@@ -15417,7 +15445,7 @@
611
 
           [\\/$]*) false;;
612
 
           *) test -f "$srcdir/$ac_f" && ac_f="$srcdir/$ac_f";;
613
 
           esac ||
614
 
-          as_fn_error 1 "cannot find input file: \`$ac_f'" "$LINENO" 5;;
615
 
+          as_fn_error 1 "cannot find input file: \`$ac_f'" "$LINENO" 5 ;;
616
 
       esac
617
 
       case $ac_f in *\'*) ac_f=`$as_echo "$ac_f" | sed "s/'/'\\\\\\\\''/g"`;; esac
618
 
       as_fn_append ac_file_inputs " '$ac_f'"
619
 
@@ -15444,7 +15472,7 @@
620
 
 
621
 
     case $ac_tag in
622
 
     *:-:* | *:-) cat >"$tmp/stdin" \
623
 
-      || as_fn_error $? "could not create $ac_file" "$LINENO" 5 ;;
624
 
+      || as_fn_error $? "could not create $ac_file" "$LINENO" 5  ;;
625
 
     esac
626
 
     ;;
627
 
   esac
628
 
Index: consolekit/src/Makefile.in
629
 
===================================================================
630
 
--- consolekit.orig/src/Makefile.in     2010-09-20 03:08:41.129094222 +0200
631
 
+++ consolekit/src/Makefile.in  2010-09-20 03:08:01.029091854 +0200
632
 
@@ -48,6 +48,10 @@
633
 
 @CK_COMPILE_FREEBSD_TRUE@      ck-sysdeps-freebsd.c    \
634
 
 @CK_COMPILE_FREEBSD_TRUE@      $(NULL)
635
 
 
636
 
+@CK_COMPILE_GNU_TRUE@am__append_4 = \
637
 
+@CK_COMPILE_GNU_TRUE@  ck-sysdeps-gnu.c        \
638
 
+@CK_COMPILE_GNU_TRUE@  $(NULL)
639
 
+
640
 
 sbin_PROGRAMS = console-kit-daemon$(EXEEXT) $(am__EXEEXT_1)
641
 
 noinst_PROGRAMS = test-event-logger$(EXEEXT) \
642
 
        test-tty-idle-monitor$(EXEEXT) test-vt-monitor$(EXEEXT) \
643
 
@@ -75,15 +79,19 @@
644
 
 @CK_COMPILE_FREEBSD_TRUE@libck_la_DEPENDENCIES =  \
645
 
 @CK_COMPILE_FREEBSD_TRUE@      $(am__DEPENDENCIES_1)
646
 
 am__libck_la_SOURCES_DIST = ck-sysdeps.h ck-sysdeps-unix.c \
647
 
-       ck-sysdeps-linux.c ck-sysdeps-solaris.c ck-sysdeps-freebsd.c
648
 
+       ck-sysdeps-linux.c ck-sysdeps-solaris.c ck-sysdeps-freebsd.c \
649
 
+       ck-sysdeps-gnu.c
650
 
 @CK_COMPILE_LINUX_TRUE@am__objects_2 = ck-sysdeps-linux.lo \
651
 
 @CK_COMPILE_LINUX_TRUE@        $(am__objects_1)
652
 
 @CK_COMPILE_SOLARIS_TRUE@am__objects_3 = ck-sysdeps-solaris.lo \
653
 
 @CK_COMPILE_SOLARIS_TRUE@      $(am__objects_1)
654
 
 @CK_COMPILE_FREEBSD_TRUE@am__objects_4 = ck-sysdeps-freebsd.lo \
655
 
 @CK_COMPILE_FREEBSD_TRUE@      $(am__objects_1)
656
 
+@CK_COMPILE_GNU_TRUE@am__objects_5 = ck-sysdeps-gnu.lo \
657
 
+@CK_COMPILE_GNU_TRUE@  $(am__objects_1)
658
 
 am_libck_la_OBJECTS = ck-sysdeps-unix.lo $(am__objects_1) \
659
 
-       $(am__objects_2) $(am__objects_3) $(am__objects_4)
660
 
+       $(am__objects_2) $(am__objects_3) $(am__objects_4) \
661
 
+       $(am__objects_5)
662
 
 libck_la_OBJECTS = $(am_libck_la_OBJECTS)
663
 
 am__EXEEXT_1 =
664
 
 am__installdirs = "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(dbusifdir)"
665
 
@@ -97,16 +105,16 @@
666
 
        ck-manager-glue.h ck-seat-glue.h ck-session-glue.h \
667
 
        ck-marshal.c ck-marshal.h ck-file-monitor-dummy.c \
668
 
        ck-file-monitor-inotify.c
669
 
-am__objects_5 = ck-marshal.$(OBJEXT) $(am__objects_1)
670
 
-@ENABLE_INOTIFY_FALSE@am__objects_6 = ck-file-monitor-dummy.$(OBJEXT)
671
 
-@ENABLE_INOTIFY_TRUE@am__objects_6 =  \
672
 
+am__objects_6 = ck-marshal.$(OBJEXT) $(am__objects_1)
673
 
+@ENABLE_INOTIFY_FALSE@am__objects_7 = ck-file-monitor-dummy.$(OBJEXT)
674
 
+@ENABLE_INOTIFY_TRUE@am__objects_7 =  \
675
 
 @ENABLE_INOTIFY_TRUE@  ck-file-monitor-inotify.$(OBJEXT)
676
 
 am_console_kit_daemon_OBJECTS = main.$(OBJEXT) ck-manager.$(OBJEXT) \
677
 
        ck-vt-monitor.$(OBJEXT) ck-tty-idle-monitor.$(OBJEXT) \
678
 
        ck-job.$(OBJEXT) ck-seat.$(OBJEXT) ck-session-leader.$(OBJEXT) \
679
 
        ck-session.$(OBJEXT) ck-log.$(OBJEXT) \
680
 
        ck-run-programs.$(OBJEXT) ck-event-logger.$(OBJEXT) \
681
 
-       $(am__objects_5) $(am__objects_1) $(am__objects_6)
682
 
+       $(am__objects_6) $(am__objects_1) $(am__objects_7)
683
 
 console_kit_daemon_OBJECTS = $(am_console_kit_daemon_OBJECTS)
684
 
 console_kit_daemon_DEPENDENCIES = $(am__DEPENDENCIES_1) \
685
 
        $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) libck.la \
686
 
@@ -122,7 +130,7 @@
687
 
        ck-file-monitor-dummy.c ck-file-monitor-inotify.c \
688
 
        test-tty-idle-monitor.c
689
 
 am_test_tty_idle_monitor_OBJECTS = ck-tty-idle-monitor.$(OBJEXT) \
690
 
-       $(am__objects_6) test-tty-idle-monitor.$(OBJEXT) \
691
 
+       $(am__objects_7) test-tty-idle-monitor.$(OBJEXT) \
692
 
        $(am__objects_1)
693
 
 test_tty_idle_monitor_OBJECTS = $(am_test_tty_idle_monitor_OBJECTS)
694
 
 test_tty_idle_monitor_DEPENDENCIES = $(am__DEPENDENCIES_1) \
695
 
@@ -428,13 +436,16 @@
696
 
        $(NULL)
697
 
 
698
 
 libck_la_SOURCES = ck-sysdeps.h ck-sysdeps-unix.c $(NULL) \
699
 
-       $(am__append_1) $(am__append_2) $(am__append_3)
700
 
+       $(am__append_1) $(am__append_2) $(am__append_3) \
701
 
+       $(am__append_4)
702
 
 @CK_COMPILE_FREEBSD_TRUE@libck_la_LIBADD = $(KVM_LIBS)
703
 
+@CK_COMPILE_GNU_TRUE@libck_la_LIBADD = -lps
704
 
 @CK_COMPILE_SOLARIS_TRUE@libck_la_LIBADD = -lscf
705
 
 EXTRA_libck_la_SOURCES = \
706
 
        ck-sysdeps-linux.c              \
707
 
        ck-sysdeps-solaris.c            \
708
 
        ck-sysdeps-freebsd.c            \
709
 
+       ck-sysdeps-gnu.c                \
710
 
        $(NULL)
711
 
 
712
 
 BUILT_SOURCES = \
713
 
@@ -658,6 +669,7 @@
714
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-session-leader.Po@am__quote@
715
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-session.Po@am__quote@
716
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-sysdeps-freebsd.Plo@am__quote@
717
 
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-sysdeps-gnu.Plo@am__quote@
718
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-sysdeps-linux.Plo@am__quote@
719
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-sysdeps-solaris.Plo@am__quote@
720
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ck-sysdeps-unix.Plo@am__quote@