~ubuntu-branches/ubuntu/raring/dkms/raring

« back to all changes in this revision

Viewing changes to debian/patches/666023.patch

  • Committer: Package Import Robot
  • Author(s): Felix Geyer
  • Date: 2012-07-26 11:43:22 UTC
  • mfrom: (2.1.19 sid)
  • Revision ID: package-import@ubuntu.com-20120726114322-vjtfqxvkgd2y4t2a
Tags: 2.2.0.3-1.1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Add apport_supported_kernel_packages.diff:
    Only report bugs about supported kernel versions.
  - Add Add-support-for-forcing-modules-installation.patch, backported
    from trunk:
    Add support to force module installation by adding files to
    /usr/share/dkms/modules_to_force_install
  - Add apport_python3.patch: Port apport hook to Python 3 and
    take care of opening the output file in binary mode
  - debian/control: added 'dpkg-dev' and 'debhelper' to Suggests.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Andreas Beckmann <debian@abeckmann.de>
 
2
Subject: do not fail if /lib/modules does not exist
 
3
Bug-Debian: http://bugs.debian.org/666023
 
4
 
 
5
diff --git a/dkms_common.postinst b/dkms_common.postinst
 
6
index d8cf3a7..0c8cfc1 100644
 
7
--- a/dkms_common.postinst
 
8
+++ b/dkms_common.postinst
 
9
@@ -146,7 +146,7 @@ if [ -z "$NAME" ] || [ -z "$VERSION" ]; then
 
10
     exit 1
 
11
 fi
 
12
 
 
13
-KERNELS=$(ls /lib/modules/)
 
14
+KERNELS=$(ls /lib/modules/ 2>/dev/null || true)
 
15
 CURRENT_KERNEL=$(uname -r)
 
16
 
 
17
 #We never want to keep an older version side by side to prevent conflicts