~ubuntu-branches/ubuntu/raring/dnstop/raring

« back to all changes in this revision

Viewing changes to debian/patches/Makefile.patch

  • Committer: Package Import Robot
  • Author(s): Marc Haber
  • Date: 2012-06-18 13:43:13 UTC
  • mfrom: (1.2.5) (2.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20120618134313-dtwt51sj7t56iftr
Tags: 20120611-2
remove dnstop.o rule from Makefile (fix hardening)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- Makefile.orig       2008-03-28 21:20:21.000000000 +0100
2
 
+++ Makefile    2008-03-28 22:11:20.000000000 +0100
3
 
@@ -1,5 +1,5 @@
4
 
 CFLAGS=-g -Wall
5
 
-OPTFLAGS=-DUSE_IPV6=1 -DUSE_PPP=0
6
 
+OPTFLAGS=-DUSE_IPV6=1 -DUSE_PPP=1
7
 
 PROG=dnstop
8
 
 DATE != date +%Y%m%d
9
 
 CC=gcc
10
 
@@ -14,8 +14,8 @@
11
 
        hashtbl.o \
12
 
        lookup3.o
13
 
 
14
 
-PREFIX=/usr/local
15
 
-BINDIR=$(PREFIX)/bin
16
 
+PREFIX=$(DESTDIR)/usr
17
 
+BINDIR=$(PREFIX)/sbin
18
 
 DATADIR=$(PREFIX)/share
19
 
 MANDIR=$(DATADIR)/man
20
 
 
21
 
@@ -44,6 +44,8 @@
22
 
        md5 *.gz > MD5s.txt
23
 
 
24
 
 install: $(PROG)
25
 
+       install -d $(BINDIR)
26
 
+       install -d $(MANDIR)/man8
27
 
        install -m 755 $(PROG) $(BINDIR)
28
 
        install -m 644 $(PROG).8 $(MANDIR)/man8
29