~ubuntu-branches/ubuntu/raring/enigma/raring

« back to all changes in this revision

Viewing changes to debian/patches/enigma-1.01-r1745.patch

  • Committer: Bazaar Package Importer
  • Author(s): Erich Schubert
  • Date: 2010-05-26 02:27:26 UTC
  • mfrom: (5.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20100526022726-7tnbf65s6btbibu2
Tags: 1.10~~pre-alpha+r2100-1
* New SVN checkout, shortly after upstream "pre-alpha" release
* Target unstable, to get more testing for enigma
* Remove spelling patches included upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: src/items.cc
2
 
===================================================================
3
 
--- src/items.cc        (Revision 1744)
4
 
+++ src/items.cc        (Revision 1745)
5
 
@@ -1423,7 +1423,7 @@
6
 
         void animcb() {
7
 
             GridPos p= get_pos();
8
 
             if ((server::GameCompatibility == GAMET_OXYDMAGNUM || server::GameCompatibility == GAMET_OXYD1) &&
9
 
-                (get_stone_name() == "st-wood-growing" && GetStone(p))) {
10
 
+                (!strcmp(get_stone_name(),"st-wood-growing") && GetStone(p))) {
11
 
                 string model = GetStone(p)->get_kind();
12
 
                 if (model == "st-grate1") {
13
 
                     SetFloor(p, MakeFloor("fl-stwood"));
14
 
@@ -3313,6 +3313,7 @@
15
 
                 }
16
 
                 return ITEM_KILL;
17
 
             }
18
 
+            return ITEM_KEEP;
19
 
         }
20
 
 
21
 
     public:
22
 
Index: src/main.cc
23
 
===================================================================
24
 
--- src/main.cc (Revision 1744)
25
 
+++ src/main.cc (Revision 1745)
26
 
@@ -300,6 +300,9 @@
27
 
     }
28
 
 
29
 
     // ----- Initialize SDL library
30
 
+#ifdef WIN32
31
 
+    SDL_putenv("SDL_VIDEODRIVER=directx");  //needed for SDL 1.2.12 that favors GDI which crashes on SetGamma
32
 
+#endif
33
 
     int sdl_flags = SDL_INIT_VIDEO;
34
 
     if (enigma::WizardMode)
35
 
         sdl_flags |= SDL_INIT_NOPARACHUTE;
36
 
Index: src/gui/LevelPackMenu.hh
37
 
===================================================================
38
 
--- src/gui/LevelPackMenu.hh    (Revision 1744)
39
 
+++ src/gui/LevelPackMenu.hh    (Revision 1745)
40
 
@@ -46,7 +46,7 @@
41
 
     class LevelPackMenu : public Menu {
42
 
     public:
43
 
         LevelPackMenu();
44
 
-        bool manageLevelMenu();
45
 
+        void manageLevelMenu();
46
 
         virtual bool manage();
47
 
 
48
 
         bool on_event (const SDL_Event &e);
49
 
Index: src/gui/LevelPackMenu.cc
50
 
===================================================================
51
 
--- src/gui/LevelPackMenu.cc    (Revision 1744)
52
 
+++ src/gui/LevelPackMenu.cc    (Revision 1745)
53
 
@@ -299,7 +299,7 @@
54
 
         }
55
 
     }
56
 
     
57
 
-    bool LevelPackMenu::manageLevelMenu() {
58
 
+    void LevelPackMenu::manageLevelMenu() {
59
 
         bool finished = false;
60
 
         while (!finished) {
61
 
             {        
62
 
Index: src/sound_internal.hh
63
 
===================================================================
64
 
--- src/sound_internal.hh       (Revision 1744)
65
 
+++ src/sound_internal.hh       (Revision 1745)
66
 
@@ -181,7 +181,7 @@
67
 
         bool play_music (const std::string &/*filename*/) { return false; }
68
 
         void stop_music() {}
69
 
         void fadeout_music() {}
70
 
-        bool play_sound (const SoundEvent &) {}
71
 
+        bool play_sound (const SoundEvent &) { return false;}
72
 
         void define_sound (const SoundName &, const std::string &/*filename*/) {}
73
 
         void define_sound (const SoundName &, const SoundData &) {}
74
 
         void set_listenerpos (ecl::V2 pos) {}
75
 
Index: src/lev/RatingManager.cc
76
 
===================================================================
77
 
--- src/lev/RatingManager.cc    (Revision 1744)
78
 
+++ src/lev/RatingManager.cc    (Revision 1745)
79
 
@@ -529,7 +529,7 @@
80
 
             default:
81
 
                 ecl::Assert <XFrontend> (false, "RatingManager::getBestScore illegal difficulty");
82
 
         }
83
 
-                
84
 
+        return -1;
85
 
     }
86
 
     
87
 
     std::string RatingManager::cutHolders(std::string org, int factor) {
88
 
@@ -566,6 +566,7 @@
89
 
             default:
90
 
                 ecl::Assert <XFrontend> (false, "RatingManager::getBestScoreHolder illegal difficulty");
91
 
         }
92
 
+        return "";
93
 
     }
94
 
 
95
 
     short RatingManager::getBestScoreEasy(Proxy *levelProxy) {
96
 
@@ -612,7 +613,7 @@
97
 
             default:
98
 
                 ecl::Assert <XFrontend> (false, "RatingManager::getParScore illegal difficulty");
99
 
         }
100
 
-                
101
 
+        return -1;
102
 
     }
103
 
     
104
 
     short RatingManager::getParScoreEasy(Proxy *levelProxy) {
105
 
Index: src/lev/ScoreManager.cc
106
 
===================================================================
107
 
--- src/lev/ScoreManager.cc     (Revision 1744)
108
 
+++ src/lev/ScoreManager.cc     (Revision 1745)
109
 
@@ -61,18 +61,24 @@
110
 
 namespace {
111
 
 #if _XERCES_VERSION >= 30000
112
 
     class ScoreDomSerFilter : public DOMLSSerializerFilter {
113
 
+        public:
114
 
+            virtual DOMNodeFilter::FilterAction acceptNode(const DOMNode *node) const;
115
 
 #else
116
 
     class ScoreDomSerFilter : public DOMWriterFilter {
117
 
-#endif
118
 
         public:
119
 
             virtual short acceptNode(const DOMNode *node) const;
120
 
+#endif
121
 
             virtual unsigned long getWhatToShow () const {
122
 
                 return DOMNodeFilter::SHOW_ALL;
123
 
             }
124
 
             virtual void setWhatToShow (unsigned long toShow) {}
125
 
     };
126
 
     
127
 
+#if _XERCES_VERSION >= 30000
128
 
+    DOMNodeFilter::FilterAction ScoreDomSerFilter::acceptNode(const DOMNode *node) const {
129
 
+#else
130
 
     short ScoreDomSerFilter::acceptNode(const DOMNode *node) const {
131
 
+#endif
132
 
         if (node->getNodeType () == DOMNode::ELEMENT_NODE &&
133
 
                  std::string(XMLtoUtf8(node->getNodeName()).c_str()) == "level") {
134
 
             const DOMElement *e = dynamic_cast<const DOMElement *>(node);
135
 
Index: src/stones_complex.cc
136
 
===================================================================
137
 
--- src/stones_complex.cc       (Revision 1744)
138
 
+++ src/stones_complex.cc       (Revision 1745)
139
 
@@ -3104,6 +3104,7 @@
140
 
                 return Value();
141
 
             }
142
 
         }
143
 
+        return Value();
144
 
     }
145
 
 
146
 
     void ChessStone::alarm() {
147
 
Index: src/lua.cc
148
 
===================================================================
149
 
--- src/lua.cc  (Revision 1744)
150
 
+++ src/lua.cc  (Revision 1745)
151
 
@@ -574,7 +574,7 @@
152
 
     int         y       = round_down<int>(lua_tonumber(L, 2));
153
 
     const char *dir     = lua_tostring(L,3);
154
 
     const char *allowed = "wsen";
155
 
-    char       *found   = strchr(allowed, dir[0]);
156
 
+    const char *found   = strchr(allowed, dir[0]);
157
 
 
158
 
     if (found && found[0]) 
159
 
         world::AddScramble(GridPos(x,y), enigma::Direction(found-allowed));
160
 
Index: lib-src/enigma-core/ecl_sys_localename.cc
161
 
===================================================================
162
 
--- lib-src/enigma-core/ecl_sys_localename.cc   (Revision 1744)
163
 
+++ lib-src/enigma-core/ecl_sys_localename.cc   (Revision 1745)
164
 
@@ -490,10 +490,10 @@
165
 
 # define SUBLANG_AZERI_CYRILLIC 0x02
166
 
 # endif
167
 
 # ifndef SUBLANG_BENGALI_INDIA
168
 
-# define SUBLANG_BENGALI_INDIA 0x00
169
 
+# define SUBLANG_BENGALI_INDIA 0x01
170
 
 # endif
171
 
 # ifndef SUBLANG_BENGALI_BANGLADESH
172
 
-# define SUBLANG_BENGALI_BANGLADESH 0x01
173
 
+# define SUBLANG_BENGALI_BANGLADESH 0x02
174
 
 # endif
175
 
 # ifndef SUBLANG_CHINESE_MACAU
176
 
 # define SUBLANG_CHINESE_MACAU 0x05
177
 
@@ -586,16 +586,16 @@
178
 
 # define SUBLANG_NEPALI_INDIA 0x02
179
 
 # endif
180
 
 # ifndef SUBLANG_PUNJABI_INDIA
181
 
-# define SUBLANG_PUNJABI_INDIA 0x00
182
 
+# define SUBLANG_PUNJABI_INDIA 0x01
183
 
 # endif
184
 
 # ifndef SUBLANG_PUNJABI_PAKISTAN
185
 
-# define SUBLANG_PUNJABI_PAKISTAN 0x01
186
 
+# define SUBLANG_PUNJABI_PAKISTAN 0x02
187
 
 # endif
188
 
 # ifndef SUBLANG_ROMANIAN_ROMANIA
189
 
-# define SUBLANG_ROMANIAN_ROMANIA 0x00
190
 
+# define SUBLANG_ROMANIAN_ROMANIA 0x01
191
 
 # endif
192
 
 # ifndef SUBLANG_ROMANIAN_MOLDOVA
193
 
-# define SUBLANG_ROMANIAN_MOLDOVA 0x01
194
 
+# define SUBLANG_ROMANIAN_MOLDOVA 0x02
195
 
 # endif
196
 
 # ifndef SUBLANG_SERBIAN_LATIN
197
 
 # define SUBLANG_SERBIAN_LATIN 0x02
198
 
@@ -603,12 +603,12 @@
199
 
 # ifndef SUBLANG_SERBIAN_CYRILLIC
200
 
 # define SUBLANG_SERBIAN_CYRILLIC 0x03
201
 
 # endif
202
 
-# ifndef SUBLANG_SINDHI_INDIA
203
 
-# define SUBLANG_SINDHI_INDIA 0x00
204
 
-# endif
205
 
 # ifndef SUBLANG_SINDHI_PAKISTAN
206
 
 # define SUBLANG_SINDHI_PAKISTAN 0x01
207
 
 # endif
208
 
+# ifndef SUBLANG_SINDHI_AFGHANISTAN
209
 
+# define SUBLANG_SINDHI_AFGHANISTAN 0x02
210
 
+# endif
211
 
 # ifndef SUBLANG_SPANISH_GUATEMALA
212
 
 # define SUBLANG_SPANISH_GUATEMALA 0x04
213
 
 # endif
214
 
@@ -666,14 +666,14 @@
215
 
 # ifndef SUBLANG_TAMAZIGHT_ARABIC
216
 
 # define SUBLANG_TAMAZIGHT_ARABIC 0x01
217
 
 # endif
218
 
-# ifndef SUBLANG_TAMAZIGHT_LATIN
219
 
-# define SUBLANG_TAMAZIGHT_LATIN 0x02
220
 
+# ifndef SUBLANG_TAMAZIGHT_ALGERIA_LATIN
221
 
+# define SUBLANG_TAMAZIGHT_ALGERIA_LATIN 0x02
222
 
 # endif
223
 
 # ifndef SUBLANG_TIGRINYA_ETHIOPIA
224
 
-# define SUBLANG_TIGRINYA_ETHIOPIA 0x00
225
 
+# define SUBLANG_TIGRINYA_ETHIOPIA 0x01
226
 
 # endif
227
 
 # ifndef SUBLANG_TIGRINYA_ERITREA
228
 
-# define SUBLANG_TIGRINYA_ERITREA 0x01
229
 
+# define SUBLANG_TIGRINYA_ERITREA 0x02
230
 
 # endif
231
 
 # ifndef SUBLANG_URDU_PAKISTAN
232
 
 # define SUBLANG_URDU_PAKISTAN 0x01
233
 
@@ -1060,8 +1060,8 @@
234
 
     case LANG_SINDHI:
235
 
       switch (sub)
236
 
        {
237
 
-       case SUBLANG_SINDHI_INDIA: return "sd_IN";
238
 
        case SUBLANG_SINDHI_PAKISTAN: return "sd_PK";
239
 
+       case SUBLANG_SINDHI_AFGHANISTAN: return "sd_AF";
240
 
        }
241
 
       return "sd";
242
 
     case LANG_SINHALESE: return "si_LK";
243
 
@@ -1114,7 +1114,7 @@
244
 
        {
245
 
        /* FIXME: Adjust this when Tamazight locales appear on Unix.  */
246
 
        case SUBLANG_TAMAZIGHT_ARABIC: return "ber_MA@arabic";
247
 
-       case SUBLANG_TAMAZIGHT_LATIN: return "ber_MA@latin";
248
 
+       case SUBLANG_TAMAZIGHT_ALGERIA_LATIN: return "ber_MA@latin";
249
 
        }
250
 
       return "ber_MA";
251
 
     case LANG_TAMIL:
252
 
Index: configure.ac
253
 
===================================================================
254
 
--- configure.ac        (Revision 1744)
255
 
+++ configure.ac        (Revision 1745)
256
 
@@ -123,7 +123,7 @@
257
 
 AC_CHECK_LIB(SDL_mixer, Mix_QuickLoad_RAW, have_mix_quickload="yes", have_mix_quickload="no")
258
 
 
259
 
 if test "$have_mix_quickload" = no; then
260
 
-   AC_MSG_ERROR([SDL_mixer >= 1.2.5 is required to compile Enigma])
261
 
+  AC_MSG_ERROR([SDL_mixer >= 1.2.5 is required to compile Enigma])
262
 
 fi
263
 
 
264
 
 dnl ----------------------------------------
265
 
@@ -167,22 +167,22 @@
266
 
 dnl Check for xerces
267
 
 dnl ----------------------------------------
268
 
 if test "$MINGW32" = yes; then
269
 
-  AC_MSG_CHECKING([for Xerces 3.0 experimental version])
270
 
+  AC_MSG_CHECKING([for Xerces release 3.0])
271
 
   AC_EGREP_HEADER([gXercesMajVersion = 3],[xercesc/util/XercesVersion.hpp],
272
 
       [AC_MSG_RESULT([found])],
273
 
       [AC_MSG_ERROR([not found])])      
274
 
-   AC_CHECK_LIB(xerces, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
275
 
+   AC_CHECK_LIB(xerces-c, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
276
 
 else
277
 
-  AC_MSG_CHECKING([for Xerces 3.0 experimental version])
278
 
+  AC_MSG_CHECKING([for current Xerces release 3.0])
279
 
   AC_EGREP_HEADER([gXercesMajVersion = 3],[xercesc/util/XercesVersion.hpp],
280
 
       xerces3exp="yes",
281
 
       xerces3exp="no")      
282
 
   if test "x$xerces3exp" = xyes; then
283
 
     AC_MSG_RESULT([found])
284
 
-    AC_CHECK_LIB(xerces, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
285
 
+    AC_CHECK_LIB(xerces-c, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
286
 
   else
287
 
     AC_MSG_RESULT([not found])
288
 
-    AC_MSG_CHECKING([for Xerces >=2.4 released version])
289
 
+    AC_MSG_CHECKING([for old Xerces release >=2.4])
290
 
     AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <xercesc/util/XercesVersion.hpp>]],
291
 
           [[if (XERCES_VERSION_MAJOR < 2)
292
 
               return 1;
293
 
Index: doc/REQUIREMENTS
294
 
===================================================================
295
 
--- doc/REQUIREMENTS    (Revision 1744)
296
 
+++ doc/REQUIREMENTS    (Revision 1745)
297
 
@@ -15,32 +15,31 @@
298
 
 
299
 
 Libraries:
300
 
 ----------
301
 
-SDL-devel       1.2.9, 1.2.11      (no 1.2.10 on Mac!) 
302
 
+SDL-devel       1.2.12 -  1.2.9, 1.2.11      (no 1.2.10 on Mac!) 
303
 
                 http://www.libsdl.org/download-1.2.php
304
 
                 SDL-devel-1.2.9-mingw32.tar.gz (Mingw32)
305
 
                 
306
 
-SDL_ttf-devel   2.0.7
307
 
+SDL_ttf-devel   2.0.9 -  2.0.7
308
 
                 http://www.libsdl.org/projects/SDL_ttf/
309
 
                 SDL_ttf-devel-2.0.7-VC6.zip (W)
310
 
                 
311
 
-SDL_mixer-devel 1.2.6
312
 
+SDL_mixer-devel 1.2.8 - 1.2.7
313
 
                 http://www.libsdl.org/projects/SDL_mixer/
314
 
                 SDL_mixer-devel-1.2.6-VC6.zip
315
 
                 
316
 
-SDL_image-devel 1.2.4
317
 
+SDL_image-devel 1.2.6
318
 
                 http://www.libsdl.org/projects/SDL_image/
319
 
                 SDL_image-devel-1.2.4-VC6.zip (W)
320
 
 
321
 
-Xerces-C        3.0 r454356     2.4 - 2.7 (L)   < 2.3 (L); 3.0 < r454356
322
 
+Xerces-C        3.0.1     2.4 - 3.0.1 (L)   < 2.3 (L); 3.0 < r671894
323
 
 Apache          2.7 : http://xml.apache.org/xerces-c/download.cgi
324
 
                       Linux: use rpm spec 
325
 
                 3.0 : https://svn.apache.org/repos/asf/xerces/c/trunk
326
 
                       Linux: ./configure --prefix=/mysweethome; make; install)
327
 
                       Windows: see doc/README.mingw
328
 
 
329
 
-libpng          1.2.7                           
330
 
-/GnuWin32       http://gnuwin32.sourceforge.net/packages/libpng.htm
331
 
-                Developer files (W)
332
 
+libpng          1.2.18  - must be compatible to dynamic SDL_imager libs                         
333
 
+               http://sourceforge.net/project/showfiles.php?group_id=5624                Developer files (W)
334
 
                 (The 1.2.8 dll is incompatible to SDL_image 1.2.4)
335
 
                 
336
 
 zlib            1.2.3
337
 
@@ -52,7 +51,9 @@
338
 
 
339
 
 gcc             3.4.2 (W)   - 4.0 (L)                    
340
 
 GNU/mingw       http://www.mingw.org/download.shtml
341
 
-                MinGW-4.1.0.exe + MinSYS-1.0.10.exe + msysDTK-1.0.1
342
 
+                MinGW-5.1.3.exe + MinSYS-1.0.10.exe + msysDTK-1.0.1 with
343
 
+               w32api 3.9 + binutils 2.16.91-20060119-1 +
344
 
+               gcc-core 3.4.2-20040916-1 + gcc-g++ 3.4.2-20040916-1    
345
 
                 (crosscompiler see doc/README.mingw and etc/build-cross.sh)
346
 
 
347
 
 autoconf        2.59                            <= 2.56
348
 
@@ -60,7 +61,7 @@
349
 
                 msys-autoconf-2.59.tar.bz2
350
 
 
351
 
 
352
 
-texi2html       1.76                            < 1.70 ?
353
 
+texi2html       1.78, 1.76                            < 1.70 ?
354
 
                 http://www.nongnu.org/texi2html/
355
 
 
356
 
 gettext         0.14.4
357
 
@@ -79,7 +80,7 @@
358
 
 AT&T            http://www.graphviz.org/About.php
359
 
                 (for source documentation)
360
 
 
361
 
-upx             1.2.5
362
 
+upx             3.00 -  1.2.5
363
 
                 http://upx.sourceforge.net/
364
 
 
365
 
 ccache          2.4 (L)
366
 
Index: intl/localename.c
367
 
===================================================================
368
 
--- intl/localename.c   (Revision 1744)
369
 
+++ intl/localename.c   (Revision 1745)
370
 
@@ -484,10 +484,10 @@
371
 
 # define SUBLANG_AZERI_CYRILLIC 0x02
372
 
 # endif
373
 
 # ifndef SUBLANG_BENGALI_INDIA
374
 
-# define SUBLANG_BENGALI_INDIA 0x00
375
 
+# define SUBLANG_BENGALI_INDIA 0x01
376
 
 # endif
377
 
 # ifndef SUBLANG_BENGALI_BANGLADESH
378
 
-# define SUBLANG_BENGALI_BANGLADESH 0x01
379
 
+# define SUBLANG_BENGALI_BANGLADESH 0x02
380
 
 # endif
381
 
 # ifndef SUBLANG_CHINESE_MACAU
382
 
 # define SUBLANG_CHINESE_MACAU 0x05
383
 
@@ -580,16 +580,16 @@
384
 
 # define SUBLANG_NEPALI_INDIA 0x02
385
 
 # endif
386
 
 # ifndef SUBLANG_PUNJABI_INDIA
387
 
-# define SUBLANG_PUNJABI_INDIA 0x00
388
 
+# define SUBLANG_PUNJABI_INDIA 0x01
389
 
 # endif
390
 
 # ifndef SUBLANG_PUNJABI_PAKISTAN
391
 
-# define SUBLANG_PUNJABI_PAKISTAN 0x01
392
 
+# define SUBLANG_PUNJABI_PAKISTAN 0x02
393
 
 # endif
394
 
 # ifndef SUBLANG_ROMANIAN_ROMANIA
395
 
-# define SUBLANG_ROMANIAN_ROMANIA 0x00
396
 
+# define SUBLANG_ROMANIAN_ROMANIA 0x01
397
 
 # endif
398
 
 # ifndef SUBLANG_ROMANIAN_MOLDOVA
399
 
-# define SUBLANG_ROMANIAN_MOLDOVA 0x01
400
 
+# define SUBLANG_ROMANIAN_MOLDOVA 0x02
401
 
 # endif
402
 
 # ifndef SUBLANG_SERBIAN_LATIN
403
 
 # define SUBLANG_SERBIAN_LATIN 0x02
404
 
@@ -597,12 +597,12 @@
405
 
 # ifndef SUBLANG_SERBIAN_CYRILLIC
406
 
 # define SUBLANG_SERBIAN_CYRILLIC 0x03
407
 
 # endif
408
 
-# ifndef SUBLANG_SINDHI_INDIA
409
 
-# define SUBLANG_SINDHI_INDIA 0x00
410
 
-# endif
411
 
 # ifndef SUBLANG_SINDHI_PAKISTAN
412
 
 # define SUBLANG_SINDHI_PAKISTAN 0x01
413
 
 # endif
414
 
+# ifndef SUBLANG_SINDHI_AFGHANISTAN
415
 
+# define SUBLANG_SINDHI_AFGHANISTAN 0x02
416
 
+# endif
417
 
 # ifndef SUBLANG_SPANISH_GUATEMALA
418
 
 # define SUBLANG_SPANISH_GUATEMALA 0x04
419
 
 # endif
420
 
@@ -660,14 +660,14 @@
421
 
 # ifndef SUBLANG_TAMAZIGHT_ARABIC
422
 
 # define SUBLANG_TAMAZIGHT_ARABIC 0x01
423
 
 # endif
424
 
-# ifndef SUBLANG_TAMAZIGHT_LATIN
425
 
-# define SUBLANG_TAMAZIGHT_LATIN 0x02
426
 
+# ifndef SUBLANG_TAMAZIGHT_ALGERIA_LATIN
427
 
+# define SUBLANG_TAMAZIGHT_ALGERIA_LATIN 0x02
428
 
 # endif
429
 
 # ifndef SUBLANG_TIGRINYA_ETHIOPIA
430
 
-# define SUBLANG_TIGRINYA_ETHIOPIA 0x00
431
 
+# define SUBLANG_TIGRINYA_ETHIOPIA 0x01
432
 
 # endif
433
 
 # ifndef SUBLANG_TIGRINYA_ERITREA
434
 
-# define SUBLANG_TIGRINYA_ERITREA 0x01
435
 
+# define SUBLANG_TIGRINYA_ERITREA 0x02
436
 
 # endif
437
 
 # ifndef SUBLANG_URDU_PAKISTAN
438
 
 # define SUBLANG_URDU_PAKISTAN 0x01
439
 
@@ -1038,8 +1038,8 @@
440
 
     case LANG_SINDHI:
441
 
       switch (sub)
442
 
        {
443
 
-       case SUBLANG_SINDHI_INDIA: return "sd_IN";
444
 
        case SUBLANG_SINDHI_PAKISTAN: return "sd_PK";
445
 
+       case SUBLANG_SINDHI_AFGHANISTAN: return "sd_AF";
446
 
        }
447
 
       return "sd";
448
 
     case LANG_SINHALESE: return "si_LK";
449
 
@@ -1092,7 +1092,7 @@
450
 
        {
451
 
        /* FIXME: Adjust this when Tamazight locales appear on Unix.  */
452
 
        case SUBLANG_TAMAZIGHT_ARABIC: return "ber_MA@arabic";
453
 
-       case SUBLANG_TAMAZIGHT_LATIN: return "ber_MA@latin";
454
 
+       case SUBLANG_TAMAZIGHT_ALGERIA_LATIN: return "ber_MA@latin";
455
 
        }
456
 
       return "ber_MA";
457
 
     case LANG_TAMIL: