~ubuntu-branches/ubuntu/raring/eog/raring

« back to all changes in this revision

Viewing changes to debian/patches/02_sanitize_sys.path.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2008-11-17 10:24:53 UTC
  • mfrom: (2.1.3 lenny)
  • Revision ID: james.westby@ubuntu.com-20081117102453-htjmd6xgd1g3x82r
Tags: 2.24.1-1ubuntu1
* Sync on Debian
* debian/control.in:
  - build-depends on liblaunchpad-integration-dev
  - update for the python build
* debian/patches/01_lpi.patch:
  - launchpad integration
* debian/patches/02_autoconf.patch:
  - configure update
* debian/rules:
  - update clean target
  - use --enable-python option and call dh_pycentral

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/src/eog-python-module.c
 
2
+++ b/src/eog-python-module.c
 
3
@@ -388,6 +388,9 @@
 
4
 
 
5
        PySys_SetArgv (1, argv);
 
6
 
 
7
+       /* Sanitize sys.path */
 
8
+       PyRun_SimpleString("import sys; sys.path = filter(None, sys.path)");
 
9
+
 
10
        if (!check_pygtk2 ()) {
 
11
                /* Warning message already printed in check_pygtk2 */
 
12
                goto python_init_error;