~ubuntu-branches/ubuntu/raring/file-roller/raring-security

« back to all changes in this revision

Viewing changes to debian/patches/99_ltmain_as-needed.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2012-05-14 18:57:27 UTC
  • mfrom: (2.1.19 sid)
  • Revision ID: package-import@ubuntu.com-20120514185727-26izf1ipd2al4y52
Tags: 3.4.2-1ubuntu1
* Merge with Debian. Remaining changes:
* debian/control.in:
  - Drop the scrollkeeper build-depends
  - Use the ubuntu epoch number for the nautilus depends
  - Depend on zip and unzip instead of p7zip which is in universe
  - Depend on genisoimage
  - Recommend sessioninstaller

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Bug-Debian: http://bugs.debian.org/347650
 
2
Last-Update: 2011-06-14
 
3
 
 
4
Index: file-roller-3.3.92/ltmain.sh
 
5
===================================================================
 
6
--- file-roller-3.3.92.orig/ltmain.sh   2012-03-20 00:21:26.000000000 +0100
 
7
+++ file-roller-3.3.92/ltmain.sh        2012-03-20 07:34:47.462360486 +0100
 
8
@@ -5800,6 +5800,11 @@
 
9
        arg=$func_stripname_result
 
10
        ;;
 
11
 
 
12
+      -Wl,--as-needed|-Wl,--no-as-needed)
 
13
+       deplibs="$deplibs $arg"
 
14
+       continue
 
15
+       ;;
 
16
+
 
17
       -Wl,*)
 
18
        func_stripname '-Wl,' '' "$arg"
 
19
        args=$func_stripname_result
 
20
@@ -6160,6 +6165,15 @@
 
21
        lib=
 
22
        found=no
 
23
        case $deplib in
 
24
+       -Wl,--as-needed|-Wl,--no-as-needed)
 
25
+         if test "$linkmode,$pass" = "prog,link"; then
 
26
+           compile_deplibs="$deplib $compile_deplibs"
 
27
+           finalize_deplibs="$deplib $finalize_deplibs"
 
28
+         else
 
29
+           deplibs="$deplib $deplibs"
 
30
+         fi
 
31
+         continue
 
32
+         ;;
 
33
        -mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe \
 
34
         |-threads|-fopenmp|-openmp|-mp|-xopenmp|-omp|-qsmp=*)
 
35
          if test "$linkmode,$pass" = "prog,link"; then