~ubuntu-branches/ubuntu/raring/gcc-4.7/raring

« back to all changes in this revision

Viewing changes to debian/patches/armhf-triplet.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2011-12-17 23:19:46 UTC
  • Revision ID: package-import@ubuntu.com-20111217231946-n668coanjbjgqxq7
Tags: 4.7-20111217-1
* GCC-4.7 snapshot build.
  - Including the GFDL documentation; will stay in experimental
    until the 4.7.0 release sometime next year.
* Update patches for the trunk.
* Update symbols files.
* Build libitm packages.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: add support for arm-linux-*eabi* triplets; useful for armhf
 
2
 
 
3
--- a/src/libjava/configure.ac.orig
 
4
+++ b/src/libjava/configure.ac
 
5
@@ -924,7 +924,7 @@
 
6
     # on Darwin -single_module speeds up loading of the dynamic libraries.
 
7
     extra_ldflags_libjava=-Wl,-single_module
 
8
     ;;
 
9
-arm*linux*eabi)
 
10
+arm*-*-linux-*eabi*)
 
11
     # Some of the ARM unwinder code is actually in libstdc++.  We
 
12
     # could in principle replicate it in libgcj, but it's better to
 
13
     # have a dependency on libstdc++.
 
14
--- a/src/gcc/config.gcc.orig
 
15
+++ b/src/gcc/config.gcc
 
16
@@ -822,7 +822,7 @@
 
17
        esac
 
18
        tmake_file="${tmake_file} t-linux arm/t-arm"
 
19
        case ${target} in
 
20
-       arm*-*-linux-*eabi)
 
21
+       arm*-*-linux-*eabi*)
 
22
            tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h"
 
23
            tm_file="$tm_file ../../libgcc/config/arm/bpabi-lib.h"
 
24
            tmake_file="$tmake_file arm/t-arm-elf arm/t-bpabi arm/t-linux-eabi t-slibgcc-libgcc"
 
25
@@ -850,7 +850,7 @@
 
26
        tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/linux-gas.h arm/uclinux-elf.h glibc-stdint.h"
 
27
        tmake_file="arm/t-arm arm/t-arm-elf"
 
28
        case ${target} in
 
29
-       arm*-*-uclinux*eabi)
 
30
+       arm*-*-uclinux*eabi*)
 
31
            tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h"
 
32
            tm_file="$tm_file ../../libgcc/config/arm/bpabi-lib.h"
 
33
            tmake_file="$tmake_file arm/t-bpabi"
 
34
--- a/src/gcc/testsuite/lib/target-supports.exp.orig
 
35
+++ b/src/gcc/testsuite/lib/target-supports.exp
 
36
@@ -3235,7 +3235,7 @@
 
37
             || [istarget i?86-*-*]
 
38
             || [istarget x86_64-*-*]
 
39
             || [istarget alpha*-*-*] 
 
40
-            || [istarget arm*-*-linux-gnueabi] 
 
41
+            || [istarget arm*-*-linux-*eabi*] 
 
42
             || [istarget bfin*-*linux*]
 
43
             || [istarget hppa*-*linux*]
 
44
             || [istarget s390*-*-*] 
 
45
@@ -3266,7 +3266,7 @@
 
46
             || [istarget i?86-*-*]
 
47
             || [istarget x86_64-*-*]
 
48
             || [istarget alpha*-*-*] 
 
49
-            || [istarget arm*-*-linux-gnueabi] 
 
50
+            || [istarget arm*-*-linux-*eabi*] 
 
51
             || [istarget hppa*-*linux*]
 
52
             || [istarget s390*-*-*] 
 
53
             || [istarget powerpc*-*-*]
 
54
--- a/src/gcc/ada/gcc-interface/Makefile.in.orig
 
55
+++ b/src/gcc/ada/gcc-interface/Makefile.in
 
56
@@ -1846,7 +1846,7 @@
 
57
   LIBRARY_VERSION := $(LIB_VERSION)
 
58
 endif
 
59
 
 
60
-ifeq ($(strip $(filter-out arm% linux-gnueabi,$(arch) $(osys)-$(word 4,$(targ)))),)
 
61
+ifeq ($(strip $(filter-out arm%-linux,$(arch)-$(osys)) $(if $(findstring eabi,$(word 4,$(targ))),,$(word 4,$(targ)))),)
 
62
   LIBGNAT_TARGET_PAIRS = \
 
63
   a-intnam.ads<a-intnam-linux.ads \
 
64
   s-inmaop.adb<s-inmaop-posix.adb \
 
65
--- a/src/libstdc++-v3/configure.host.orig
 
66
+++ b/src/libstdc++-v3/configure.host
 
67
@@ -322,7 +322,7 @@
 
68
         fi
 
69
     esac
 
70
     case "${host}" in
 
71
-      arm*-*-linux-*eabi)
 
72
+      arm*-*-linux-*eabi*)
 
73
        port_specific_symbol_files="\$(srcdir)/../config/os/gnu-linux/arm-eabi-extra.ver"
 
74
        ;;
 
75
     esac
 
76
--- a/src/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc.orig
 
77
+++ b/src/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc
 
78
@@ -1,5 +1,5 @@
 
79
 // { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
 
80
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
 
81
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
 
82
 
 
83
 // 2007-05-03  Benjamin Kosnik  <bkoz@redhat.com>
 
84
 //
 
85
--- a/src/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc.orig
 
86
+++ b/src/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc
 
87
@@ -1,5 +1,5 @@
 
88
 // { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
 
89
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
 
90
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
 
91
 
 
92
 // 2007-05-03  Benjamin Kosnik  <bkoz@redhat.com>
 
93
 //
 
94
--- a/src/libgcc/config.host
 
95
+++ b/src/libgcc/config.host
 
96
@@ -334,7 +334,7 @@
 
97
 arm*-*-linux*)                 # ARM GNU/Linux with ELF
 
98
        tmake_file="${tmake_file} arm/t-arm t-fixedpoint-gnu-prefix"
 
99
        case ${host} in
 
100
-       arm*-*-linux-*eabi)
 
101
+       arm*-*-linux-*eabi*)
 
102
          tmake_file="${tmake_file} arm/t-elf arm/t-bpabi arm/t-linux-eabi t-slibgcc-libgcc"
 
103
          tm_file="$tm_file arm/bpabi-lib.h"
 
104
          unwind_header=config/arm/unwind-arm.h