~ubuntu-branches/ubuntu/raring/gnome-orca/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_brlapi_fixes.patch

  • Committer: Package Import Robot
  • Author(s): Luke Yelavich
  • Date: 2012-11-21 09:52:26 UTC
  • mfrom: (0.12.4)
  • Revision ID: package-import@ubuntu.com-20121121095226-os5cwqi6ix4r2v15
Tags: 3.7.2-0ubuntu1
The below changelog entries are combined from 3.7.0.94, 3.7.0.100 and 3.7.2
* New upstream release
  - General
    + Fix for bug 675288 - Orca doesn't always announce selection changes
      in Nautilus 3.6's icon view
    + Fix for bug 680228 - In Thunderbird 14.0 e-mail address auto
      completion results are not spoken
    + Fix for bug 684838 - Orca should present the accessible name of
      sliders
    + Fix for bug 675656 - Mark Hungarian 8 dot computer braille for
      translation
    + Use subprocess.Popen() instead of the deprecated os.popen()
    + Use for() instead of map() in cleanup()
    + Pkill fails to kill Orca in Python 3
    + Fix for bug 686189 - Use importlib.import_module() instead of
      __import__() and imp.reload() instead of reload()
    + Fix for braille email address auto completions in Thunderbird
    + Replace deprecated GObject functions with their GLib equivalents
    + Improve performance of building flat review context
    + Add keywords to the desktop file
    + Python 3 compatibility fixes for brlapi
    + Fix for bug 687526 - Patch: Orca excepts trying to output exceptions
    + Fix for bug 687527 - Handle applications returning 0 as the Value's
      minimalIncrement
  - Gecko
    + Fix for bug 674526 - Orca sometimes fails to present download dialog
      widgets in Firefox
    + Fix for bug 688057 - A page that hangs Orca.
  - Speech
    + Most of the fix for bug 688172 - Orca gets stuck in uppercase pitch
    + Fix for Orca continuing to speak when speech is disabled via the
      Preferences dialog
    + Fix for bug 687239 - Traceback seen in Python 3.3 when there are no
      settings saved
  - New and updated translations (THANKS EVERYONE!!!):
    + bg            Bulgarian               Alexander Shopov
    + ca            Catalan                 Gil Forcada
    + ca            Catalan (Valencian)     Carles Ferrando
    + cs            Czech                   Lucas Lommer
    + de            German                  Simon Bienlein, Mario Blättermann
                                            Hendrik Knackstedt
    + hu            Hungarian              Attila Hammer
    + it            Italian                 Milo Casagrande
    + lv            Latvian                 Rudolfs Mazurs
    + sl            Slovenian               Matej Urbančič
    + pt            Portuguese              Rui Batista
    + ta            Tamil                   Dr.T.Vasudevan
    + uk            Ukranian                Daniel Korostil
* debian/patches/02_brlapi_fixes.patch: Dropped, applied upstream
* debian/control: Bumped minimum dependency requirements

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-orca-3.7.0.4/src/orca/braille.py
2
 
===================================================================
3
 
--- gnome-orca-3.7.0.4.orig/src/orca/braille.py 2012-07-17 02:36:49.000000000 +1000
4
 
+++ gnome-orca-3.7.0.4/src/orca/braille.py      2012-08-01 16:32:53.111428123 +1000
5
 
@@ -1382,7 +1382,7 @@
6
 
             if attributeMask:
7
 
                 attributeMask += '\x00'
8
 
             writeStruct.regionSize += 1
9
 
-        writeStruct.text = substring
10
 
+        writeStruct.text = substring.encode("utf-8")
11
 
         writeStruct.cursor = cursorCell
12
 
 
13
 
         # [[[WDW - if you want to muck around with the dots on the
14
 
@@ -1401,7 +1401,7 @@
15
 
         #writeStruct.attrOr = myUnderline
16
 
 
17
 
         if attributeMask:
18
 
-            writeStruct.attrOr = attributeMask[startPos:endPos]
19
 
+            writeStruct.attrOr = attributeMask[startPos:endPos].encode("utf-8")
20
 
 
21
 
         if not _brlAPIRunning:
22
 
             init(_callback, settings.tty)