~ubuntu-branches/ubuntu/raring/gnome-session/raring

« back to all changes in this revision

Viewing changes to debian/patches/12_no_gdm_fallback.patch

  • Committer: Package Import Robot
  • Author(s): Robert Ancell
  • Date: 2012-07-29 16:22:23 UTC
  • mfrom: (1.1.78)
  • Revision ID: package-import@ubuntu.com-20120729162223-zvvdhbwa7s8r0zdx
Tags: 3.5.4-0ubuntu1
* New upstream release
* debian/control:
  - Bump build-depends on libglib2.0-dev
* debian/patches/21_up_start_on_demand.patch:
  - Dropped, code has changed too much

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Don’t fall back to GDM when ConsoleKit fails. If CK is not available, it 
4
4
will not be attempted anyway.
5
5
 
6
 
Index: gnome-session-3.4.1/gnome-session/gsm-manager.c
 
6
Index: gnome-session-3.5.4/gnome-session/gsm-manager.c
7
7
===================================================================
8
 
--- gnome-session-3.4.1.orig/gnome-session/gsm-manager.c        2012-03-27 10:34:56.000000000 +0200
9
 
+++ gnome-session-3.4.1/gnome-session/gsm-manager.c     2012-04-25 00:03:14.416196315 +0200
10
 
@@ -504,7 +504,7 @@
11
 
                 g_signal_connect (system,
 
8
--- gnome-session-3.5.4.orig/gnome-session/gsm-manager.c        2012-07-19 13:41:23.511406643 +1200
 
9
+++ gnome-session-3.5.4/gnome-session/gsm-manager.c     2012-07-19 13:41:50.227405715 +1200
 
10
@@ -492,7 +492,7 @@
 
11
                 g_signal_connect (manager->priv->system,
12
12
                                   "request-completed",
13
13
                                   G_CALLBACK (quit_request_completed),
14
14
-                                  GINT_TO_POINTER (GDM_LOGOUT_ACTION_REBOOT));
15
15
+                                  GINT_TO_POINTER (GDM_LOGOUT_ACTION_NONE));
16
 
                 gsm_system_attempt_restart (system);
 
16
                 gsm_system_attempt_restart (manager->priv->system);
17
17
                 break;
18
18
         case GSM_MANAGER_LOGOUT_REBOOT_GDM:
19
 
@@ -519,7 +519,7 @@
20
 
                 g_signal_connect (system,
 
19
@@ -506,7 +506,7 @@
 
20
                 g_signal_connect (manager->priv->system,
21
21
                                   "request-completed",
22
22
                                   G_CALLBACK (quit_request_completed),
23
23
-                                  GINT_TO_POINTER (GDM_LOGOUT_ACTION_SHUTDOWN));
24
24
+                                  GINT_TO_POINTER (GDM_LOGOUT_ACTION_NONE));
25
 
                 gsm_system_attempt_stop (system);
 
25
                 gsm_system_attempt_stop (manager->priv->system);
26
26
                 break;
27
27
         case GSM_MANAGER_LOGOUT_SHUTDOWN_GDM: