~ubuntu-branches/ubuntu/raring/gtk+2.0/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/065_gir_set_packages.patch

  • Committer: Package Import Robot
  • Author(s): Ken VanDine
  • Date: 2011-10-18 15:25:41 UTC
  • Revision ID: package-import@ubuntu.com-20111018152541-rdh6zos2owllavez
Tags: 2.24.6-0ubuntu6
* debian/patches/065_gir_set_packages.patch
  - Merged changes from 064_gir_build_workaround.patch in and refreshed 
    to match what was resubmitted upstream.
* -debian/patches/064_gir_build_workaround.patch
  - Merged into 065_gir_set_packages.patch 
* debian/control.in
  - bumped standards version to 3.9.2

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'gdk/Makefile.am'
2
 
Index: gtk+-2.24.3/gdk/Makefile.am
3
 
===================================================================
4
 
--- gtk+-2.24.3.orig/gdk/Makefile.am    2011-03-15 18:00:46.403971555 +1100
5
 
+++ gtk+-2.24.3/gdk/Makefile.am 2011-03-15 18:00:47.964060326 +1100
6
 
@@ -3,6 +3,7 @@
 
1
From 57434e403a73ee3c543717278ed2a7d3dacfeffd Mon Sep 17 00:00:00 2001
 
2
From: Ken VanDine <ken.vandine@canonical.com>
 
3
Date: Tue, 18 Oct 2011 15:19:16 -0400
 
4
Subject: [PATCH] Include <package/> tag in generated GIR
 
5
 
 
6
Specify pkg-config name when generating GIR files, used for mapping GIR
 
7
name to pkg-config names
 
8
 
 
9
https://bugzilla.gnome.org/show_bug.cgi?id=635287
 
10
---
 
11
 gdk/Makefile.am |   10 +++++++---
 
12
 gtk/Makefile.am |    6 ++++--
 
13
 2 files changed, 11 insertions(+), 5 deletions(-)
 
14
 
 
15
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
 
16
index 4adb2f0..4aaba3b 100644
 
17
--- a/gdk/Makefile.am
 
18
+++ b/gdk/Makefile.am
 
19
@@ -3,6 +3,7 @@ include $(top_srcdir)/Makefile.decl
7
20
 -include $(INTROSPECTION_MAKEFILE)
8
21
 INTROSPECTION_GIRS =
9
22
 INTROSPECTION_SCANNER_ARGS = \
11
24
    --add-include-path=../gdk
12
25
 INTROSPECTION_COMPILER_ARGS = \
13
26
    --includedir=$(srcdir) \
14
 
@@ -198,10 +199,11 @@
 
27
@@ -198,10 +199,11 @@ introspection_files =             \
15
28
         gdkenumtypes.h
16
29
 
17
30
 Gdk-2.0.gir: $(gdktargetlib) Makefile
18
 
-Gdk_2_0_gir_SCANNERFLAGS = --warn-all --strip-prefix=Gdk
 
31
-Gdk_2_0_gir_SCANNERFLAGS = --warn-all
19
32
+Gdk_2_0_gir_SCANNERFLAGS = --c-include="gdk/gdk.h"
20
33
 Gdk_2_0_gir_INCLUDES = Gio-2.0 GdkPixbuf-2.0 Pango-1.0 cairo-1.0
21
34
 Gdk_2_0_gir_LIBS = $(gdktargetlib)
24
37
 Gdk_2_0_gir_CFLAGS = $(INCLUDES)
25
38
 INTROSPECTION_GIRS += Gdk-2.0.gir
26
39
 
27
 
@@ -239,10 +241,12 @@
 
40
@@ -239,10 +241,12 @@ x11_introspection_files =                 \
28
41
         x11/gdkx.h
29
42
 
30
43
 GdkX11-2.0.gir: $(gdktargetlib) Gdk-2.0.gir Makefile
36
49
 GdkX11_2_0_gir_LIBS = $(gdktargetlib)
37
50
 GdkX11_2_0_gir_FILES = $(x11_introspection_files)
38
51
+GdkX11_2_0_gir_EXPORT_PACKAGES = gdk-x11-2.0
39
 
 GdkX11_2_0_gir_CFLAGS = $(INCLUDES) -L$(top_builddir)/gdk -I.. -I$(srcdir)
 
52
 GdkX11_2_0_gir_CFLAGS = $(INCLUDES) -L$(top_builddir)/gdk
40
53
 INTROSPECTION_GIRS += GdkX11-2.0.gir
41
54
 
42
 
Index: gtk+-2.24.3/gtk/Makefile.am
43
 
===================================================================
44
 
--- gtk+-2.24.3.orig/gtk/Makefile.am    2011-03-15 18:00:37.923481796 +1100
45
 
+++ gtk+-2.24.3/gtk/Makefile.am 2011-03-15 18:00:47.964060326 +1100
46
 
@@ -3,6 +3,7 @@
 
55
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
 
56
index 15343df..cf38fe5 100644
 
57
--- a/gtk/Makefile.am
 
58
+++ b/gtk/Makefile.am
 
59
@@ -3,6 +3,7 @@ include $(top_srcdir)/Makefile.decl
47
60
 -include $(INTROSPECTION_MAKEFILE)
48
61
 INTROSPECTION_GIRS =
49
62
 INTROSPECTION_SCANNER_ARGS = \
51
64
        --add-include-path=../gdk
52
65
 INTROSPECTION_COMPILER_ARGS = \
53
66
        --includedir=$(srcdir) \
54
 
@@ -999,11 +1000,11 @@
 
67
@@ -1010,11 +1011,11 @@ introspection_files = \
55
68
     gtktypebuiltins.c
56
69
 
57
70
 Gtk-2.0.gir: $(INTROSPECTION_SCANNER) $(gtktargetlib) $(top_builddir)/gdk/Gdk-2.0.gir Makefile
65
78
 Gtk_2_0_gir_CFLAGS = \
66
79
                $(INCLUDES) \
67
80
                -UGDK_DISABLE_DEPRECATED \
68
 
@@ -1011,6 +1012,7 @@
 
81
@@ -1022,6 +1023,7 @@ Gtk_2_0_gir_CFLAGS = \
69
82
                -DGTK_TEXT_USE_INTERNAL_UNSUPPORTED_API
70
83
 Gtk_2_0_gir_LIBS = $(gtktargetlib)
71
84
 Gtk_2_0_gir_FILES = $(addprefix $(srcdir)/, $(introspection_files))
73
86
 INTROSPECTION_GIRS += Gtk-2.0.gir
74
87
 
75
88
 girdir = $(datadir)/gir-1.0
 
89
-- 
 
90
1.7.5.4
 
91