~ubuntu-branches/ubuntu/raring/hplip/raring

« back to all changes in this revision

Viewing changes to debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch

  • Committer: Package Import Robot
  • Author(s): Mark Purcell
  • Date: 2012-10-06 15:03:44 UTC
  • mfrom: (1.6.1) (20.1.16 quantal)
  • Revision ID: package-import@ubuntu.com-20121006150344-2p3xz26br0t3hu2q
Tags: 3.12.10-1
* New upstream release
  - Fixes "Network scanning fails (Closes: #683033)
* quilt refresh hplip-syslog-fix-debug-messages-to-error.dpatch
* Fix "error in clean build env" updated debian/rules (Closes: #687129)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## hp-systray-make-menu-title-visible-in-sni-qt-indicator.patch.dpatch by  <till.kamppeter@gmail.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
--- a/ui4/systemtray.py
 
9
+++ b/ui4/systemtray.py
 
10
@@ -416,29 +416,11 @@
 
11
     def setMenu(self):
 
12
         self.menu = QMenu()
 
13
 
 
14
-        title = QWidgetAction(self.menu)
 
15
+        title = QAction(self.menu)
 
16
         #title.setDisabled(True)
 
17
-
 
18
-        hbox = QFrame(self.menu)
 
19
-        layout = QHBoxLayout(hbox)
 
20
-        layout.setMargin(3)
 
21
-        layout.setSpacing(5)
 
22
-        pix_label = QLabel(hbox)
 
23
-
 
24
-        layout.insertWidget(-1, pix_label, 0)
 
25
-
 
26
-        icon_size = self.menu.style().pixelMetric(QStyle.PM_SmallIconSize)
 
27
-        pix_label.setPixmap(self.prop_icon.pixmap(icon_size))
 
28
-
 
29
-        label = QLabel(hbox)
 
30
-        layout.insertWidget(-1, label, 20)
 
31
-        title.setDefaultWidget(hbox)
 
32
-
 
33
-        label.setText(self.__tr("HPLIP Status Service"))
 
34
-
 
35
-        f = label.font()
 
36
-        f.setBold(True)
 
37
-        label.setFont(f)
 
38
+        title.setText(self.__tr("HPLIP Status Service"))
 
39
+        title.setIcon(self.prop_icon)
 
40
+        title.setIconVisibleInMenu(True)
 
41
         self.menu.insertAction(None, title)
 
42
 
 
43
         if devices: