~ubuntu-branches/ubuntu/raring/iproute/raring

« back to all changes in this revision

Viewing changes to debian/patches/txtdocs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Wirt, Andreas Henriksson, Justin B Rye, Alexander Wirt
  • Date: 2008-05-11 11:18:29 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20080511111829-rfewew7s6kiev0bh
Tags: 20080417-1
[ Andreas Henriksson ]
* New upstream release, v2.6.25 a.k.a. snapshot 20080417.
  - Initial documentation for xfrm (Partially fixes #451337)
  - Fixes manpage error caught by lintian!
* Fix typos (syntax error) in ip(8) manpage.
  - Introduced by upstream, caught by lintian yet again!
* Don't ship useless headers in iproute-dev (Closes: #467557)
* Cherry-pick "Fix bad hash calculation because of signed address" from
  upstream. (Closes: #480173)

[ Justin B Rye ]
* Update package description (Closes: #464521)

[ Alexander Wirt ]
* Fix typo in short package description.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## txtdocs.dpatch by Andreas Henriksson <andreas@fatal.se>
 
3
## Original author unknown, this was split out to a dpatch
 
4
## from a direct source edit.
 
5
##
 
6
## All lines beginning with `## DP:' are a description of the patch.
 
7
## DP: Add make rules to build documentation in plain text format.
 
8
## DP: This adds a build-dependency on lynx.
 
9
 
 
10
@DPATCH@
 
11
diff -urNad pkg-iproute~/doc/Makefile pkg-iproute/doc/Makefile
 
12
--- pkg-iproute~/doc/Makefile   2008-01-09 21:24:37.000000000 +0100
 
13
+++ pkg-iproute/doc/Makefile    2008-01-09 21:24:46.000000000 +0100
 
14
@@ -14,6 +14,7 @@
 
15
 PAGESPERPAGE=2
 
16
 
 
17
 HTMLFILES=$(subst .sgml,.html,$(shell echo *.sgml))
 
18
+TXTFILES=$(subst .sgml,.txt,$(shell echo *.sgml))
 
19
 DVIFILES=$(subst .ps,.dvi,$(PSFILES))
 
20
 
 
21
 
 
22
@@ -25,6 +26,8 @@
 
23
 
 
24
 dvi: $(DVIFILES)
 
25
 
 
26
+txt: $(TXTFILES)
 
27
+
 
28
 print: $(PSFILES)
 
29
        $(LPR) $(PSFILES)
 
30
 
 
31
@@ -47,9 +50,13 @@
 
32
 %.html: %.sgml
 
33
        $(SGML2HTML) $<
 
34
 
 
35
+%.txt: %.html
 
36
+       lynx -nolist -dump $< > $@
 
37
+               
 
38
+
 
39
 install:
 
40
        install -m 0644 $(shell echo *.tex) $(DESTDIR)$(DOCDIR)
 
41
        install -m 0644 $(shell echo *.sgml) $(DESTDIR)$(DOCDIR)
 
42
 
 
43
 clean:
 
44
-       rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html
 
45
+       rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html $(TXTFILES)