~ubuntu-branches/ubuntu/raring/joystick/raring

« back to all changes in this revision

Viewing changes to debian/patches/fix-as-needed.patch

  • Committer: Bazaar Package Importer
  • Author(s): Stefan Potyra
  • Date: 2010-12-13 23:10:53 UTC
  • Revision ID: james.westby@ubuntu.com-20101213231053-355cq1ck84yaqpe5
Tags: 20051019-12ubuntu1
debian/patches/fix-as-needed.patch: Change linking order to
fix FTBFS with --as-needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: joystick-20051019/utils/Makefile
 
2
===================================================================
 
3
--- joystick-20051019.orig/utils/Makefile       2010-12-13 23:03:37.394719742 +0100
 
4
+++ joystick-20051019/utils/Makefile    2010-12-13 23:05:58.024719744 +0100
 
5
@@ -41,7 +41,7 @@
 
6
        $(RM) *.o *.swp $(PROGRAMS) *.orig *.rej map *~
 
7
 
 
8
 ffcfstress: ffcfstress.c
 
9
-       $(CC) -O2 -funsigned-char -lm ffcfstress.c -o ffcfstress
 
10
+       $(CC) -O2 -funsigned-char ffcfstress.c -lm -o ffcfstress
 
11
 
 
12
 ffmvforce.o: ffmvforce.c
 
13
        $(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
 
14
@@ -54,7 +54,7 @@
 
15
 jscal.o: jscal.c axbtnmap.h
 
16
 
 
17
 jscal: jscal.o axbtnmap.o
 
18
-       $(CC) $(CFLAGS) $(CPPFLAGS) -lm $^ -o $@
 
19
+       $(CC) $(CFLAGS) $(CPPFLAGS) $^ -lm -o $@
 
20
 
 
21
 jstest.o: jstest.c axbtnmap.h
 
22
 
 
23
@@ -64,7 +64,7 @@
 
24
        $(CC) $(CFLAGS) $(CPPFLAGS) gencodes.c -o gencodes
 
25
 
 
26
 acceltest: acceltest.c
 
27
-       $(CC) $(CFLAGS) $(CPPFLAGS) -lm $^ -o $@
 
28
+       $(CC) $(CFLAGS) $(CPPFLAGS) $^ -lm -o $@
 
29
 
 
30
 jskeepalive: jskeepalive.c
 
31
        $(CC) $(CFLAGS) $(CPPFLAGS) $^ -o $@