~ubuntu-branches/ubuntu/raring/kiwi/raring

« back to all changes in this revision

Viewing changes to debian/patches/02_avoid_version_checking.patch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Holbach
  • Date: 2007-02-06 09:42:28 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20070206094228-6jyh5ot02vd5r2oy
Tags: 1.9.13-0ubuntu1
* New upstream release:
  - Workaround GtkEntry bug when resizing the size of its GtkWindows. 
  - Include _kiwi.c in tarball, fixes build.
  - Use pkg-config to find pygtk version.
* debian/control:
  - added pkg-config to Build-Depends.
* debian/patches/02_avoid_version_checking.diff:
  - updated.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nur kiwi-1.9.13/setup.py kiwi-1.9.13.new/setup.py
 
2
--- kiwi-1.9.13/setup.py        2007-02-01 18:16:12.000000000 +0100
 
3
+++ kiwi-1.9.13.new/setup.py    2007-02-06 10:04:14.000000000 +0100
 
4
@@ -25,17 +25,6 @@
 
5
 # Build a helper module for testing on gtk+ versions lower than 2.10.
 
6
 # Don't build it on windows due to easy availability compilers and
 
7
 # the lack of pkg-config.
 
8
-if sys.platform != 'win32':
 
9
-    version = commands.getoutput('pkg-config pygtk-2.0 --modversion')
 
10
-    if version and map(int, version.split('.')) < [2, 10]:
 
11
-        pkgs = 'gdk-2.0 gtk+-2.0 pygtk-2.0'
 
12
-        cflags = commands.getoutput('pkg-config --cflags %s' % pkgs)
 
13
-        libs = commands.getoutput('pkg-config --libs %s' % pkgs)
 
14
-        include_dirs = [part.strip() for part in cflags.split('-I') if part]
 
15
-        libraries = [part.strip() for part in libs.split('-l') if part]
 
16
-        ext_modules.append(Extension('kiwi/_kiwi', ['kiwi/_kiwi.c'],
 
17
-                                     include_dirs=include_dirs,
 
18
-                                     libraries=libraries))
 
19
 
 
20
 setup(name="kiwi",
 
21
       version=".".join(map(str, kiwi_version)),